Hello,

I have just made a fresh install of the community version of OX6. Which is working fine, besides my syncml extension:

open-xchange-usm 6.20.0.0-20 The Open-Xchange Server USM Bundle
open-xchange-syncml 6.20.0.0-20 The Open-Xchange Server SyncML Bundle


I have followed the installation guide at http://oxpedia.org/wiki/index.php?ti...allation_Guide which apparently seams to be successfully installing the extension on my Ubuntu 11.04 server.

But when I try to sync my android mobile device I get a non descriptive error.

I get following trace via tshark, which apparently shows that my apache is setup correctly and open xchange is responding to it.

7.107813 94.144.63.158 -> 192.168.0.50 HTTP POST /usm-syncml/;jsessionid=7131bc4f1eda4ce09647719355d30fb9.APP1? jvm=APP1 HTTP/1.1 (WBXML 1.2, Public ID: "-//SYNCML//DTD SyncML 1.2//ENmlq\0031.2")
7.107877 192.168.0.50 -> 94.144.63.158 TCP http > 11150 [ACK] Seq=776 Ack=3555 Win=26496 Len=0 TSV=2139744763 TSER=14712712
7.133459 192.168.0.50 -> 94.144.63.158 HTTP HTTP/1.1 200 OK (WBXML 1.2, Public ID: "-//SYNCML//DTD SyncML 1.1//EN")
7.246615 94.144.63.158 -> 192.168.0.50 TCP 11150 > http [ACK] Seq=3555 Ack=1571 Win=8980 Len=0 TSV=14712731 TSER=2139744769
7.277492 94.144.63.158 -> 192.168.0.50 TCP [TCP segment of a reassembled PDU]
7.318145 94.144.63.158 -> 192.168.0.50 TCP [TCP segment of a reassembled PDU]
7.318219 192.168.0.50 -> 94.144.63.158 TCP http > 11150 [ACK] Seq=1571 Ack=5253 Win=32000 Len=0 TSV=2139744815 TSER=14712734
7.318154 94.144.63.158 -> 192.168.0.50 TCP [TCP segment of a reassembled PDU]
7.318249 94.144.63.158 -> 192.168.0.50 HTTP POST /usm-syncml/;jsessionid=7131bc4f1eda4ce09647719355d30fb9.APP1? jvm=APP1 HTTP/1.1 (WBXML 1.2, Public ID: "-//SYNCML//DTD SyncML 1.2//ENmlq\0031.2")
7.318520 192.168.0.50 -> 94.144.63.158 TCP http > 11150 [ACK] Seq=1571 Ack=5525 Win=34752 Len=0 TSV=2139744815 TSER=14712734
7.344624 192.168.0.50 -> 94.144.63.158 HTTP HTTP/1.1 200 OK (WBXML 1.2, Public ID: "-//SYNCML//DTD SyncML 1.1//EN")
7.467959 94.144.63.158 -> 192.168.0.50 TCP [TCP segment of a reassembled PDU]
7.498984 94.144.63.158 -> 192.168.0.50 TCP [TCP segment of a reassembled PDU]
7.499042 192.168.0.50 -> 94.144.63.158 TCP http > 11150 [ACK] Seq=2297 Ack=7173 Win=40192 Len=0 TSV=2139744860 TSER=14712752
7.506320 94.144.63.158 -> 192.168.0.50 TCP [TCP segment of a reassembled PDU]
7.506326 94.144.63.158 -> 192.168.0.50 HTTP POST /usm-syncml?jvm=APP1 HTTP/1.1 (WBXML 1.2, Public ID: "-//SYNCML//DTD SyncML 1.2//ENmlq\0031.2")
7.506484 192.168.0.50 -> 94.144.63.158 TCP http > 11150 [ACK] Seq=2297 Ack=7397 Win=42944 Len=0 TSV=2139744862 TSER=14712752
7.528492 192.168.0.50 -> 94.144.63.158 HTTP HTTP/1.1 200 OK (WBXML 1.2, Public ID: "-//SYNCML//DTD SyncML 1.1//EN")
7.646973 94.144.63.158 -> 192.168.0.50 TCP 11150 > http [ACK] Seq=7397 Ack=2995 Win=12160 Len=0 TSV=14712771 TSER=2139744868
7.746338 94.144.63.158 -> 192.168.0.50 TCP 11150 > http [FIN, ACK] Seq=7397 Ack=2995 Win=12160 Len=0 TSV=14712780 TSER=2139744868
7.746477 192.168.0.50 -> 94.144.63.158 TCP http > 11150 [FIN, ACK] Seq=2995 Ack=7398 Win=42944 Len=0 TSV=2139744922 TSER=14712780
7.806137 94.144.63.158 -> 192.168.0.50 TCP 11150 > http [ACK] Seq=7398 Ack=2996 Win=12160 Len=0 TSV=14712787 TSER=2139744922

Looking at the log file of OX i get following

Oct 5, 2011 10:33:20 PM com.openexchange.usm.syncml.servlet.SyncMLRequest retrieveUSMSession
FINE: paul@firkloevervej.dk: Authentication failed
Oct 5, 2011 10:33:20 PM com.openexchange.usm.syncml.servlet.SyncMLServlet doPost
FINE: No session: SyncMLRequest([<Put>,<Get>,<Alert>,<Final>]->[<Final>]) executed in 57 ms.
Oct 5, 2011 10:33:24 PM com.openexchange.login.internal.LoginPerformer logLoginRequest
INFO: Loginaul@firkloevervej.dk IP:127.0.0.1 AuthID:bb7ef116-ba59-4d04-b8d9-b51df7e1cb2f Agent:Jakarta Commons-HttpClient/3.1 Client:USM-SyncML(6.20.0.0-4318) Interface:HTTP_JSON Failed.
Oct 5, 2011 10:33:24 PM com.openexchange.usm.ox_json.impl.OXJSONAccessImpl login
FINE: 0:0aul@firkloevervej.dk:SyncML:IMEI:012682007095558 Authentication failed
180005: com.openexchange.usm.api.exceptions.Authentication FailedException: Authentication failed:{"category":1,"error":"Invalid credentials.","error_params":[],"error_id":"-1807559796-690","code":"LGI-0006"}
at com.openexchange.usm.ox_json.impl.OXJSONAccessImpl .performLogin(OXJSONAccessImpl.java:176)
at com.openexchange.usm.ox_json.impl.OXJSONAccessImpl .obtainConnectionData(OXJSONAccessImpl.java:350)
at com.openexchange.usm.ox_json.impl.OXJSONAccessImpl .login(OXJSONAccessImpl.java:121)
at com.openexchange.usm.ox_json.impl.OXJSONAccessServ ice.login(OXJSONAccessService.java:107)
at com.openexchange.usm.session.impl.SessionManagerIm pl.getSession(SessionManagerImpl.java:294)
at com.openexchange.usm.session.impl.SessionManagerSe rvice.getSession(SessionManagerService.java:77)
at com.openexchange.usm.syncml.servlet.SyncMLRequest. retrieveUSMSession(SyncMLRequest.java:274)
at com.openexchange.usm.syncml.servlet.SyncMLRequest. handleRequest(SyncMLRequest.java:144)
at com.openexchange.usm.syncml.servlet.SyncMLServlet. doPost(SyncMLServlet.java:246)
at javax.servlet.http.HttpServlet.service(HttpServlet .java:616)
at javax.servlet.http.HttpServlet.service(HttpServlet .java:689)
at com.openexchange.ajp13.najp.AJPv13RequestHandlerIm pl.doServletService(AJPv13RequestHandlerImpl.java: 523)
at com.openexchange.ajp13.AJPv13Request.response(AJPv 13Request.java:134)
at com.openexchange.ajp13.najp.AJPv13RequestHandlerIm pl.createResponse(AJPv13RequestHandlerImpl.java:33 5)
at com.openexchange.ajp13.najp.AJPv13ConnectionImpl.c reateResponse(AJPv13ConnectionImpl.java:227)
at com.openexchange.ajp13.najp.AJPv13Task.call(AJPv13 Task.java:352)
at java.util.concurrent.FutureTask$Sync.innerRun(Futu reTask.java:334)
at java.util.concurrent.FutureTask.run(FutureTask.jav a:166)
at com.openexchange.threadpool.internal.CustomThreadP oolExecutor$Worker.runTask(CustomThreadPoolExecuto r.java:750)
at com.openexchange.threadpool.internal.CustomThreadP oolExecutor$Worker.run(CustomThreadPoolExecutor.ja va:776)
at java.lang.Thread.run(Thread.java:679)
Oct 5, 2011 10:33:24 PM com.openexchange.usm.syncml.servlet.SyncMLRequest retrieveUSMSession
FINE: paul@firkloevervej.dk: Authentication failed
Oct 5, 2011 10:33:24 PM com.openexchange.usm.syncml.servlet.SyncMLServlet doPost
FINE: No session: SyncMLRequest([<Put>,<Get>,<Alert>,<Final>]->[<Final>]) executed in 162 ms.


Which clearly indicate that I have a authentication problem. But I can se any problems in my user name or password.

My Android syncml account is setup as following:

Url: http://mydomain.dk/usm-syncml
User: user@mydomain.dk
Password: password


/Paul