Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 10 of 10
  1. #1
    Join Date
    Oct 2011
    Posts
    20

    Default Javaskript fehler

    Guten Tag zusammen,

    hab wie manch anderer schon eine Problem mit Javaskript wenn ich OX im browser aufrufen will,

    hier im Forum wurde geraten:

    Schauen ob der Webserver die notwendigen Berechtigungen auf alle Dateien im wwwroot hat
    wie kann ich das machen?

    VG
    Vic

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hallo,

    was ist denn das konkrete Problem? Siehst du eine Fehlerseite? Was steht drauf?

    Gruß

  3. #3
    Join Date
    Oct 2011
    Posts
    20

    Default

    You need to enable JavaScript to access the Open-Xchange Server.

    Für den Zugriff auf den Open-Xchange Server müssen Sie JavaScript aktivieren.
    das steht da. aber javaskript ist natürlich im Browser aktiv

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    okay - das passiert meist wenn die Apache Konfiguration nicht stimmt, im Besonderen mod_rewrite. Bitte prüf nochmal ob du die Konfiguration exakt so vorgenommen hast wie auf OXpedia beschrieben.

    Gruß

  5. #5
    Join Date
    Oct 2011
    Posts
    20

    Default

    Nein hab ich nicht gemacht,

    da virtualhost 80 und 81 bei mir schon belegt ist (und was ich nicht ändern kann/darf). Deswegen habe ich eine weiteren virtualhost erstell (82) und hab eigentlich die OX config für apache daran angepasst. Hab dann nach dem Listener gesagt er soll auch auf 82 achten. Normal sollte das nun klappen, tut es aber nicht. :/

    VG
    Vic

  6. #6
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    hast du in diesem Virtualhost Eintrag dann auch die ox6.conf Datei Incuded? Apache machts ja offenbar richtig und schickt die Anfrage auf Port 82 zur OX. Dort scheint dann aber nicht die gesamte Konfiguration angewandt zu werden.

    Gruß

  7. #7
    Join Date
    Oct 2011
    Posts
    20

    Default

    hm...danke für die antwort!

    wie meinst du das? Bei welcher ox6.conf...?

    Hab in der Apache conf.d den weiteren Port angegeben, dann in "sites-enabled" einen weiteren Virtualhost angelegt und innerhalb dieser dann den Part der von OX zustädig ist gesagt, das er der virtualhost ist den ich neu angelegt habe.

    Muss ich sonst noch irgend wo etwas anpassen? (wenn ja evtl ansagen, wie diese datei sich befindet xD)

    VG
    Vic
    Last edited by Victo; 11-14-2011 at 11:23 AM.

  8. #8
    Join Date
    Oct 2011
    Posts
    20

    Default

    ah

    wenn ich den port mitangeben beim aufrufen, funktionierts, also *:82/ox6/...
    Wie kann ich das machen, das ich es nicht brauche? also nur */ox6/? (wobei * für eine IP-Adresse steht)

    VG
    Vic

  9. #9
    Join Date
    Feb 2008
    Location
    Southern Bavaria - where others spend their vacations :)
    Posts
    129

    Default

    Quote Originally Posted by Victo View Post
    ah
    wenn ich den port mitangeben beim aufrufen, funktionierts, also *:82/ox6/...
    Wie kann ich das machen, das ich es nicht brauche? also nur */ox6/? (wobei * für eine IP-Adresse steht)
    Hallo, nix für ungut, aber: http ist Standard-Port 80. Wenn Du einen anderen nehmen "mußt", mußt Du Dich entweder mit einem redirect auskennen, sofern die Domains unterscheidbar sind, oder die Mitteilung "hey, ich horche woanders, nämlich Port 82" hinnehmen.

    VG, D.K.

  10. #10
    Join Date
    Oct 2011
    Posts
    20

    Default

    Auch dir vielen danke für deine antwort...

    Naja für mich sah das hier wie ein Frage Forum aus, deswegen habe ich hier eine Frage gepostet... und bei den Port 81 muss ich ja auch nicht *:81/x/ machen... aber na gut.

    Wenn noch wer einen Vorschlag für mich hat, würde ich mich sehr freun (Solang er mir hilft)

    VG
    Vic

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •