Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 7 of 7
  1. #1
    jsbach Guest

    Default problem compiling open-xchange-admin

    Hi all,

    i just started my installation of open-xchange und there seems to be a problem with open-xchange-admin from CVS:

    Code:
    Buildfile: build.xml
    
    replacer:
         [copy] Copying 10 files to /tmp/open-xchange-admin
         [exec] /tmp /tmp/open-xchange-admin
         [exec] /tmp/open-xchange-admin
    
    compile:
        [javac] Compiling 72 source files to /tmp/open-xchange-admin/classes
        [javac] /tmp/open-xchange-admin/src/com/openexchange/admin/rmi/extensions/OXUserMailExtension.java:58: no interface expected here
        [javac] public class OXUserMailExtension extends OXUserExtensionInterface {
        [javac]                                          ^
        [javac] Note: /tmp/open-xchange-admin/src/com/openexchange/admin/tools/OXRunner.java uses or overrides a deprecated API.
        [javac] Note: Recompile with -Xlint:deprecation for details.
        [javac] Note: /tmp/open-xchange-admin/src/com/openexchange/admin/tools/PropertyHandler.java uses unchecked or unsafe operations.
        [javac] Note: Recompile with -Xlint:unchecked for details.
        [javac] 1 error
    
    BUILD FAILED
    Unfortunatly i don't know java but this looks like a syntax/logic error?

    Best Regards,

    Sebastian

  2. #2
    Quaestor Guest

    Default

    Quote Originally Posted by jsbach View Post
    Hi all,

    i just started my installation of open-xchange und there seems to be a problem with open-xchange-admin from CVS:

    Code:
    ---->% cut ----
    
    BUILD FAILED
    Unfortunatly i don't know java but this looks like a syntax/logic error?

    Best Regards,

    Sebastian
    Same here. Any suggestions?

    Cheers
    H.

  3. #3
    iojeda Guest

    Default

    Same here. Any suggestions?

  4. #4
    balendonck Guest

    Angry

    Also the same Problem here.

  5. #5
    mogox Guest

    Default if fixed, but i'm not sure

    I change the extends to "implement" like this


    public class OXUserMailExtension implements OXUserExtensionInterface {


    And then I add the interface function

    public String getExtensionName(){
    return "";
    }

    And, I could compile, buy I don't know if that is what the developers want to do. Also I'm not sure what problems I will be creating by using this solution.

    Now, i'm having trouble with the oxinstaller:
    RMI module OXContextPlugin not available on server

    good luck!

    =============================
    Mogox
    http://www.quersystem.com

  6. #6
    iojeda Guest

    Default

    THANKS, is compiled without errors

  7. #7
    tronn Guest

    Default

    Quote Originally Posted by jsbach View Post
    Hi all,

    i just started my installation of open-xchange und there seems to be a problem with open-xchange-admin from CVS:

    Code:
    Buildfile: build.xml
    
    replacer:
         [copy] Copying 10 files to /tmp/open-xchange-admin
         [exec] /tmp /tmp/open-xchange-admin
         [exec] /tmp/open-xchange-admin
    
    compile:
        [javac] Compiling 72 source files to /tmp/open-xchange-admin/classes
        [javac] /tmp/open-xchange-admin/src/com/openexchange/admin/rmi/extensions/OXUserMailExtension.java:58: no interface expected here
        [javac] public class OXUserMailExtension extends OXUserExtensionInterface {
        [javac]                                          ^
        [javac] Note: /tmp/open-xchange-admin/src/com/openexchange/admin/tools/OXRunner.java uses or overrides a deprecated API.
        [javac] Note: Recompile with -Xlint:deprecation for details.
        [javac] Note: /tmp/open-xchange-admin/src/com/openexchange/admin/tools/PropertyHandler.java uses unchecked or unsafe operations.
        [javac] Note: Recompile with -Xlint:unchecked for details.
        [javac] 1 error
    
    BUILD FAILED
    Unfortunatly i don't know java but this looks like a syntax/logic error?

    Best Regards,

    Sebastian

    I allso got the same problem, I downloaded a fresh source from CVS, I was about to do a fresh install on a new machine, im sure that my lib are in order, coz I compiled a previous source code, but now it dont work again.

    Then I tried to do a update on the VM-image, and download from CVS and transfered that files to the Centos box im install on, then open-xchange-admin compiled Okay ????

    Tronn
    Last edited by tronn; 03-18-2007 at 11:54 PM. Reason: New discover ...............

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •