Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 8 of 8
  1. #1
    Join Date
    Nov 2009
    Posts
    135

    Default Hilfe! Update auf 3.0 .. nix geht mehr

    Hallo

    ich habe das Update auf UCS 3.0 gemacht laut Anleitung (natürlich vorher auf einer Testmaschine problemlos getestet). Das Update auf dem Livesystem ist sauber durchgelaufen, aber jetzt geht nix mehr. Anmelden an der Webgui bring den Fehler: Ein Fehler ist aufgetreten. (CTX-0005, 1517683585-279). Mit Thunderbird kann ich mich nicht mehr connecten. Im /var/log/mai.err erscheinen Fehler wie diese:

    Jun 24 13:18:09 sigosmail postfix/trivial-rewrite[23243]: fatal: ldap:ldaptransport(0,lock|fold_fix): table lookup problem
    Jun 24 13:18:11 sigosmail postfix/trivial-rewrite[23244]: fatal: ldap:ldapgroups(0,lock|fold_fix): table lookup problem

    In /var/log/mail.log erscheinen Fehler wie folgt:

    Jun 24 13:19:11 sigosmail postfix/smtpd[22798]: warning: problem talking to service rewrite: Connection reset by peer
    Jun 24 13:19:11 sigosmail postfix/master[2037]: warning: process /usr/lib/postfix/trivial-rewrite pid 24686 exit status 1
    Jun 24 13:19:11 sigosmail postfix/smtpd[22144]: warning: problem talking to service rewrite: Success
    Jun 24 13:19:11 sigosmail postfix/master[2037]: warning: process /usr/lib/postfix/trivial-rewrite pid 24688 exit status 1
    Jun 24 13:19:11 sigosmail postfix/smtpd[22705]: warning: problem talking to service rewrite: Connection reset by peer
    Jun 24 13:19:11 sigosmail postfix/smtpd[4958]: warning: problem talking to service rewrite: Connection reset by peer
    Jun 24 13:19:11 sigosmail postfix/master[2037]: warning: process /usr/lib/postfix/trivial-rewrite pid 24689 exit status 1
    Jun 24 13:19:11 sigosmail postfix/smtpd[4106]: warning: problem talking to service rewrite: Success
    Jun 24 13:19:11 sigosmail postfix/master[2037]: warning: process /usr/lib/postfix/trivial-rewrite pid 24690 exit status 1
    Jun 24 13:19:11 sigosmail postfix/smtpd[23812]: warning: problem talking to service rewrite: Connection reset by peer
    Jun 24 13:19:11 sigosmail postfix/smtpd[23813]: warning: problem talking to service rewrite: Connection reset by peer
    Jun 24 13:19:11 sigosmail postfix/smtpd[24049]: warning: problem talking to service rewrite: Connection reset by peer
    Jun 24 13:19:11 sigosmail postfix/smtpd[24353]: warning: problem talking to service rewrite: Connection reset by peer
    Jun 24 13:19:11 sigosmail postfix/smtpd[24097]: warning: problem talking to service rewrite: Connection reset by peer
    Jun 24 13:19:11 sigosmail postfix/master[2037]: warning: process /usr/lib/postfix/trivial-rewrite pid 24693 exit status 1
    Jun 24 13:19:11 sigosmail postfix/smtpd[24364]: warning: problem talking to service rewrite: Connection reset by peer
    Jun 24 13:19:12 sigosmail postfix/trivial-rewrite[24694]: warning: dict_ldap_lookup: ldaptransport: Search base '' not found: 32: No such object
    Jun 24 13:19:12 sigosmail postfix/trivial-rewrite[24694]: fatal: ldap:ldaptransport(0,lock|fold_fix): table lookup problem

  2. #2
    Join Date
    Nov 2009
    Posts
    135

    Default

    Hallo

    eigene Dummheit: in /etc/univention/templates/files/etc/postfix/main.cf.d/ habe ich Änderungen aus 10_general und 30_maps nicht nachgeführt. Aber ich hatte dann immer noch Probleme, ein Grund: mysqld existierte nicht mehr!! Wieso wurde das gelöscht? Geholfen hat ein "apt-get install mysql-server".

    Probleme, die ich bisher nicht lösen konnte:

    1) alle 30 Minuten kommt eine Fehlermail:
    Subject: Cron <root@sigosmail> [ -x /usr/lib/php5/maxlifetime ] && [ -d /var/lib/php5 ] && find /var/lib/php5/ -type f -cmin +$(/usr/lib/php5/maxlifetime) -delete

    PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/curl.ini on line 1 in Unknown on line 0
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/curl.so' - /usr/lib/php5/20090626/curl.so: cannot open shared object file: No such file or directory in Unknown on line 0

    2: Subject: Cron <root@sigosmail> /usr/sbin/univention-share-replication (failed)

    Cron <root@sigosmail> [ -x /usr/lib/php5/maxlifetime ] && [ -d /var/lib/php5 ] && find /var/lib/php5/ -type f -cmin +$(/usr/lib/php5/maxlifetime) -delete

    Was läuft denn da noch schief?

  3. #3
    Join Date
    Jun 2012
    Posts
    3

    Default

    Hatte einen ähnlichen Fehler:

    Bei mir wurde während des Upgrades meiner OX-ASE von UCS 2.4.4-sec 8 auf UCS 3.0-1 errata 88 das univention-kolab-legacy-schema - Paket automatisch deinstalliert. Ohne dieses wollte der ldap-Server nicht mehr sauber starten, sondern blieb bei der Schema-Prüfung hängen.
    Nachdem ich es manuell wieder installiert habe, geht der ldap-wieder, allerdings hat mein ox 6 in der UMC jetzt auf einmal ein GUI im Design und mit den Logos eines Univention Corporate Server und nicht mehr die OX6-typische Management GUI.


    Grüße

    Thomas Baumann
    Last edited by mpieconomics; 06-25-2012 at 04:36 PM. Reason: Präzisierung des Postings

  4. #4
    Join Date
    Jun 2012
    Posts
    4

    Default Hallo,

    Punkt 1) könnten Installationsreste sein.

    bei uns mußte nur die curl.ini gelöscht werden und apache neu gestartet werden.
    rm /etc/php5/apache2/conf.d/curl.ini
    /etc/init.d/apache2 restart


    Gruß
    rwse

  5. #5

    Default

    Quote Originally Posted by obr View Post
    Hallo

    eigene Dummheit: in /etc/univention/templates/files/etc/postfix/main.cf.d/ habe ich Änderungen aus 10_general und 30_maps nicht nachgeführt. Aber ich hatte dann immer noch Probleme, ein Grund: mysqld existierte nicht mehr!! Wieso wurde das gelöscht? Geholfen hat ein "apt-get install mysql-server".
    Hallo, wir haben scheinbar genau das gleiche Problem hier, identische Fehlermeldungen in den logs.
    Was meinst Du mit "Änderungen nachgeführt"?

    Wir haben das komplette /etc/univention/templates/files/etc/postfix/main.cf.d/ aus der alten Version mal testweise auf den laufenden Server kopiert, aber das hat erstmal nichts gebracht.
    Auch haben wir testweise den Ordner /etc/postfix aus der Sicherung in das neue System kopiert, ebenfalls ohne Erfolg.

    Wäre dankbar für Hilfe, da ich nicht genau weiss, was der erste Administrator damals da alles manuell verändert hat.

    Vielen Dank
    Sascha

  6. #6
    Join Date
    Dec 2008
    Posts
    11

    Default

    Leider hat das Update von UCS 2.4.4-7 auf UCS 3.0 ebenfalls meinen OX6-Server "zerlegt" Mein Eindruck laut den Logfiles ist der, dass die Kommunikation zwischen Postfix und LDAP nicht mehr korrekt funktioniert, laut den Logfiles hat postfix hier auch massiv Probleme und Mailversand und Zustellung funktionieren gar nicht mehr. Irgendwie scheinen hier massiv Änderungen durch das Update vorgenommen worden zu sein. Alles andere scheint aber zu laufen. Ich musste das ganze aber wieder zurückbauen auf die alte Version. Ich werde die Tage aber mal die Maschine clonen lassen und dann mit dem Clone das Update nochmals durchlaufen und testen lassen.

    Gruß,
    Ralf

  7. #7
    Join Date
    Dec 2008
    Posts
    11

    Default

    So, ich habe das ganze jetzt auf einem VM-Clone durchgeführt mit dem gleichen Ergebnis. /var/log/mail.err und /var/log/mail.log sind voll von LDAP-Fehlern:

    /var/log/mail.err
    Nov 26 09:49:27 odin postfix/cleanup[5193]: fatal: ldap:ldaptransport(0,lock|fold_fix): table lookup problem
    Nov 26 09:50:28 odin postfix/cleanup[5333]: fatal: ldap:ldaptransport(0,lock|fold_fix): table lookup problem

    /var/log/mail.log
    Nov 26 09:50:28 odin postfix/cleanup[5333]: warning: dict_ldap_lookup: ldaptransport: Search base '' not found: 32: No such object
    Nov 26 09:50:28 odin postfix/cleanup[5333]: fatal: ldap:ldaptransport(0,lock|fold_fix): table lookup problem

    slapd läuft, aber offensichtlich funktioniert die Anbindung vom LDAP an postfix nicht mehr.

    Hat überhaupt jemand mal ein Update auf die 3.0er-Version ohne Probleme hinbekommen?

    Gruß,
    Ralf

  8. #8
    Join Date
    Dec 2008
    Posts
    11

    Default

    So, ich habe das Update auf UCS 3 soweit wieder am laufen. Einige wichtige Prozesse wie postfix, amavisd und cyrus/imap liefen nach dem Update nicht mehr. Deswegen als Lösung, was ich hier fixen musste, für Leute, die evtl. mal in die gleichen Probleme laufen:

    1. Cyrus imapd/pop3d startet nicht mehr mit Fehlermeldung

    FATAL: option 'loginrealms' was specified twice in config file"

    in /var/log/mail.err

    In der Datei /etc/imapd/imapd.conf taucht der Eintrag "loginrealms" doppelt auf:

    loginrealms: domain.de t1.domain.de t2.domain.de n.domain.de hostname1.domain.de localhost
    loginrealms: domain.de t1.domain.de t2.domain.de n.domain.de hostname1.de localhost hostname2.domain.de t2.domain.de hostname3.domain.de

    Der letzte Eintrag ist falsch und kann gelöscht werden. Der Fehler kommt durch einen Eintrag
    in dem Template-File /etc/univention/templates/files/etc/imapd/imapd.conf (Zeile 55). Wenn der Registry-Eintrag "hosteddomains" Einträge enthält, dann wird "loginrealms" doppelt eingetragen in die imapd.conf und damit startet der cyrus nicht mehr. Ich habe in diesem Fall die brutale Variante gewählt aus dem Template-File den entsprechenden Eintrag auskommentiert:

    if baseConfig.has_key('mail/cyrus/loginrealms') and baseConfig['mail/cyrus/loginrealms'] != '':
    print 'loginrealms: %s' % baseConfig['mail/cyrus/loginrealms']
    if baseConfig.has_key('mail/hosteddomains') and baseConfig['mail/hosteddomains'] != '':
    print 'loginrealms: %s' % baseConfig['mail/hosteddomains']
    else:
    print 'loginrealms: %s' % baseConfig['domainname']
    @!@

    Der Eintrag "if baseConfig.has_key('mail/hosteddomains')" sorgt für den doppelten loginrealms-Eintrag. Am besten diesen auskommentieren:

    if baseConfig.has_key('mail/cyrus/loginrealms') and baseConfig['mail/cyrus/loginrealms'] != '':
    print 'loginrealms: %s' % baseConfig['mail/cyrus/loginrealms']
    #if baseConfig.has_key('mail/hosteddomains') and baseConfig['mail/hosteddomains'] != '':
    # print 'loginrealms: %s' % baseConfig['mail/hosteddomains']
    else:
    print 'loginrealms: %s' % baseConfig['domainname']
    @!@

    2. cyrus/imap Fehlermeldung

    In /var/log/mail.err tauchen viele Fehlermeldungen auf:

    odin cyrus/imap[32619]: ldap simple bind to ox6server.domain.de with failed

    Verbindungen funktionieren aber per imap und imaps (Mailclient und WebGUI). Hier habe ich noch keine Lösung gefunden, da aber alles soweit funktioniert, sehe ich diese Meldung erstmal nicht so kritisch.


    3. Amavis startet nicht mehr mit Fehlermeldung

    Wird amavisd gestartet, kommt es zu folgender Fehlermeldung:

    root@ox6server:/etc/amavis# (OX6Test) /etc/init.d/amavis restart
    Stopping amavisd: amavisd-new.
    Starting amavisd: Error in config file "/etc/amavis/conf.d/30-template_localization": Can't open file /etc/amavis/de_DE/charset for reading: Datei oder Verzeichnis nicht gefunden at /usr/sbin/amavisd-new line 2658.
    (failed).

    Grund ist ein Verweis auf "de_DE" in der Config-Datei. Abhilfe: Einen Softlink machen für dieses Verzeichnis im Verzeichnis /etc/amavis/

    root@ox6server:/etc/amavis# (OX6Test) ln -s de_DE.outdated_for_2.3.3-2 de_DE
    root@ox6server:/etc/amavis# (OX6Test) ls -l
    insgesamt 16
    drwxr-xr-x 2 root root 4096 27. Nov 10:57 conf.d
    lrwxrwxrwx 1 root root 26 27. Nov 11:14 de_DE -> de_DE.outdated_for_2.3.3-2
    drwxr-xr-x 2 root root 4096 21. Nov 16:06 de_DE.outdated_for_2.3.3-2
    drwxr-xr-x 2 root root 4096 21. Nov 16:06 en_US
    -rw-r--r-- 1 root root 978 8. Jan 2010 README.l10n

    und amavisd neu starten

    4. postfix startet nicht mehr

    Postfix startet nicht mehr wegen LDAP-Probleme. Das Logfile /var/log/mail.err ist voll von Einträgen:
    postfix/trivial-rewrite[22383]: fatal: ldap:ldaptransport(0,lock|fold_fix): table lookup problem

    Problem hier ist ein fehlerhafter Eintrag in der Postfix-Config /etc/postfix/main.cf

    transport_maps = hash:/etc/postfix/transport, ldap:ldaptransport

    Wird dieser Eintrag korrigiert auf

    transport_maps = hash:/etc/postfix/transport, ldap:/etc/postfix/ldap.transport

    und der Postfix neu gestartet, funktioniert auch wieder die SMTP-Verbindung. Hier ist im Template-File
    "/etc/univention/templates/files/etc/postfix/main.cf.d/10_general" ein Fehler. Der Eintrag

    transport_maps = hash:/etc/postfix/transport, ldap:ldaptransport

    sollte auf

    transport_maps = hash:/etc/postfix/transport, ldap:/etc/postfix/ldap.transport

    korrigiert werden.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •