Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 4 of 4
  1. #1
    Join Date
    Jul 2012
    Posts
    5

    Default prepare migration under different domain: CTX-0010

    Hi,

    I'm preparing and testing my initial migration to OX.
    I can not use my real domain, usegroup.de, because this is of course still MX of my old system and I want to migrate my email with relatively little downtime. So I set up the server with FQDN mail.usegroup.de but I currently use the DNS entries of party04.de. When I now log in into www.party04.de/ox6/ I'll get a Ein Fehler ist aufgetreten. (CTX-0010, -425662330-20), more precisely a CTX-0010 Category=8 Message=Cannot find context "usegroup.de". exceptionID=-1311572052-46.

    Questions:
    Can you tell me how to fix or circumvent the error?
    Will this go away when I switch my DNS?
    Do you recommend any other procedure to migrate towards OX with little email downtime? There's ~2GB of mails to be migrated, which takes around 6h.

    What I tried:
    I also changed my /etc/hosts of the server and \windows\system32\drivers\etc\hosts of the client (expecting AJAX) to have the new IP as mail.usegroup.de and usegroup.de and tried logging in to the then-working mail.usegroup.de/ox6/.

    When it worked:
    When I had set up the server for mail.party04.de it worked -- but of course I would not be able to e.g. test the mobile extender or with the latest updates as my license is valid only for usegroup.de

    Steps to reproduce:
    If you want to check yourself just try party04.de/ox6/ with user test and password test12345 .


    Details:

    Info requested from https://forum.open-xchange.com/showt...oblems-or-Bugs are attached as file details.txt



    Thanks a lot!
    Jochen
    Attached Files Attached Files

  2. #2
    Join Date
    Jul 2012
    Posts
    4

    Default

    Hi Jochen,

    if i migrate a Maildomain then i set up the real FQDN like in your case usergroup.de and set up the Host Entries on the System to the IP of the new System so you can test your new System under the real Domain and prepare your migration. On date x you only change the IP of your DNS Record.

  3. #3
    Join Date
    Jul 2012
    Posts
    5

    Default

    Quote Originally Posted by kockiren View Post
    On date x you only change the IP of your DNS Record.
    Thanks. It turned out that the CTX-10 was not related to the system not running on the public IP of the FQDN. The problem persists...

  4. #4
    Join Date
    Jul 2012
    Posts
    5

    Default problem solved

    The server was just too slow, the database was not yet up when the context was to be created. After reinstalling on a RAM-increased VM (2 to 4GB) and doubling the IO performance with cache=writeback (virt-install -v -n openxchange -r 4096 --vcpus=1 --disk pool=ugpool,size=100,cache=writeback --os-type=linux --os-variant=debiansqueeze --network=bridge:br0 -c /kvm/oxase6205-20120625-dvd-amd64.iso --vnc --noautoconsole) the problem disappeared.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •