Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    Join Date
    Jan 2008
    Posts
    140

    Default Mail sent freeze after Update 6.20.6 Rev.3

    Hi,

    we have installed the update today from 6.20.2 -> 6.20.6.
    Everything worked fine, no errors, but NO USER can sent an email!
    The window of the new mail does nothing ..

    Any idea ?

    Bye, Peer

  2. #2
    Join Date
    Jan 2008
    Posts
    140

    Default

    I see the following error message:

    Jul 19, 2012 11:42:22 AM com.openexchange.log.internal.LoggerTask call
    SEVERE: Logged at: com.openexchange.ajp13.najp.AJPv13Task.call(AJPv13 Task.java:448)
    AJP-0001 Category=7 Message=javax/security/auth/Subject exceptionID=-594428836-81392
    Throwable occurred: AJP-0001 Category=7 Message=javax/security/auth/Subject exceptionID=-594428836-81392
    at com.openexchange.ajp13.najp.AJPv13Task.call(AJPv13 Task.java:446)
    at java.util.concurrent.FutureTask$Sync.innerRun(Futu reTask.java:303)
    at java.util.concurrent.FutureTask.run(FutureTask.jav a:138)
    at com.openexchange.threadpool.internal.CustomThreadP oolExecutor$Worker.runTask(CustomThreadPoolExecuto r.java:781)
    at com.openexchange.threadpool.internal.CustomThreadP oolExecutor$Worker.run(CustomThreadPoolExecutor.ja va:807)
    at java.lang.Thread.run(Thread.java:736)
    Caused by: java.lang.NoClassDefFoundError: javax/security/auth/Subject
    at com.openexchange.smtp.SMTPTransport.getSMTPSession (SMTPTransport.java:308)
    at com.openexchange.smtp.SMTPTransport.sendMailMessag e(SMTPTransport.java:646)
    at com.openexchange.mail.transport.MailTransport.send MailMessage(MailTransport.java:155)
    at com.openexchange.mail.MailServletInterfaceImpl.sen dMessage(MailServletInterfaceImpl.java:2329)
    at com.openexchange.ajax.Mail.action(Mail.java:5045)
    at com.openexchange.ajax.AJAXServlet.fireUploadEvent( AJAXServlet.java:842)
    at com.openexchange.ajax.Mail.doPost(Mail.java:4915)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:727)
    at com.openexchange.ajax.AJAXServlet.service(AJAXServ let.java:429)
    at com.openexchange.ajax.SessionServlet.service(Sessi onServlet.java:257)
    at com.openexchange.ajax.PermissionServlet.service(Pe rmissionServlet.java:82)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at com.openexchange.ajp13.najp.AJPv13RequestHandlerIm pl.doServletService(AJPv13RequestHandlerImpl.java: 563)
    at com.openexchange.ajp13.AJPv13Request.response(AJPv 13Request.java:138)
    at com.openexchange.ajp13.najp.AJPv13RequestHandlerIm pl.createResponse(AJPv13RequestHandlerImpl.java:36 5)
    at com.openexchange.ajp13.najp.AJPv13ConnectionImpl.c reateResponse(AJPv13ConnectionImpl.java:224)
    at com.openexchange.ajp13.najp.AJPv13Task.call(AJPv13 Task.java:394)
    ... 5 more
    Jul 19, 2012 11:42:26 AM com.openexchange.log.internal.LoggerTask call
    WARNING: Logged at: com.openexchange.imap.entity2acl.CyrusEntity2ACL.g etUserIDInternal(CyrusEntity2ACL.java:178)
    Found multiple users with login "pkoch" subscribed to IMAP server "mail.bgc-jena.mpg.de/141.5.16.49:143": [2, 592]

  3. #3
    Join Date
    Jan 2008
    Posts
    140

    Default

    Caused by: java.lang.NoClassDefFoundError: javax/security/auth/Subject

    seems to be related to Change #1072 (page 6) update JavaMail library from 1.4.3 -> 1.4.5

    I've change in
    mail.properties
    mail.debug=true

    But where is the log ?
    Where can I trace which java applets are loaded ?

    OK found it ox-console log.

    Thanks and bye,
    Peer
    Last edited by peko; 07-19-2012 at 04:15 PM.

  4. #4
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    What java vm are you using and what linux version?
    OXpedia.org - the answer to almost all questions.

  5. #5
    Join Date
    Jan 2008
    Posts
    140

    Default

    Sorry: SLES 11 SP1 (x86_64)
    java java-1_6_0-ibm-1.6.0_sr10.1-0.3.1
    open-xchange-6.20.6.0-3_7.1

    We are doing a backup every day. Can I stop everything and restore the files from the previous release (from the backup) ?
    Normally my vacation would start tomorrow ... ;(

    I've checked various things. All jar files within the folder structure are new. All open-xchange rpm's are at the newest level.
    Only sending mails is not working. Everything else (imap is working) is fine.

    Bye, Peer

  6. #6
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    we are working on the issue
    OXpedia.org - the answer to almost all questions.

  7. #7
    Join Date
    Jan 2008
    Posts
    140

    Default

    Hi,

    it was a problem of IBM Java <-> open-xchange-smtp.rpm. I've got a patched rpm which is working now.
    Good work from the OX-team. Thank you!

    Bye, Peer

  8. #8
    Join Date
    Oct 2009
    Posts
    13

    Default

    Hi,

    got the same Problem here. Can i have that patched rpm too ?

  9. #9
    Join Date
    Jan 2008
    Posts
    140

    Default

    Look into your mbox

  10. #10
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    The fix has already been synced to software.o.c.
    An announcement will follow asap.
    OXpedia.org - the answer to almost all questions.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •