Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 3 of 3
  1. #1

    Question Kein Mailversand möglich mit 6.20.6

    Nachdem ich für eine geplante Neuinstallation wegen notwendigem Update von SLES 10 auf SLES 11 (danke! ) zunächst mit 6.20.4 installiert hatte, unter dem eigentlich alles im Test einwandfrei lief, hatte ich im Rahmen der weiteren Testphase beim Kunden auch die nachfolgenden Updates durchgezogen, um nicht gleich im neuen System mit einer veralteten Version zu starten. Leider stellt sich nun - nach erfolgter Migration der Daten in das neue System - heraus, daß der Mailversand nicht mehr funktioniert. Dies ist offensichtlich im Rahmen eines der Updates seit 6.20.4 "kaputt gegangen" ... das Mailfenster bleibt nach dem Senden klicken stehen, der Warte-Kreis läuft dauerhaft, und im Logfile kommt dieser Fehler:

    Jul 25, 2012 8:26:43 PM com.openexchange.log.internal.LoggerTask call
    SEVERE: Logged at: com.openexchange.ajp13.coyote.AjpProcessor.process (AjpProcessor.java:868)
    Error processing request: request-URI=''/ajax/mail'', query-string=''action=new&session=78f1769bf0af409e98f0b9 b6cbb0b89b''
    com.openexchange.ajp13.remoteAddress=127.0.0.1
    com.openexchange.ajp13.remotePort=34232
    Throwable occurred: java.lang.NoClassDefFoundError: javax/security/auth/Subject
    at com.openexchange.smtp.SMTPTransport.getSMTPSession (SMTPTransport.java:308)
    at com.openexchange.smtp.SMTPTransport.sendMailMessag e(SMTPTransport.java:646)
    at com.openexchange.mail.transport.MailTransport.send MailMessage(MailTransport.java:155)
    at com.openexchange.mail.MailServletInterfaceImpl.sen dMessage(MailServletInterfaceImpl.java:2329)
    at com.openexchange.ajax.Mail.action(Mail.java:5045)
    at com.openexchange.ajax.AJAXServlet.fireUploadEvent( AJAXServlet.java:842)
    at com.openexchange.ajax.Mail.doPost(Mail.java:4915)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:727)
    at com.openexchange.ajax.AJAXServlet.service(AJAXServ let.java:429)
    at com.openexchange.ajax.SessionServlet.service(Sessi onServlet.java:257)
    at com.openexchange.ajax.PermissionServlet.service(Pe rmissionServlet.java:82)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at com.openexchange.ajp13.coyote.AjpProcessor.process (AjpProcessor.java:832)
    at com.openexchange.ajp13.coyote.sockethandler.Coyote Task.call(CoyoteTask.java:184)
    at java.util.concurrent.FutureTask$Sync.innerRun(Futu reTask.java:314)
    at java.util.concurrent.FutureTask.run(FutureTask.jav a:149)
    at com.openexchange.threadpool.internal.CustomThreadP oolExecutor$Worker.runTask(CustomThreadPoolExecuto r.java:781)
    at com.openexchange.threadpool.internal.CustomThreadP oolExecutor$Worker.run(CustomThreadPoolExecutor.ja va:807)
    at java.lang.Thread.run(Thread.java:736)

    Ich habe schon die Release Docs zu den beiden Updates durchgeschaut, kann aber nichts entdecken, was ich im Rahmen der Updates ggf. hätte anpassen müssen ... habe ich dennoch etwas übersehen, oder ist die Funktion derzeit einfach kaputt? Gibt es etwas, was ich kurzfristig machen kann, um das System wieder betriebsbereit zu bekommen, oder muß ich die ca. 6 Stunden Zeitaufwand (und die zusätzliche Zeit der Fehlersuche) in den Wind schießen und das alte System wieder in Betrieb nehmen?

  2. #2
    Join Date
    Sep 2007
    Location
    Germany
    Posts
    494

    Default

    Welche Versionsnummer hat open-xchange-smtp?

    Soll:
    ox:~ # rpm -q open-xchange-smtp
    open-xchange-smtp-6.20.6.0-4_5.1

  3. #3

    Default

    Update: Eben noch den Thread https://forum.open-xchange.com/showt...e-6-20-6-Rev-3 gefunden, nach erneutem zypper ref/up kam dann doch das neue smtp-Paket, das den Fehler behebt ...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •