Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2012
    Posts
    5

    Default Web Interface Install Issues

    Hi All,

    Having an issue getting the GUI working on a separate server. I get the web interface login screen and upon logging in I'm getting a 503 - Service Unavailable error. I checked the httpd logs on the GUI server and found the following errors in the logs:

    Code:
    [Wed Aug 15 10:45:20 2012] [error] (111)Connection refused: proxy: AJP: attempt to connect to IP_OF_BACKEND_SERVER:8009 (172.16.10.40) failed
    [Wed Aug 15 10:45:20 2012] [error] ap_proxy_connect_backend disabling worker for (IP_OF_BACKEND_SERVER)
    [Wed Aug 15 10:45:20 2012] [error] proxy: AJP: failed to make connection to backend: IP_OF_BACKEND_SERVER
    Checking the httpd logs on the backend server reveals no connection attempts. The groupware and admin logs for open-xchange also are blank for this time period.

    My proxy_ajp.conf file is as follows:

    Code:
    <Location /servlet/axis2/services>
        # restrict access to the soap provisioning API
        Order Deny,Allow
        Deny from all
        Allow from 127.0.0.1
        # you might add more ip addresses / networks here
        # Allow from 192.168 10 172.16
    </Location>
    
    LoadModule proxy_ajp_module modules/mod_proxy_ajp.so
    
    <IfModule mod_proxy_ajp.c>
       ProxyRequests Off
       <Proxy balancer://oxcluster>
           Order deny,allow
           Allow from all
           # multiple server setups need to have the hostname inserted instead localhost
           BalancerMember ajp://IP_OF_BACKEND:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=OX1
           # Enable and maybe add additional hosts running OX here
           # BalancerMember ajp://oxhost2:8009 timeout=100  smax=0 ttl=60 retry=60 loadfactor=50 route=OX2
           ProxySet stickysession=JSESSIONID
       </Proxy>
       <Proxy /ajax>
           ProxyPass balancer://oxcluster/ajax
       </Proxy>
       <Proxy /servlet>
           ProxyPass balancer://oxcluster/servlet
       </Proxy>
       <Proxy /infostore>
           ProxyPass balancer://oxcluster/infostore
       </Proxy>
       <Proxy /publications>
           ProxyPass balancer://oxcluster/publications
       </Proxy>
       <Proxy /Microsoft-Server-ActiveSync>
           ProxyPass balancer://oxcluster/Microsoft-Server-ActiveSync
       </Proxy>
       <Proxy /usm-json>
           ProxyPass balancer://oxcluster/usm-json
       </Proxy>
    </IfModule>
    Can anyone help with this issue?

    Thanks,

    -Mike

  2. #2
    Join Date
    Sep 2007
    Location
    Germany
    Posts
    494

    Default

    Is AJP really listening on the external interface?

    Please check with netstat -apn | grep 8009
    and the property AJP_BIND_ADDR in ajp.properties.

  3. #3
    Join Date
    Aug 2012
    Posts
    5

    Default

    Thank you Wolfgang! That was it. I changed the AJP_BIND_ADDR and everything started working properly.

    -Mike

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •