Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 5 of 5
  1. #1
    Join Date
    Aug 2012
    Posts
    4

    Default Problems with sieve connection

    Hi all!

    I have some problem with connection to the sieve server;

    --------------------------------------
    SCHWERWIEGEND: Logged at: com.openexchange.mailfilter.ajax.AJAXServlet.doGet (AJAXServlet.java:160)
    MAIL_FILTER-0014 Category=8 Message=Error in low level connection to sieve server 127.0.0.1 at port 2000 exceptionID=-381530551-7
    com.openexchange.ajp13.remoteAddress=127.0.0.1
    com.openexchange.ajp13.remotePort=40932
    MAIL_FILTER-0014 Category=8 Message=Error in low level connection to sieve server 127.0.0.1 at port 2000 exceptionID=-381530551-7
    at com.openexchange.mailfilter.ajax.actions.Mailfilte rAction.actionConfig(MailfilterAction.java:237)
    at com.openexchange.mailfilter.ajax.actions.Mailfilte rAction.actionConfig(MailfilterAction.java:113)
    at com.openexchange.mailfilter.ajax.actions.AbstractA ction.action(AbstractAction.java:79)
    at com.openexchange.mailfilter.ajax.AJAXServlet.doGet (AJAXServlet.java:158)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:707)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at com.openexchange.ajp13.coyote.AjpProcessor.process (AjpProcessor.java:832)
    at com.openexchange.ajp13.coyote.sockethandler.Coyote Task.call(CoyoteTask.java:184)
    at java.util.concurrent.FutureTask$Sync.innerRun(Futu reTask.java:334)
    at java.util.concurrent.FutureTask.run(FutureTask.jav a:166)
    at com.openexchange.threadpool.internal.CustomThreadP oolExecutor$Worker.runTask(CustomThreadPoolExecuto r.java:781)
    at com.openexchange.threadpool.internal.CustomThreadP oolExecutor$Worker.run(CustomThreadPoolExecutor.ja va:807)
    at java.lang.Thread.run(Thread.java:636)
    Caused by: javax.security.sasl.SaslException: Failure to initialize security context [Caused by GSSException: Invalid name provided (Mechanism level: Could not load configuration file /etc/krb5.conf (No such file or directory))]

    ----------------------------------------------

    but connection to the sieve server should be ok;

    Code:
    root@test:~# telnet 127.0.0.1 2000
    Trying 127.0.0.1...
    Connected to 127.0.0.1.
    Escape character is '^]'.
    "IMPLEMENTATION" "Cyrus timsieved v2.2.13-Debian-2.2.13-19+squeeze3"
    "SASL" "CRAM-MD5 PLAIN LOGIN NTLM DIGEST-MD5 GSSAPI"
    "SIEVE" "fileinto reject envelope vacation imapflags notify subaddress relational comparator-i;ascii-numeric regex"
    OK
    Whats krb5.conf?

    Thanks for any help!

  2. #2
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    Your sieve server offers GSSAPI and because this is the strongest authentication mechanism, open-xchange tries to use that (since it has kerberos support builtin. Just remove the package libsasl2-modules-gssapi-heimdal or libsasl2-modules-gssapi-mit, whatever you
    have installed on your server running sieve, or configure your sieve server to only offer the PLAIN mechanism in capabilities.
    OXpedia.org - the answer to almost all questions.

  3. #3
    Join Date
    Aug 2012
    Posts
    4

    Default

    Quote Originally Posted by Carsten Hoeger View Post
    Your sieve server offers GSSAPI and because this is the strongest authentication mechanism, open-xchange tries to use that (since it has kerberos support builtin. Just remove the package libsasl2-modules-gssapi-heimdal or libsasl2-modules-gssapi-mit, whatever you
    have installed on your server running sieve, or configure your sieve server to only offer the PLAIN mechanism in capabilities.
    Hi Carsten

    Sorry for my late answer and thank a lot for your help. That was exactly my problem!

  4. #4
    Join Date
    Dec 2012
    Posts
    2

    Default

    An how to get rid of the error without to disable GSSAPI? I am using GSSAPI when connecting to the server from another clients.
    BTW: The fallback to another mechanizms worked before (don't remember in which version), but since some update it doesn't.
    Last edited by MaT; 12-05-2012 at 02:01 PM.

  5. #5
    Join Date
    Dec 2012
    Posts
    2

    Default

    After update to 6.22 there is a com.openexchange.mail.filter.preferGSSAPI=false (default), which solves the problem for me.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •