Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 4 of 4
  1. #1
    sulung Guest

    Default net.freeutils.charset problem on

    First, I'am sorry for my poor English.

    I use Debian Sarge 3.1 x86_64, JDK 1.5.0.13 x86_64 on 2 GB RAM AMD Opteron server.
    I follow OX Hyperion wiki to install my OX.
    A few days ago (Thu Oct 25 & Fri, Oct 26) I have no problem with compiling OX (although I still can't have successful OX installation because some problems).

    While tried to do some "trial error" to get success with my OX installation, suddenly I get this error while recompile OX:

    ox:/tmp/open-xchange# ant -Dlib.dir=/opt/open-xchange/lib install
    Buildfile: build.xml

    prepare:

    patchVersionJava:
    [copy] Copying 1 file to /tmp/open-xchange/src/com/openexchange/server

    compile:
    [javac] Compiling 839 source files to /tmp/open-xchange/build
    [javac] /tmp/open-xchange/src/com/openexchange/charset/AliasCharsetProvider.java:119: package net.freeutils.charset does not exist
    [javac] c = new net.freeutils.charset.CharsetProvider().charsetFor Name(charsetName);
    [javac] ^
    [javac] Note: Some input files use or override a deprecated API.
    [javac] Note: Recompile with -Xlint:deprecation for details.
    [javac] Note: Some input files use unchecked or unsafe operations.
    [javac] Note: Recompile with -Xlint:unchecked for details.
    [javac] 1 error

    BUILD FAILED
    /tmp/open-xchange/build.xml:114: Compile failed; see the compiler error output for details.

    Total time: 25 seconds

    All libs (*jar) are exactly the same as I used before.

    Even I clean reinstall my OS, the same problem still occur.
    Thanks for help.

  2. #2
    user001 Guest

    Default

    Hy Sulug,

    Add in your build.xml, see the 2 Line jcharset
    Downloaw jcharset from http://www.freeutils.net/source/jcharset/
    and copy jcharset to you java lib (/opt/open-xchange/lib)


    <!-- JAR names for classpath -->
    <property name="servletjar" value="servlet-api-2.4.jar" />
    <property name="jdbcjar" value="mysql-connector-java-3.1.13-bin.jar" />
    <property name="mailjar" value="mail.jar" />
    <property name="activationjar" value="activation.jar" />
    <property name="jdomjar" value="jdom.jar" />
    <property name="jcsjar" value="jcs-1.2.7.9.2.jar" />
    <property name="concurrentjar" value="concurrent.jar" />
    <property name="loggingjar" value="commons-logging.jar" />
    <property name="jsonjar" value="json.jar" />
    <property name="fileuploadjar" value="commons-fileupload.jar" />
    <property name="iojar" value="commons-io.jar" />
    <property name="webdavjar" value="jakarta-slide-webdavlib-2.1.jar" />
    <property name="httpclientjar" value="commons-httpclient-2.0.2.jar" />
    <property name="tnefjar" value="tnef.jar" />
    <property name="springbeanjar" value="spring-beans_1.2.7.jar" />
    <property name="springcorejar" value="spring-core_1.2.7.jar" />
    <property name="commonscodecjar" value="commons-codec-1.3.jar" />
    <property name="jcharsetjar" value="jcharset.jar" />

    <!-- Classpath -->
    <path id="project.classpath">
    <pathelement location="${3rdlib}/${servletjar}"/>
    <pathelement location="${3rdlib}/${jdbcjar}"/>
    <pathelement location="${3rdlib}/${mailjar}"/>
    <pathelement location="${3rdlib}/${activationjar}"/>
    <pathelement location="${3rdlib}/${jdomjar}"/>
    <pathelement location="${3rdlib}/${jcsjar}"/>
    <pathelement location="${3rdlib}/${concurrentjar}"/>
    <pathelement location="${3rdlib}/${loggingjar}"/>
    <pathelement location="${3rdlib}/${jsonjar}"/>
    <pathelement location="${3rdlib}/${fileuploadjar}"/>
    <pathelement location="${3rdlib}/${iojar}"/>
    <pathelement location="${3rdlib}/${webdavjar}"/>
    <pathelement location="${3rdlib}/${httpclientjar}"/>
    <pathelement location="${3rdlib}/${tnefjar}" />
    <pathelement location="${3rdlib}/${springbeanjar}" />
    <pathelement location="${3rdlib}/${springcorejar}" />
    <pathelement location="${3rdlib}/${commonscodecjar}" />
    <pathelement location="${3rdlib}/${jcharsetjar}" />


    Greeting from Germany
    Last edited by user001; 10-29-2007 at 10:27 AM.

  3. #3
    sulung Guest

    Default

    OK, it works now
    Thank you very very much.
    I will continue my OX installation now.

    Regards,
    Sulung

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    just for your information: this issue has been fixed as of today.

    Greetings

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •