Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    Join Date
    Jan 2013
    Posts
    6

    Question Unable to register - at the installation procces. please advise

    Hi guys, I'm tryin to install OX. now everything went well untill I came to the part where I have to register the server. this step :

    $ /opt/open-xchange/sbin/registerserver -n oxserver -A oxadminmaster -P admin_master_password


    as soon as I do this i get an error :


    root@ubuntu:/# /opt/open-xchange/sbin/registerserver -n oxserver -A oxadminmaster -P admin_master_password
    server could not be registered:
    Server response:
    com.openexchange.admin.rmi.exceptions.PoolExceptio n: SRV-0001 Category=4 Message=The required service com.openexchange.database.DatabaseService is temporary not available. Please try again later. exceptionID=-377067820-2
    at com.openexchange.admin.storage.mysqlStorage.OXTool MySQLStorage.existsServerName(OXToolMySQLStorage.j ava:2094)
    at com.openexchange.admin.storage.mysqlStorage.OXTool MySQLStorage.existsServerName(OXToolMySQLStorage.j ava:2118)
    at com.openexchange.admin.rmi.impl.OXUtil.registerSer ver(OXUtil.java:396)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:616)
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastSe rverRef.java:322)
    at sun.rmi.transport.Transport$1.run(Transport.java:1 77)
    at java.security.AccessController.doPrivileged(Native Method)
    at sun.rmi.transport.Transport.serviceCall(Transport. java:173)
    at sun.rmi.transport.tcp.TCPTransport.handleMessages( TCPTransport.java:553)
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er.run0(TCPTransport.java:808)
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er.run(TCPTransport.java:667)
    at java.util.concurrent.ThreadPoolExecutor.runWorker( ThreadPoolExecutor.java:1110)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:603)
    at java.lang.Thread.run(Thread.java:679)
    at sun.rmi.transport.StreamRemoteCall.exceptionReceiv edFromServer(StreamRemoteCall.java:273)
    at sun.rmi.transport.StreamRemoteCall.executeCall(Str eamRemoteCall.java:251)
    at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:1 60)
    at java.rmi.server.RemoteObjectInvocationHandler.invo keRemoteMethod(RemoteObjectInvocationHandler.java: 194)
    at java.rmi.server.RemoteObjectInvocationHandler.invo ke(RemoteObjectInvocationHandler.java:148)
    at $Proxy0.registerServer(Unknown Source)
    at com.openexchange.admin.console.util.server.Registe rServer.<init>(RegisterServer.java:84)
    at com.openexchange.admin.console.util.server.Registe rServer.main(RegisterServer.java:92)


    why m I getting this error ?

    the web gui is already accesable,

    I have also already followed other steps, the creating directory and registring it, all went well until that step,

    at the final step I also get same error :

    this part : /opt/open-xchange/sbin/registerdatabase -A oxadminmaster -P admin_master_password \
    -n oxdatabase -p db_password -m true


    this is same result :

    root@ubuntu:/# /opt/open-xchange/sbin/registerdatabase -A oxadminmaster -P admin_master_password \
    > -n oxdatabase -p db_password -m true
    database could not be registered:
    Server response:
    Database oxdatabase already exists!
    at com.openexchange.admin.rmi.impl.OXUtil.registerDat abase(OXUtil.java:332)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:616)
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastSe rverRef.java:322)
    at sun.rmi.transport.Transport$1.run(Transport.java:1 77)
    at java.security.AccessController.doPrivileged(Native Method)
    at sun.rmi.transport.Transport.serviceCall(Transport. java:173)
    at sun.rmi.transport.tcp.TCPTransport.handleMessages( TCPTransport.java:553)
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er.run0(TCPTransport.java:808)
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er.run(TCPTransport.java:667)
    at java.util.concurrent.ThreadPoolExecutor.runWorker( ThreadPoolExecutor.java:1110)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:603)
    at java.lang.Thread.run(Thread.java:679)
    at sun.rmi.transport.StreamRemoteCall.exceptionReceiv edFromServer(StreamRemoteCall.java:273)
    at sun.rmi.transport.StreamRemoteCall.executeCall(Str eamRemoteCall.java:251)
    at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:1 60)
    at java.rmi.server.RemoteObjectInvocationHandler.invo keRemoteMethod(RemoteObjectInvocationHandler.java: 194)
    at java.rmi.server.RemoteObjectInvocationHandler.invo ke(RemoteObjectInvocationHandler.java:148)
    at $Proxy0.registerDatabase(Unknown Source)
    at com.openexchange.admin.console.util.database.Regis terDatabase.<init>(RegisterDatabase.java:88)
    at com.openexchange.admin.console.util.database.Regis terDatabase.main(RegisterDatabase.java:97)



    what is wrong ?

    please help / advise what to do.


    I also get error if I go further with creating context users I get same error.

    it says cannot create context. is same error I gues :

    root@ubuntu:/# /opt/open-xchange/sbin/createcontext -A oxadminmaster -P admin_master_password -c 1 -u oxadmin -d "Context Admin" -g Admin -s User -p admin_password -L defaultcontext -e oxadmin@example.com -q 1024 --access-combination-name=all
    context 1 could not be created:
    Server response:
    com.openexchange.admin.rmi.exceptions.OXContextExc eption: The new context could not be created. All not full databases can not be connected to.
    at com.openexchange.admin.storage.mysqlStorage.OXCont extMySQLStorage.create(OXContextMySQLStorage.java: 1036)
    at com.openexchange.admin.rmi.impl.OXContext.createma incall(OXContext.java:868)
    at com.openexchange.admin.rmi.impl.OXContextCommonImp l.createcommon(OXContextCommonImpl.java:159)
    at com.openexchange.admin.rmi.impl.OXContext.create(O XContext.java:225)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:616)
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastSe rverRef.java:322)
    at sun.rmi.transport.Transport$1.run(Transport.java:1 77)
    at java.security.AccessController.doPrivileged(Native Method)
    at sun.rmi.transport.Transport.serviceCall(Transport. java:173)
    at sun.rmi.transport.tcp.TCPTransport.handleMessages( TCPTransport.java:553)
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er.run0(TCPTransport.java:808)
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er.run(TCPTransport.java:667)
    at java.util.concurrent.ThreadPoolExecutor.runWorker( ThreadPoolExecutor.java:1110)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:603)
    at java.lang.Thread.run(Thread.java:679)
    at sun.rmi.transport.StreamRemoteCall.exceptionReceiv edFromServer(StreamRemoteCall.java:273)
    at sun.rmi.transport.StreamRemoteCall.executeCall(Str eamRemoteCall.java:251)
    at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:1 60)
    at java.rmi.server.RemoteObjectInvocationHandler.invo keRemoteMethod(RemoteObjectInvocationHandler.java: 194)
    at java.rmi.server.RemoteObjectInvocationHandler.invo ke(RemoteObjectInvocationHandler.java:148)
    at $Proxy0.create(Unknown Source)
    at com.openexchange.admin.console.context.Create.main call(Create.java:126)
    at com.openexchange.admin.console.context.CreateCore. commonfunctions(CreateCore.java:140)
    at com.openexchange.admin.console.context.Create.<ini t>(Create.java:77)
    at com.openexchange.admin.console.context.Create.main (Create.java:81)


    please help, any help is much much aprisciated.

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    this "com.openexchange.database.DatabaseService" error is temporary and should resolve itself after OX is fully started. No need to re-create any databases. Does it still happens after waiting a minute or two?

    Greetings
    Martin

  3. #3
    Join Date
    Jan 2013
    Posts
    6

    Default

    Well this happens even after a night of sleep i turned off the server (its a fisical dual xeon with 4gb) test server, and next day I satarted where i left. and still same.
    I can acces the web part, it asks user pass, I dont know what to put in there, any standart user pass is not accepted.
    So I gues all steps must be done before I'll be able to login ? Cause OX is running, if I check the service its running.
    Last edited by turalo; 01-28-2013 at 07:24 PM.

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    okay, please check if there are any bundles not ACTIVE when executing /opt/open-xchange/sbin/listbundles
    Also please clean up the log files at /var/log/open-xchange, restart the open-xchange service and check if there are any entries at the console.log and osgi.log file.

    Cheers
    Martin

  5. #5
    Join Date
    Jan 2013
    Posts
    6

    Default

    Done as you said, all bundles are active,

    and after restart nothing is in the logs.

    now the register part telling me that it's already registred. Now only 2 problems left :


    the part with : Creating contexts and users

    $ /opt/open-xchange/sbin/createcontext -A oxadminmaster -P admin_master_password -c 1 \
    -u oxadmin -d "Context Admin" -g Admin -s User -p admin_password -L defaultcontext \
    -e oxadmin@example.com -q 1024 --access-combination-name=all


    and


    $ /opt/open-xchange/sbin/createuser -c 1 -A oxadmin -P admin_password -u testuser \
    -d "Test User" -g Test -s User -p secret -e testuser@example.com \
    --imaplogin testuser --imapserver 127.0.0.1 --smtpserver 127.0.0.1

    here is the result ------------------

    root@ubuntu:/# /opt/open-xchange/sbin/createcontext -A oxadminmaster -P admin_master_password -c 1 \
    > -u oxadmin -d "Context Admin" -g Admin -s User -p admin_password -L defaultcontext \
    > -e oxadmin@example.com -q 1024 --access-combination-name=all
    context 1 could not be created:
    Server response:
    com.openexchange.admin.rmi.exceptions.OXContextExc eption: The new context could not be created. All not full databases can not be connected to.
    at com.openexchange.admin.storage.mysqlStorage.OXCont extMySQLStorage.create(OXContextMySQLStorage.java: 1036)
    at com.openexchange.admin.rmi.impl.OXContext.createma incall(OXContext.java:868)
    at com.openexchange.admin.rmi.impl.OXContextCommonImp l.createcommon(OXContextCommonImpl.java:159)
    at com.openexchange.admin.rmi.impl.OXContext.create(O XContext.java:225)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:616)
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastSe rverRef.java:322)
    at sun.rmi.transport.Transport$1.run(Transport.java:1 77)
    at java.security.AccessController.doPrivileged(Native Method)
    at sun.rmi.transport.Transport.serviceCall(Transport. java:173)
    at sun.rmi.transport.tcp.TCPTransport.handleMessages( TCPTransport.java:553)
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er.run0(TCPTransport.java:808)
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er.run(TCPTransport.java:667)
    at java.util.concurrent.ThreadPoolExecutor.runWorker( ThreadPoolExecutor.java:1110)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:603)
    at java.lang.Thread.run(Thread.java:679)
    at sun.rmi.transport.StreamRemoteCall.exceptionReceiv edFromServer(StreamRemoteCall.java:273)
    at sun.rmi.transport.StreamRemoteCall.executeCall(Str eamRemoteCall.java:251)
    at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:1 60)
    at java.rmi.server.RemoteObjectInvocationHandler.invo keRemoteMethod(RemoteObjectInvocationHandler.java: 194)
    at java.rmi.server.RemoteObjectInvocationHandler.invo ke(RemoteObjectInvocationHandler.java:148)
    at $Proxy0.create(Unknown Source)
    at com.openexchange.admin.console.context.Create.main call(Create.java:126)
    at com.openexchange.admin.console.context.CreateCore. commonfunctions(CreateCore.java:140)
    at com.openexchange.admin.console.context.Create.<ini t>(Create.java:77)
    at com.openexchange.admin.console.context.Create.main (Create.java:81)




    thanks for your help.

  6. #6
    Join Date
    Jan 2013
    Posts
    6

    Default

    Please guys, help me out with this.

  7. #7
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Please post the output of sbin/listdatabases.

  8. #8
    Join Date
    Jan 2013
    Posts
    6

    Default

    root@ubuntu:/opt/open-xchange/sbin# listdatabase
    databases could not be listed:
    Server response:
    Authentication failed
    at com.openexchange.admin.rmi.impl.BasicAuthenticator .doAuthentication(BasicAuthenticator.java:152)
    at com.openexchange.admin.rmi.impl.OXUtil.listDatabas e(OXUtil.java:460)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:616)
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastSe rverRef.java:322)
    at sun.rmi.transport.Transport$1.run(Transport.java:1 77)
    at java.security.AccessController.doPrivileged(Native Method)
    at sun.rmi.transport.Transport.serviceCall(Transport. java:173)
    at sun.rmi.transport.tcp.TCPTransport.handleMessages( TCPTransport.java:553)
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er.run0(TCPTransport.java:808)
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er.run(TCPTransport.java:667)
    at java.util.concurrent.ThreadPoolExecutor.runWorker( ThreadPoolExecutor.java:1110)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:603)
    at java.lang.Thread.run(Thread.java:679)
    at sun.rmi.transport.StreamRemoteCall.exceptionReceiv edFromServer(StreamRemoteCall.java:273)
    at sun.rmi.transport.StreamRemoteCall.executeCall(Str eamRemoteCall.java:251)
    at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:1 60)
    at java.rmi.server.RemoteObjectInvocationHandler.invo keRemoteMethod(RemoteObjectInvocationHandler.java: 194)
    at java.rmi.server.RemoteObjectInvocationHandler.invo ke(RemoteObjectInvocationHandler.java:148)
    at $Proxy0.listDatabase(Unknown Source)
    at com.openexchange.admin.console.util.database.ListD atabase.<init>(ListDatabase.java:86)
    at com.openexchange.admin.console.util.database.ListD atabase.main(ListDatabase.java:142)



    auth fail it says... my db is on a standart user root and pass 12345678 it's local test db, no acces from outside. but also I have addes openxchange user an priviliged it to all rights with pass 12345678

  9. #9
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Well, you need to supply adminmaster credentials if you've authentication enabled. Same story as registerserver etc. Please check the listdatabase -h output on how to use the tool.

  10. #10
    Join Date
    Jan 2013
    Posts
    6

    Default

    Martin thank you for your time and help. I now understand why I got all this problem.
    The problem was my MYSQL password, by default the install procedure expects that MYSQL has no password. that's why I got this issius, somewhere on the way I remember even setting the passwords in the settings in one of the files, but that helped only for a part not for all. So what I did is ismple because this was a test server and at home, I just formated it again with ubuntu DVD installed all from zero and this time I didnot set the MYSQL password, all procedures went well from start to the end.
    Now I have a working interface and I gues a working OX.
    I'll play with it a bit, to see if it can be usifull in my situation. If yes I'll get littel more deeper to it, and install it with the secure method with passwords etc...

    thanks for now.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •