Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    mayank Guest

    Default OX error on Fedora 7

    hi all
    Im getting this error while running oxinstaller scirpt :

    initializing database (step 2/2)
    user in context 1 could not be created:
    Server response:
    com.openexchange.admin.plugins.PluginException: com.openexchange.admin.rmi.exceptions.OXUserIMAPEx ception: javax.mail.AuthenticationFailedException: Login failed: authentication failure
    done

    don't know what is missing as everything (E-mail setup is working fine)...
    Pl'z help !!!!!!

  2. #2

    Default

    Please download the latest version fom the cvs. I think it is the same problem as described under an incident called: "IMAP problem is new Hyperion install"

    http://www.open-xchange.com/forum/sh...=newpost&t=751

    Kind regards
    Michael

  3. #3
    mayank Guest

    Default

    hi.
    i've already downloaded new CVS version.
    I checked that link and i didn't find any solution there as i already have
    new cvs.
    i think some package is missing in FC7 which is present in Debian-based sys.
    as i've already tested on Debian without any error !



    Quote Originally Posted by mmlitz View Post
    Please download the latest version fom the cvs. I think it is the same problem as described under an incident called: "IMAP problem is new Hyperion install"

    http://www.open-xchange.com/forum/sh...=newpost&t=751

    Kind regards
    Michael

  4. #4
    Join Date
    Mar 2007
    Posts
    5

    Default

    Quote Originally Posted by mayank View Post
    hi all
    Im getting this error while running oxinstaller scirpt :

    initializing database (step 2/2)
    user in context 1 could not be created:
    Server response:
    com.openexchange.admin.plugins.PluginException: com.openexchange.admin.rmi.exceptions.OXUserIMAPEx ception: javax.mail.AuthenticationFailedException: Login failed: authentication failure
    done

    don't know what is missing as everything (E-mail setup is working fine)...
    Pl'z help !!!!!!
    cyrus-imapd requires slaslauth. Running "/etc/rc.d/init.d/saslauthd restart" should solve your problem.

  5. #5
    mayank Guest

    Default

    Nothing happened.
    I've restarted all services but same error !!
    Also im not able to see any "Postfix-mysql" pkg discussed in OX Installation Wiki. I've searched for this everywhere.
    Is there any with this name ??


    Quote Originally Posted by arcade View Post
    cyrus-imapd requires slaslauth. Running "/etc/rc.d/init.d/saslauthd restart" should solve your problem.
    Last edited by mayank; 11-05-2007 at 08:14 AM.

  6. #6
    Join Date
    Mar 2007
    Posts
    5

    Default

    Quote Originally Posted by mayank View Post
    Nothing happened.
    I've restarted all services but same error !!
    saslauth cannot find the user. Fedora does not include the pam-mysql libraries, install them from http://pam-mysql.sourceforge.net/.

    Quote Originally Posted by mayank View Post
    Also im not able to see any "Postfix-mysql" pkg discussed in OX Installation Wiki. I've searched for this everywhere.
    Is there any with this name ??
    Same problem here, you must recompile postfix with mysql support (MYSQL is not conditional on the spec)

    Code:
    $ rpm -ihv postfix-2.4.3-2.fc7.src.rpm
    $ perl -pi -e 's/(\%define MYSQL )0/$1 1/' /usr/src/redhat/SPECS/postfix.spec
    $ rpmbuild -bb /usr/src/redhat/SPECS/postfix.spec
    $ rpm -ihv /usr/src/redhat/RPMS/i386/postfix-2.4.3-2.fc7.i386.rpm
    Saludos

  7. #7
    mayank Guest

    Default

    HI
    ur right
    It's prob of not finding users
    i already have Postfix installed
    So only pam_mysql will work or i've to start frm scratch.?


    Quote Originally Posted by arcade View Post
    saslauth cannot find the user. Fedora does not include the pam-mysql libraries, install them from http://pam-mysql.sourceforge.net/.



    Same problem here, you must recompile postfix with mysql support (MYSQL is not conditional on the spec)

    Code:
    $ rpm -ihv postfix-2.4.3-2.fc7.src.rpm
    $ perl -pi -e 's/(\%define MYSQL )0/$1 1/' /usr/src/redhat/SPECS/postfix.spec
    $ rpmbuild -bb /usr/src/redhat/SPECS/postfix.spec
    $ rpm -ihv /usr/src/redhat/RPMS/i386/postfix-2.4.3-2.fc7.i386.rpm
    Saludos

  8. #8
    Join Date
    Mar 2007
    Posts
    5

    Default

    Quote Originally Posted by mayank View Post
    HI
    ur right
    It's prob of not finding users
    i already have Postfix installed
    So only pam_mysql will work or i've to start frm scratch.?
    There's no need to start from scratch, just install pam_mysql, reinstall postfix with mysql support, configure and try again.

    Saludos

  9. #9
    mayank Guest

    Default

    hi
    i've done as per what u said...
    unistalled postfix, installed pam_mysql, then installed postfix and configure postfix
    but nothing happened !!

    Quote Originally Posted by arcade View Post
    There's no need to start from scratch, just install pam_mysql, reinstall postfix with mysql support, configure and try again.

    Saludos

  10. #10
    SoftDux Guest

    Default

    I'm new to Open Exchange, and would like to install it on Fedora Core 7 as well, and would like to know if it will actually work on FC7?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •