Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 10 of 10
  1. #1
    Join Date
    Feb 2013
    Posts
    6

    Question OX6.22 service open-exchange does not start

    Hi,

    For days now I have been trying to install OX6.22 on Debian Squeeze, but I am stuck starting the /etc/init.d/open-xchange service. It will not start and gives back as status: not running. I have been using this guide: http://oxpedia.org/wiki/index.php?ti...Debian_6.0_622

    I checked the java version on the machine and it should be a supported one:
    Code:
    java version "1.6.0_26"
    Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
    Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)

    I have also installe the open-xchange-log4j package, but it gives no log entries in /var/log/messages /var/log/open-xchange/open-xchange.log.0 or -console.log.

    Also the next step in the installation proces: registerserver gives me a java error: connection refused (which makes sense since the service is not running).

    Does anybody have any clues, any help is welcome. Thanks for the help.

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    how much memory does that machine have? What hardware architecture is in use? If the service does not start up, no commands like registerserver can be executed, that's normal.

    Thanks
    Martin

  3. #3
    Join Date
    Feb 2013
    Posts
    6

    Default

    Hi Martin,

    Thanks for your reply. The machine has 512Mb in it, it is a hosted virtual server.

    Could I have set the --servermemory MAX_MEMORY_FOR_JAVAVM incorrectly?

    BTW: I have updated all packages since the official release, so I am on the latest software.

    $ cat /proc/cpuinfo
    processor : 0
    vendor_id : GenuineIntel
    cpu family : 6
    model : 37
    model name : Intel(R) Xeon(R) CPU E5620 @ 2.40GHz
    stepping : 1
    microcode : 0x14
    cpu MHz : 2400.085
    cache size : 12288 KB
    fpu : yes
    fpu_exception : yes
    cpuid level : 11
    wp : yes
    flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss syscall nx rdtscp lm constant_tsc up arch_perfmon pebs bts nopl xtopology tsc_reliable nonstop_tsc aperfmperf pni pclmulqdq ssse3 cx16 sse4_1 sse4_2 popcnt aes hypervisor lahf_lm arat epb dtherm
    bogomips : 4800.17
    clflush size : 64
    cache_alignment : 64
    address sizes : 40 bits physical, 48 bits virtual
    power management:
    Last edited by NilOGrav; 03-21-2013 at 11:46 AM.

  4. #4
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    When you installed the log4j package, it tries to log via syslog.
    This requires syslog to be configured to accept syslog data via network.

    See http://oxpedia.org/wiki/index.php?ti..._Configuration
    OXpedia.org - the answer to almost all questions.

  5. #5
    Join Date
    Feb 2013
    Posts
    6

    Default

    Hi Carsten,

    Thanks for the answer. The link to the guide you've sent, is the one I used also and I have made the prescribed adjustments to the syslog config.

  6. #6
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    You wont find logs in /var/log/open-xchange once you installed the log4j package.
    So as it looks like syslog does not work in your case, I'd suggest to stick with logging without the log4j package.
    Once you got it to work without, you could start trying to use syslog.
    OXpedia.org - the answer to almost all questions.

  7. #7
    Join Date
    Feb 2013
    Posts
    6

    Default

    Hi Carsten,


    I have removed the open-xchange-log4j package (even rebooted), but /etc/init.d/open-xchange still won't start. Status: not running.

    I have set the --servermemory flag at 268435456 (512Mb/2). Result unchanged /etc/init.d/open-xchange still won't start.

    Absolutely no clue also where to find some error/debug info.
    Last edited by NilOGrav; 03-22-2013 at 01:34 PM.

  8. #8
    Join Date
    Feb 2013
    Posts
    6

    Default

    After upgrading to mysql-5.5 I've tried again to start the open-xchange service, but alas no luck. I also have tried to regenerate the oxadmin password and start the service: no luck either.

    I also noticed that the command listbundles gives me a java error of: connection refused (probably since the service is not running).

    Anyhow, still clueless...

  9. #9
    Join Date
    Mar 2013
    Location
    Munich
    Posts
    6

    Default

    Quote Originally Posted by NilOGrav View Post
    After upgrading to mysql-5.5 I've tried again to start the open-xchange service, but alas no luck. I also have tried to regenerate the oxadmin password and start the service: no luck either.

    I also noticed that the command listbundles gives me a java error of: connection refused (probably since the service is not running).

    Anyhow, still clueless...
    Is systemd running on your system and do you start the service with "systemctl start open-xchange" ?
    This did not work on my Opensuse 12.3. I got a service.file as a workaround.
    See
    https://forum.open-xchange.com/showt...s-with-systemd
    and the link there to a correponding opensuse bug.

  10. #10
    Join Date
    Feb 2013
    Posts
    6

    Default

    Hi moenchmeyer,

    Thanks for your help. Checked the solution. Thing is that I'm running debian without systemd.

    Thinking about getting on with my live and do an "apt-get purge open-xchange".

    Chrz!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •