Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 4 of 4
  1. #1
    Join Date
    May 2010
    Location
    Ilmenau
    Posts
    51

    Default CentOS6 Problem after update to OX AppSuite

    Hi,

    i updated my OX server to OX AppSuite.
    I used the howto from oxpedia : http://oxpedia.org/wiki/index.php?ti...22_for_CentOS6 .

    After the update i can connect and use the old OX6 frontend (so i can use the system).
    If i connect to the Appsuite i can login and after that, the system loads ....... .
    In the the logfile i found the following error:

    Login:username IP:myIP AuthID:55eeb05e86274e41b328a77cebe682d2 Agent:Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0 Clientpen-xc
    hange-appsuite(null) Interface:HTTP_JSON Context:1(1,defaultcontext) User:4(username) Session:578fc88699f74f97b8115d77c0e3b499 Random:d62d4749eb554a30bf60da80495d0
    6b1
    Apr 4, 2013 4:20:24 PM com.openexchange.log.internal.LoggerTask call
    SEVERE: Logged at: com.openexchange.ajax.requesthandler.DispatcherSer vlet.handle(DispatcherServlet.java:348)
    com.openexchange.ajax.requestNumber=44
    com.openexchange.ajpv13.remoteAddress=127.0.0.1
    com.openexchange.database.schema=oxdatabase_6
    com.openexchange.session.contextId=1
    com.openexchange.session.userId=4

    Error processing request:
    com.openexchange.ajax.action=list
    com.openexchange.ajax.requestNumber=44
    com.openexchange.ajp13.httpSession=aa29c64a1aa0489 181f41aab80aaacd8.APP1
    com.openexchange.ajpv13.remoteAddress=127.0.0.1
    com.openexchange.ajpv13.remotePort=49603
    com.openexchange.ajpv13.requestIp=myIP
    com.openexchange.ajpv13.requestURI=/ajax/jslob
    com.openexchange.ajpv13.serverName=ox.commitor.de
    com.openexchange.ajpv13.servletPath=/ajax/jslob
    com.openexchange.ajpv13.threadName=AJP-Processor-0000084
    com.openexchange.database.schema=oxdatabase_6
    com.openexchange.session.clientId=open-xchange-appsuite
    com.openexchange.session.session={contextId=1, userId=4, sessionId=578fc88699f74f97b8115d77c0e3b499, login=username, localIp=myIP, authId=55eeb05e86274e41b328a77cebe682d2, hash=JOKU4eBg4qWlmLgFGVa98A, client=open-xchange-appsuite}
    com.openexchange.session.sessionId=578fc88699f74f9 7b8115d77c0e3b499
    com.openexchange.session.userId=4

    JSNCON-0001 Categories=ERROR Message='An unexpected error occurred: null' exceptionID=1037947650-103
    at com.openexchange.exception.OXExceptionFactory.crea te(OXExceptionFactory.java:158)
    at com.openexchange.jslob.JSlobExceptionCodes.create( JSlobExceptionCodes.java:178)
    at com.openexchange.jslob.config.ConfigJSlobService.a ddConfigTreeToJslob(ConfigJSlobService.java:377)
    at com.openexchange.jslob.config.ConfigJSlobService.g et(ConfigJSlobService.java:328)
    at com.openexchange.jslob.json.action.ListAction.perf orm(ListAction.java:113)
    at com.openexchange.jslob.json.action.JSlobAction.per form(JSlobAction.java:135)
    at com.openexchange.ajax.requesthandler.DefaultDispat cher.perform(DefaultDispatcher.java:198)
    at com.openexchange.ajax.requesthandler.DispatcherSer vlet.handle(DispatcherServlet.java:316)
    at com.openexchange.ajax.requesthandler.DispatcherSer vlet.doPut(DispatcherServlet.java:263)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:730)
    at com.openexchange.ajax.AJAXServlet.service(AJAXServ let.java:499)
    at com.openexchange.ajax.SessionServlet.service(Sessi onServlet.java:328)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at com.openexchange.ajp13.coyote.AjpProcessor.process (AjpProcessor.java:912)
    at com.openexchange.ajp13.coyote.sockethandler.Coyote Task.call(CoyoteTask.java:185)
    at java.util.concurrent.FutureTask$Sync.innerRun(Futu reTask.java:334)
    at java.util.concurrent.FutureTask.run(FutureTask.jav a:166)
    at com.openexchange.threadpool.internal.CustomThreadP oolExecutor$Worker.runTask(CustomThreadPoolExecuto r.java:798)
    at com.openexchange.threadpool.internal.CustomThreadP oolExecutor$Worker.run(CustomThreadPoolExecutor.ja va:825)
    at java.lang.Thread.run(Thread.java:679)
    Caused by: java.lang.NullPointerException
    at com.openexchange.groupware.settings.impl.RdbSettin gStorage.readSharedValue(RdbSettingStorage.java:38 6)
    at com.openexchange.groupware.settings.impl.RdbSettin gStorage.readValues(RdbSettingStorage.java:331)
    at com.openexchange.jslob.config.ConfigJSlobService.a ddConfigTreeToJslob(ConfigJSlobService.java:364)
    ... 17 more


    Can anybody reproduce this error or has an solution?
    The system is CentOS 6.4 x86_64.

    Thanks

    Silvio

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi Silvio,

    thanks for reporting. What version OX (backend/frontend) are you using exactly?

    Regards
    Martin

  3. #3
    Join Date
    May 2010
    Location
    Ilmenau
    Posts
    51

    Default

    Hi Martin,

    i updated the system today to the last version. The error still occurs in this release.
    My installed rpms are:
    open-xchange-meta-backend-ox6-7.0.2-7_9.1.noarch
    open-xchange-appsuite-backend-7.0.2-7_9.1.noarch
    open-xchange-gui-l10n-6.22.2-7_7.1.noarch
    open-xchange-gui-login-theme-default-6.22.2-7_7.1.noarch
    open-xchange-gui-wizard-plugin-gui-6.22.2-7_7.1.noarch
    open-xchange-gui-l10n-en-us-6.22.2-7_7.1.noarch
    open-xchange-gui-themes-default-6.22.2-7_7.1.noarch
    open-xchange-gui-6.22.2-7_7.1.noarch
    open-xchange-gui-wizard-plugin-6.22.2-7_7.1.noarch
    open-xchange-gui-loading-theme-default-6.22.2-7_7.1.noarch
    open-xchange-gui-l10n-de-de-6.22.2-7_7.1.noarch
    open-xchange-meta-gui-6.22.1-13_13.1.noarch
    open-xchange-appsuite-l10n-en-us-7.0.1-8.1.noarch
    open-xchange-appsuite-7.0.1-8.1.noarch
    open-xchange-appsuite-l10n-de-de-7.0.1-8.1.noarch

    Silvio

  4. #4
    Join Date
    May 2010
    Location
    Ilmenau
    Posts
    51

    Default

    Hi,

    after the last update to version 7.2 the system is working now.

    Thanks

    Silvio

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •