Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    Join Date
    Mar 2013
    Posts
    13

    Default Connection Error when trying to access OX AppSuite

    Hello,

    I already installed and succesfully configured OpenXchange Server, and now I try to run the OpenXchange AppSuite. I installed it succesfully, but when I try to login it gives me this error : "Connection error. The service is not available right now. Retry". I mention that I already have the user e-mail accounts configured with authentication database.
    Can you help me to use also the OX AppSuite with these accounts ?

    Thanks!

  2. #2
    Join Date
    Sep 2007
    Location
    Germany
    Posts
    494

    Default

    You have the OX6 frontend running already?

    In that case it might be that Apache is not configured for App Suite frontend. The error at least looks like the frontend has issues talking to the backend which most likely misses some Apache configuration _if_ OX6 frontend is running correctly.
    Otherwise it could be anything and you would need to provide more information.

  3. #3
    Join Date
    Mar 2013
    Posts
    13

    Default

    Yes, I have OX6 version 6.22 installed and running.
    I configured apache like in the documentation, with another VirtualHost (with other IP than VirtualHost for OX Server) like that:
    [root@oxa ~]# cat /etc/httpd/conf.d/oxapp.conf
    <VirtualHost oxapp.copeland.ro:80>
    ServerAdmin daniel@copeland.ro
    ServerName oxapp.copeland.ro
    DocumentRoot /var/www/html/
    <Directory /var/www/html/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    RedirectMatch ^/$ /appsuite/
    </Directory>

    <Directory /var/www/html/appsuite>
    Options None +SymLinksIfOwnerMatch
    AllowOverride Indexes FileInfo
    </Directory>

    ErrorLog /var/log/httpd/oxapp_error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog /var/log/httpd/oxapp_access.log combined
    </VirtualHost>

    I need to change other thinks ?

    Thanks!

  4. #4
    Join Date
    Sep 2007
    Location
    Germany
    Posts
    494

    Default

    The proxy_ajp.conf is the more interesting one.
    Does it contain everything mentioned in the documentation?

  5. #5
    Join Date
    Mar 2013
    Posts
    13

    Default

    Hello,

    Yes, it includes this :

    <Location /webservices>
    # restrict access to the soap provisioning API
    Order Deny,Allow
    Deny from all
    Allow from 127.0.0.1
    Allow from 10.20.30
    Allow from 192.168.45
    # you might add more ip addresses / networks here
    # Allow from 192.168 10 172.16
    </Location>
    # the old path is kept for compatibility reasons
    <Location /servlet/axis2/services>
    # restrict access to the soap provisioning API
    Order Deny,Allow
    Deny from all
    Allow from 127.0.0.1
    Allow from 10.20.30
    Allow from 192.168.45
    # you might add more ip addresses / networks here
    # Allow from 192.168 10 172.16
    </Location>

    <IfModule mod_proxy_ajp.c>
    ProxyRequests Off
    <Proxy balancer://oxcluster>
    Order deny,allow
    Allow from all
    # multiple server setups need to have the hostname inserted instead localhost
    BalancerMember ajp://localhost:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=OX1
    # Enable and maybe add additional hosts running OX here
    # BalancerMember ajp://oxhost2:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=OX2
    ProxySet stickysession=JSESSIONID
    </Proxy>
    <Proxy /ajax>
    ProxyPass balancer://oxcluster/ajax
    </Proxy>
    <Proxy /servlet>
    ProxyPass balancer://oxcluster/servlet
    </Proxy>
    <Proxy /infostore>
    ProxyPass balancer://oxcluster/infostore
    </Proxy>
    <Proxy /publications>
    ProxyPass balancer://oxcluster/publications
    </Proxy>
    <Proxy /Microsoft-Server-ActiveSync>
    ProxyPass balancer://oxcluster/Microsoft-Server-ActiveSync
    </Proxy>
    <Proxy /usm-json>
    ProxyPass balancer://oxcluster/usm-json
    </Proxy>
    <Proxy /webservices>
    ProxyPass balancer://oxcluster/webservices
    </Proxy>
    ProxyPass /Microsoft-Server-ActiveSync ajp://127.0.0.1:8009/Microsoft-Server-ActiveSync smax=0 ttl=60 retry=5
    </IfModule>

  6. #6
    Join Date
    Sep 2007
    Location
    Germany
    Posts
    494

    Default

    Please compare with
    http://oxpedia.org/wiki/index.php?ti...igure_services

    Especially
    <Proxy /appsuite/api>
    ProxyPass balancer://oxcluster/ajax
    </Proxy>
    seems to be missing.

  7. #7
    Join Date
    Feb 2007
    Location
    Dortmund, Germany
    Posts
    168

    Default

    Markus Wagner
    Open-Xchange Quality Assurance

  8. #8
    Join Date
    Mar 2013
    Posts
    13

    Default

    Hello,
    I changed it after the note what you tell me about but I still have the error. I restarted the http server and open-xchange. Now I have this configuration for proxy_html.conf :
    <IfModule mod_proxy_ajp.c>
    ProxyRequests Off
    <Proxy balancer://oxcluster>
    Order deny,allow
    Allow from all
    # multiple server setups need to have the hostname inserted instead localhost
    BalancerMember ajp://localhost:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=OX1
    # Enable and maybe add additional hosts running OX here
    # BalancerMember ajp://oxhost2:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=OX2
    ProxySet stickysession=JSESSIONID
    </Proxy>

    # OX AppSuite frontend
    <Proxy /appsuite/api>
    ProxyPass balancer://oxcluster/ajax
    </Proxy>

    # OX6 / Mobile Webinterface frontends
    <Proxy /ajax>
    ProxyPass balancer://oxcluster/ajax
    </Proxy>
    <Proxy /servlet>
    ProxyPass balancer://oxcluster/servlet
    </Proxy>
    <Proxy /infostore>
    ProxyPass balancer://oxcluster/infostore
    </Proxy>
    <Proxy /publications>
    ProxyPass balancer://oxcluster/publications
    </Proxy>

    # USM
    <Proxy /usm-json>
    ProxyPass balancer://oxcluster/usm-json
    </Proxy>

    # SOAP
    <Proxy /webservices>
    ProxyPass balancer://oxcluster/webservices
    </Proxy>

    # OXtender
    <Proxy /Microsoft-Server-ActiveSync>
    ProxyPass balancer://oxcluster/Microsoft-Server-ActiveSync
    </Proxy>
    ProxyPass /Microsoft-Server-ActiveSync ajp://127.0.0.1:8009/Microsoft-Server-ActiveSync smax=0 ttl=60 retry=5
    </IfModule>

    Thanks!

  9. #9
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    did you install open-xchange-ajp or open-xchange-grizzly?

    Cheers
    Martin

  10. #10
    Join Date
    Mar 2013
    Posts
    13

    Default

    Yes, I have already installed open-xchange-ajp, but when I try to install open-xchange-grizzly it shows me this errror :
    Error: open-xchange-grizzly conflicts with open-xchange-ajp-7.2.0-4_5.1.noarch

    Thanks!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •