Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 7 of 7
  1. #1
    Join Date
    Mar 2009
    Posts
    24

    Default OX AppSuite: 7.2: Installation freezes on: Processing apps/themes/demo

    Hi,
    i do have an issue with the actual 7.2 installation.
    I have tried it on 32-bit server with Debian-6, Cent-OS-6, SLES.
    the result is equal, which is a freeze after: Processing apps/themes/demo

    I have tried it with 7.0.1, which is working or let's say, not showing this issue.
    below the output messages during installation.

    root@hserver:~# apt-get update

    root@hserver:~# apt-get install mysql-server open-xchange open-xchange-authentication-database \
    > open-xchange-ajp open-xchange-cluster-discovery-static open-xchange-admin open-xchange-appsuite \
    > open-xchange-appsuite-backend open-xchange-appsuite-manifest
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut... Fertig
    Die folgenden zusätzlichen Pakete werden installiert:
    apache2 apache2-mpm-worker apache2-utils apache2.2-bin apache2.2-common avahi-daemon bind9-host dbus geoip-database gsfonts
    gsfonts-x11 java-common libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libasound2 libavahi-common-data
    libavahi-common3 libavahi-core7 libbind9-60 libdaemon0 libdbd-mysql-perl libdbi-perl libdns69 libfontenc1 libgeoip1
    libhtml-template-perl libisc62 libisccc60 libisccfg62 liblwres60 libmysqlclient16 libnet-daemon-perl libnss-mdns libplrpc-perl
    libx11-6 libx11-data libxau6 libxcb1 libxdmcp6 libxext6 libxfont1 libxi6 libxtst6 mysql-client mysql-client-5.1 mysql-common
    mysql-server-5.1 mysql-server-core-5.1 open-xchange-appsuite-l10n-en-us open-xchange-authorization-standard open-xchange-core
    open-xchange-halo open-xchange-imap open-xchange-l10n-en-us open-xchange-oauth open-xchange-osgi open-xchange-smtp
    open-xchange-themes-default open-xchange-xerces-sun sun-java6-bin sun-java6-jre x11-common xfonts-encodings xfonts-utils
    Vorgeschlagene Pakete:
    apache2-doc apache2-suexec apache2-suexec-custom avahi-autoipd dbus-x11 default-jre equivs libasound2-plugins geoip-bin
    libipc-sharedcache-perl libterm-readkey-perl tinyca binfmt-support sun-java6-plugin ia32-sun-java6-plugin sun-java6-fonts
    ttf-baekmuk ttf-unfonts ttf-unfonts-core ttf-kochi-gothic ttf-sazanami-gothic ttf-kochi-mincho ttf-sazanami-mincho
    ttf-arphic-uming
    Die folgenden NEUEN Pakete werden installiert:
    apache2 apache2-mpm-worker apache2-utils apache2.2-bin apache2.2-common avahi-daemon bind9-host dbus geoip-database gsfonts
    gsfonts-x11 java-common libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libasound2 libavahi-common-data
    libavahi-common3 libavahi-core7 libbind9-60 libdaemon0 libdbd-mysql-perl libdbi-perl libdns69 libfontenc1 libgeoip1
    libhtml-template-perl libisc62 libisccc60 libisccfg62 liblwres60 libmysqlclient16 libnet-daemon-perl libnss-mdns libplrpc-perl
    libx11-6 libx11-data libxau6 libxcb1 libxdmcp6 libxext6 libxfont1 libxi6 libxtst6 mysql-client mysql-client-5.1 mysql-common
    mysql-server mysql-server-5.1 mysql-server-core-5.1 open-xchange open-xchange-admin open-xchange-ajp open-xchange-appsuite
    open-xchange-appsuite-backend open-xchange-appsuite-l10n-en-us open-xchange-appsuite-manifest
    open-xchange-authentication-database open-xchange-authorization-standard open-xchange-cluster-discovery-static open-xchange-core
    open-xchange-halo open-xchange-imap open-xchange-l10n-en-us open-xchange-oauth open-xchange-osgi open-xchange-smtp
    open-xchange-themes-default open-xchange-xerces-sun sun-java6-bin sun-java6-jre x11-common xfonts-encodings xfonts-utils
    0 aktualisiert, 75 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
    Es müssen 159 MB an Archiven heruntergeladen werden.
    Nach dieser Operation werden 318 MB Plattenplatz zusätzlich benutzt.
    Möchten Sie fortfahren [J/n]? J
    ....
    ....

    Es wurden 159 MB in 17 s geholt (8.908 kB/s)
    Extrahiere Vorlagen aus Paketen: 100%
    Vorkonfiguration der Pakete ...
    Vormals abgewähltes Paket mysql-common wird gewählt.
    (Lese Datenbank ... 20559 Dateien und Verzeichnisse sind derzeit installiert.)
    ...
    ...
    ...
    Entpacken von open-xchange-core (aus .../open-xchange-core_7.2.0-8_all.deb) ...
    Kein Paket gefunden, das auf open-xchange-file-storage-config passt.
    Kein Paket gefunden, das auf open-xchange-folder-json passt.
    Kein Paket gefunden, das auf open-xchange-i18n passt.
    Kein Paket gefunden, das auf open-xchange-push passt.
    Kein Paket gefunden, das auf open-xchange-messaging passt.
    Kein Paket gefunden, das auf open-xchange-publish-basic passt.
    Kein Paket gefunden, das auf open-xchange-push-udp passt.
    Kein Paket gefunden, das auf open-xchange-secret passt.
    Kein Paket gefunden, das auf open-xchange-secret passt.
    Kein Paket gefunden, das auf open-xchange-threadpool passt.
    Kein Paket gefunden, das auf open-xchange-settings-extensions passt.
    Kein Paket gefunden, das auf open-xchange-settings-extensions passt.
    Kein Paket gefunden, das auf open-xchange-settings-extensions passt.
    Kein Paket gefunden, das auf open-xchange-management passt.
    Kein Paket gefunden, das auf open-xchange-templating passt.
    Kein Paket gefunden, das auf open-xchange passt.
    ....
    ....
    Kein Paket gefunden, das auf open-xchange passt.
    Vormals abgewähltes Paket mysql-client wird gewählt.
    Entpacken von mysql-client (aus .../mysql-client_5.1.66-0+squeeze1_all.deb) ...
    Trigger für man-db werden verarbeitet ...
    java-common (0.40) wird eingerichtet ...
    sun-java6-bin (6.26-0squeeze1) wird eingerichtet ...
    update-alternatives: /usr/lib/jvm/java-6-sun/jre/bin/ControlPanel wird verwendet, um /usr/bin/ControlPanel (ControlPanel) im Auto-Modus bereitzustellen.
    update-alternatives: /usr/lib/jvm/java-6-sun/jre/bin/java wird verwendet, um /usr/bin/java (java) im Auto-Modus bereitzustellen.
    update-alternatives: /usr/lib/jvm/java-6-sun/jre/bin/java_vm wird verwendet, um /usr/bin/java_vm (java_vm) im Auto-Modus bereitzustellen.
    update-alternatives: /usr/lib/jvm/java-6-sun/jre/bin/javaws wird verwendet, um /usr/bin/javaws (javaws) im Auto-Modus bereitzustellen.
    update-alternatives: /usr/lib/jvm/java-6-sun/jre/bin/jcontrol wird verwendet, um /usr/bin/jcontrol (jcontrol) im Auto-Modus bereitzustellen.
    update-alternatives: /usr/lib/jvm/java-6-sun/jre/bin/keytool wird verwendet, um /usr/bin/keytool (keytool) im Auto-Modus bereitzustellen.
    update-alternatives: /usr/lib/jvm/java-6-sun/jre/bin/pack200 wird verwendet, um /usr/bin/pack200 (pack200) im Auto-Modus bereitzustellen.
    update-alternatives: /usr/lib/jvm/java-6-sun/jre/bin/policytool wird verwendet, um /usr/bin/policytool (policytool) im Auto-Modus bereitzustellen.
    update-alternatives: /usr/lib/jvm/java-6-sun/jre/bin/rmid wird verwendet, um /usr/bin/rmid (rmid) im Auto-Modus bereitzustellen.
    update-alternatives: /usr/lib/jvm/java-6-sun/jre/bin/rmiregistry wird verwendet, um /usr/bin/rmiregistry (rmiregistry) im Auto-Modus bereitzustellen.
    update-alternatives: /usr/lib/jvm/java-6-sun/jre/bin/unpack200 wird verwendet, um /usr/bin/unpack200 (unpack200) im Auto-Modus bereitzustellen.
    update-alternatives: /usr/lib/jvm/java-6-sun/jre/bin/orbd wird verwendet, um /usr/bin/orbd (orbd) im Auto-Modus bereitzustellen.
    update-alternatives: /usr/lib/jvm/java-6-sun/jre/bin/servertool wird verwendet, um /usr/bin/servertool (servertool) im Auto-Modus bereitzustellen.
    update-alternatives: /usr/lib/jvm/java-6-sun/jre/bin/tnameserv wird verwendet, um /usr/bin/tnameserv (tnameserv) im Auto-Modus bereitzustellen.
    update-alternatives: /usr/lib/jvm/java-6-sun/jre/lib/jexec wird verwendet, um /usr/bin/jexec (jexec) im Auto-Modus bereitzustellen.
    sun-java6-jre (6.26-0squeeze1) wird eingerichtet ...
    open-xchange-osgi (7.2.0-7) wird eingerichtet ...
    open-xchange-xerces-sun (7.2.0-7) wird eingerichtet ...
    open-xchange-core (7.2.0-8) wird eingerichtet ...
    Vormals abgewähltes Paket open-xchange-admin wird gewählt.
    (Lese Datenbank ... 22651 Dateien und Verzeichnisse sind derzeit installiert.)
    Entpacken von open-xchange-admin (aus .../open-xchange-admin_7.2.0-7_all.deb) ...
    Kein Paket gefunden, das auf open-xchange-admin-plugin-hosting passt.
    Vormals abgewähltes Paket open-xchange-ajp wird gewählt.
    Entpacken von open-xchange-ajp (aus .../open-xchange-ajp_7.2.0-7_all.deb) ...
    Vormals abgewähltes Paket open-xchange-oauth wird gewählt.
    Entpacken von open-xchange-oauth (aus .../open-xchange-oauth_7.2.0-7_all.deb) ...
    Kein Paket gefunden, das auf open-xchange-http-deferrer passt.
    Kein Paket gefunden, das auf open-xchange-oauth-facebook passt.
    Kein Paket gefunden, das auf open-xchange-oauth-linkedin passt.
    Kein Paket gefunden, das auf open-xchange-oauth-msn passt.
    Kein Paket gefunden, das auf open-xchange-oauth-twitter passt.
    Kein Paket gefunden, das auf open-xchange-oauth-yahoo passt.
    Vormals abgewähltes Paket open-xchange-halo wird gewählt.
    ....
    ....
    Trigger für man-db werden verarbeitet ...
    Trigger für fontconfig werden verarbeitet ...
    libnet-daemon-perl (0.43-1) wird eingerichtet ...
    libplrpc-perl (0.2020-2) wird eingerichtet ...
    libdbi-perl (1.612-1) wird eingerichtet ...
    libmysqlclient16 (5.1.66-0+squeeze1) wird eingerichtet ...
    libdbd-mysql-perl (4.016-1) wird eingerichtet ...
    mysql-client-5.1 (5.1.66-0+squeeze1) wird eingerichtet ...
    mysql-server-core-5.1 (5.1.66-0+squeeze1) wird eingerichtet ...
    mysql-server-5.1 (5.1.66-0+squeeze1) wird eingerichtet ...
    Stopping MySQL database server: mysqld.
    Starting MySQL database server: mysqld.
    Checking for corrupt, not cleanly closed and upgrade needing tables..
    mysql-client (5.1.66-0+squeeze1) wird eingerichtet ...
    open-xchange-admin (7.2.0-7) wird eingerichtet ...
    open-xchange-ajp (7.2.0-7) wird eingerichtet ...
    open-xchange-oauth (7.2.0-7) wird eingerichtet ...
    open-xchange-halo (7.2.0-7) wird eingerichtet ...
    open-xchange-l10n-en-us (7.2.0-7) wird eingerichtet ...
    open-xchange-appsuite-l10n-en-us (7.2.0-4) wird eingerichtet ...
    open-xchange-appsuite-manifest (7.2.0-4) wird eingerichtet ...
    rm: Entfernen von „apps/themes/*/less“ nicht möglich: Datei oder Verzeichnis nicht gefunden
    Processing apps/themes/demo

    after this, dpkg --configure -a also not working, sure also not "apt-get -f install" due to not completion...

    any idea?
    Last edited by mardoc; 05-17-2013 at 04:40 PM.

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    this step just takes a few seconds to 1-2 minutes, depending on the system. Please do _not_ cancel it.

    Cheers
    Martin

  3. #3
    Join Date
    Mar 2009
    Posts
    24

    Default

    Hi Martin,

    I have tried it again, but even after several minutes (>10), the installation procress "stays" at line:
    .....
    open-xchange-appsuite-manifest (7.2.0-4) wird eingerichtet ...
    rm: Entfernen von „apps/themes/*/less“ nicht möglich: Datei oder Verzeichnis nicht gefunden

    the system, which is a virtual server, idles at about 99%.
    OS: Debian 6

    if there is an issue, which it seems, can i find a log?
    What information you would need additional?

    It would be so great, if i get this running.
    br mardoc

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    there are no logs of this, but could you check with "top" if there is any process running while this output is shown? How much memory does that machine have?

    Cheers
    Martin

  5. #5
    Join Date
    Mar 2009
    Posts
    24

    Default

    Hi Martin,

    after several restarts, kills... I got an error-message from apt-get upgrade:

    open-xchange-appsuite-manifest (7.2.0-4) wird eingerichtet ...
    rm: Entfernen von „apps/themes/*/less“ nicht möglich: Datei oder Verzeichnis nicht gefunden
    Processing apps/themes/demo
    #
    # A fatal error has been detected by the Java Runtime Environment:
    #
    # Internal Error (nmethod.cpp:2175), pid=2085, tid=3066997616
    # guarantee(nm->_lock_count >= 0) failed: unmatched nmethod lock/unlock
    #
    # JRE version: 6.0_26-b03
    # Java VM: Java HotSpot(TM) Client VM (20.1-b02 mixed mode, sharing linux-x86 )
    # An error report file with more information is saved as:
    # /opt/open-xchange/appsuite/hs_err_pid2085.log
    #
    # If you would like to submit a bug report, please visit:
    # http://java.sun.com/webapps/bugreport/crash.jsp
    #
    /opt/open-xchange/appsuite/share/update-themes.sh: Zeile 5: 2085 Abgebrochen java -jar /opt/open-xchange/bundles/com.openexchange.scripting.rhino/lib/js.jar share/update-themes.js
    dpkg: Fehler beim Bearbeiten von open-xchange-appsuite-manifest (--configure):
    Unterprozess installiertes post-installation-Skript gab den Fehlerwert 134 zurück
    configured to not write apport reports
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von open-xchange-appsuite-backend:
    open-xchange-appsuite-backend hängt ab von open-xchange-appsuite-manifest; aber:
    Paket open-xchange-appsuite-manifest ist noch nicht konfiguriert.
    dpkg: Fehler beim Bearbeiten von open-xchange-appsuite-backend (--configure):
    Abhängigkeitsprobleme - verbleibt unkonfiguriert
    configured to not write apport reports
    Fehler traten auf beim Bearbeiten von:
    open-xchange-appsuite-manifest
    open-xchange-appsuite-backend
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    the system has 2GB RAM.
    top is not showing anything intressting during dpkg --configure -a

    br mardoc

  6. #6
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    well, a fatal error at the JVM is almost certainly caused by environment issues (not enough/limited memory, library issues, faulty hardware...) and nothing one can influence from "within" the JVM. The script just starts a tool called "Mozilla Rhino" to process javascript. Is this a virtual box? (uname -a?) Usually we don't support 32bit machines anymore but a quick check on centos6 32bit with 7.2.0-rev4 did not show any issues for me.

    Martin

  7. #7
    Join Date
    Mar 2009
    Posts
    24

    Default

    Hi Martin,
    as you mentioned, I also think now this is a resource issue.
    I have moved now to a 64bit root server and the installation went fine. (this decision was anyway overdue ;-))

    great job, martin.

    br mrdoc.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •