Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 10 of 10
  1. #1
    mayank Guest

    Default OX Admin GUI error

    Hello all..
    Im getting this error in OX-ADMIN GUI

    Error code: Error occured in: com.openexchange.admin.rmi.extensions.OXUserMailfi lterExtension! Errortext: com.openexchange.admin.rmi.exceptions.OXSieveHandl erException: The server doesn't suppport PLAIN authentication

  2. #2
    vitch Guest

    Default

    Same for me
    Last edited by vitch; 11-04-2007 at 09:50 PM.

  3. #3
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Did you create a pam.d entry for sieve? Is timsieved running properly?

  4. #4
    mayank Guest

    Default

    yes, i already have this entry in /etc/pam.d/sieve .
    but how to check whether timsieved running properly or not ??


    Quote Originally Posted by Martin Braun View Post
    Did you create a pam.d entry for sieve? Is timsieved running properly?

  5. #5
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    telnet localhost 2000

    Greetings

  6. #6
    mayank Guest

    Default

    Yes, Martin
    I think command is working as it says OK.
    what next ??

    Quote Originally Posted by Martin Braun View Post
    telnet localhost 2000

    Greetings

  7. #7
    jnrk Guest

    Default

    Hi,

    got a similar error after installation on a blank new opensuse10.2 with the hyperion-opensuse_103.sh script...

    Code:
    /var/lib # telnet localhost 2000
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    "IMPLEMENTATION" "Cyrus timsieved v2.2.13"
    "SASL" "LOGIN"
    "SIEVE" "fileinto reject envelope vacation imapflags notify subaddress relational comparator-i;ascii-numeric regex"
    "STARTTLS"
    OK
    Any idea is welcome.

    Thanks and Best Regards,
    Sascha

    PS: On a testserver with Ubuntu it works without problems, the difference lies in the line
    "SASL" "PLAIN LOGIN" but I don't know how to change this setting on openSuse.

  8. #8
    Gertjan Guest

    Default

    Is PLAIN in your sasl_mech_list in /etc/imapd.conf?

    Code:
    sasl_mech_list: PLAIN LOGIN
    If it is not, but after you added it and restarted cyrus and still not working:
    Is cyrus-sasl-plain installed?

    And @mayank:
    /etc/pam.d/sieve can be a symlink to (or a copy of) /etc/pam.d/imap.
    Last edited by Gertjan; 12-14-2007 at 10:28 AM.

  9. #9
    jnrk Guest

    Thumbs up

    Quote Originally Posted by Gertjan View Post
    Is PLAIN in your sasl_mech_list in /etc/imapd.conf?

    Code:
    sasl_mech_list: PLAIN LOGIN
    If it is not, but after you added it and restarted cyrus and still not working:
    Is cyrus-sasl-plain installed?

    And @mayank:
    /etc/pam.d/sieve can be a symlink to (or a copy of) /etc/pam.d/imap.
    Hi,

    imapd.conf, cyrus.conf and pam.d/sieve have been all right... but your hint with the cyrus-sasl-plain saved my day. I don't know why it hasn't been installed before.

    Thanks a lot now it works.

    Best Regards,
    Sascha

  10. #10
    Gertjan Guest

    Default

    Nice to hear that it works now.
    The reason that it wasn't installed is because it is not in the installer script and no other installed packages depend on it. But I'm (still) working on a version of the opensuse 10.3 installer script which also includes Amavis, Spamassassin, ClamAV and SSL support. In that script, I already added the package.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •