Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 6 of 6
  1. #1
    dpk Guest

    Default another adduser / login problem

    Hi! ... I looked at the other threads but it seems that my problem is a different one.

    I compiled, installed, started ox and created the database with the oxinstaller.

    when I run the createuser command like described in the installation howto I get:

    Code:
    Exception in thread "main" java.lang.NullPointerException
            at com.openexchange.admin.rmi.impl.OXUserIMAPImpl.createimpl(OXUserIMAPImpl.java:213)
            at com.openexchange.admin.rmi.impl.OXUserIMAPImpl.create(OXUserIMAPImpl.java:297)
            at com.openexchange.admin.rmi.impl.OXUser.create(OXUser.java:169)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:585)
            at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:294)
            at sun.rmi.transport.Transport$1.run(Transport.java:153)
            at java.security.AccessController.doPrivileged(Native Method)
            at sun.rmi.transport.Transport.serviceCall(Transport.java:149)
            at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:460)
            at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:701)
            at java.lang.Thread.run(Thread.java:595)
            at sun.rmi.transport.StreamRemoteCall.exceptionReceivedFromServer(StreamRemoteCall.java:247)
            at sun.rmi.transport.StreamRemoteCall.executeCall(StreamRemoteCall.java:223)
            at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:126)
            at java.rmi.server.RemoteObjectInvocationHandler.invokeRemoteMethod(RemoteObjectInvocationHandler.java:179)
            at java.rmi.server.RemoteObjectInvocationHandler.invoke(RemoteObjectInvocationHandler.java:132)
            at $Proxy0.create(Unknown Source)
            at com.openexchange.admin.console.user.Create.<init>(Create.java:146)
            at com.openexchange.admin.console.user.Create.main(Create.java:78)
    The output in the admin-log looks ok ... no errors and "User created"

    I can't login to the ox interface. I get some complaining about wrong user/password. In the groupware log this appears:

    Code:
    14.03.2007 21:16:54 com.openexchange.database.Pools run
    AM FEINSTEN: Starting cleaner run.
    14.03.2007 21:16:54 com.openexchange.database.Pools run
    AM FEINSTEN: Cleaner run ending.
    14.03.2007 21:16:54 com.openexchange.pooling.ReentrantLockPool run
    AM FEINSTEN: Starting cleaner run.
    14.03.2007 21:16:54 com.openexchange.pooling.ReentrantLockPool run
    AM FEINSTEN: Clean run ending. Time: 0
    14.03.2007 21:16:58 com.openexchange.sessiond.SessionHandler addSession
    FEIN: addSession <e14cee69a08de1c1149519686ffd9dde>
    14.03.2007 21:16:58 com.openexchange.groupware.contexts.CachingContextStorage getContextId
    AM FEINSTEN: Cache MISS. Login info: defaultcontext
    14.03.2007 21:16:58 com.openexchange.pooling.ReentrantLockPool get
    FEIN: Creating object.
    14.03.2007 21:16:58 com.openexchange.pooling.ReentrantLockPool get
    AM FEINSTEN: Get time: 22, Created: true
    14.03.2007 21:16:58 com.openexchange.pooling.ReentrantLockPool back
    AM FEINSTEN: Back time: 0
    14.03.2007 21:16:58 com.openexchange.ajax.Login doGet
    FEIN: Context not found
    com.openexchange.groupware.contexts.ContextNotFoundException: Can't find context.
            at com.openexchange.sessiond.SessionHandler.addSession(SessionHandler.java:188)
            at com.openexchange.sessiond.SessiondConnector.addSession(SessiondConnector.java:140)
            at com.openexchange.ajax.Login.doGet(Login.java:139)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
            at com.openexchange.tools.ajp13.AJPv13Request.response(AJPv13Request.java:94)
            at com.openexchange.tools.ajp13.AJPv13RequestHandler.createResponse(AJPv13RequestHandler.java:336)
            at com.openexchange.tools.ajp13.AJPv13Connection.createResponse(AJPv13Connection.java:170)
            at com.openexchange.tools.ajp13.AJPv13Listener.run(AJPv13Listener.java:232)
            at java.lang.Thread.run(Thread.java:595)
    14.03.2007 21:17:04 com.openexchange.database.Pools run
    AM FEINSTEN: Starting cleaner run.
    14.03.2007 21:17:04 com.openexchange.database.Pools run
    AM FEINSTEN: Cleaner run ending.
    14.03.2007 21:17:04 com.openexchange.pooling.ReentrantLockPool run
    AM FEINSTEN: Starting cleaner run.
    14.03.2007 21:17:04 com.openexchange.pooling.ReentrantLockPool run
    AM FEINSTEN: Clean run ending. Time: 0

    Any ideas?

    I noticed that a user mailbox like "user/<username>" is created by the createuser command while in the installation manual "user.<username>" is used? What is needed?

    Btw. I created the user oxadmin as a system-user. I think it necessary for some tasks (like cyradm) but it is not mentioned in the installation manual.

    Thank you for your support!

  2. #2
    oprocopio Guest

    Default

    Can you login with the oxadmin user?

    do you have run the oxinstaller?

    try as root

    Code:
    mysql open-xchange-db
    and then

    Code:
    select id, mail from user;
    do you see the user you have created?

    orlando

  3. #3
    dpk Guest

    Default

    I ran the oxinstaller and did not get any errors. I can't login with the oxadmin user. I get the same complaining about wrong user/password.

    The mysql-query returns two mails of the users I created and another mail-address "openexchange@example.com". I wonder why this example.com is used in this address while the correct one is used for the created users.

  4. #4
    oprocopio Guest

    Default

    is open-xchange-groupware running?

    do you have the correct version of the mysql lib?

    when you start the mysql client, do you need to enter a password for the root user?

  5. #5
    dpk Guest

    Default

    ok ...

    (1) /etc/init.d/open-xchange-groupware status gives me:
    Checking for Open-Xchange Groupware: running

    (2) You probably mean the mysql-connector-java-3.1.13-bin.jar

    I could not find the 3.1.13 so i downloaded the 3.1.14 and renamed ist before compiling ... I hope this is ok

    (3) No, i don't have to enter a password for root

    Maybe I should try another cvs snapshot tomorrow ...

  6. #6
    Flightbase Guest

    Default

    some problem here...

    i guess it`s more or less system-related.. for most users it works... so something is wrong at our side.

    greets, Nik

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •