Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 9 of 9
  1. #1
    mayank Guest

    Default error in createuser script

    hello
    im getting this error while exec. "createuser" script :

    Server response:
    javax.mail.AuthenticationFailedException: Login failed: authentication failure

    error while executing oxinstaller script :

    Server response:
    com.openexchange.admin.plugins.PluginException: com.openexchange.admin.rmi.exceptions.OXUserIMAPEx ception: javax.mail.AuthenticationFailedException: Login failed: authentication failure
    Last edited by mayank; 11-10-2007 at 12:59 PM.

  2. #2
    ole Guest

    Default

    There are some reasons for it:

    1st: the compile process from pam_mysql.tar did not work correctly.
    2nd:If You use a 64bit OS You will find after compilation the pam_mysql.la and pam_mysql.so in /lib/security and not in /lib64/security.

    If this so,copy the both pam-files from /lib/security to /lib64/security.

    If You used the community-installer,You will find the important myslq-pam-tar in the depend-folder.

    But I don't know which OS You have?Maybe there are other things for it responsible.

    You need the both files,because without them,You have no login in the web-frontend.The user will not found in the mysql-db.
    Last edited by ole; 11-10-2007 at 05:01 PM.

  3. #3
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    It seems your IMAP Server is unable to authenticate against the mysql database.

  4. #4
    mayank Guest

    Default

    hi
    first, i've compiled pam_mysql.tar and it didn't give any errors.
    second, i've found these 2 files , pam_mysql.la and "pam_mysql.so" in "/usr/lib/security/" folder.
    im not using Comm. Installer but foll. OX wiki
    my OS is Fedora Core 7.
    Even if i create user in db without IMAP authentication, i'll be able to Login OX GUI but E-mail feature is disabled. Also Admin GUI not working.
    have u tested OX on FC 7 using OX wiki ??
    I've tested this on Debian and is working fine, but not on FC7 or RHEL
    Can u list me all packg.+dependencies on FC 7/RHEL, may be i'm missing sth.!!!



    Quote Originally Posted by ole View Post
    There are some reasons for it:

    1st: the compile process from pam_mysql.tar did not work correctly.
    2nd:If You use a 64bit OS You will find after compilation the pam_mysql.la and pam_mysql.so in /lib/security and not in /lib64/security.

    If this so,copy the both pam-files from /lib/security to /lib64/security.

    If You used the community-installer,You will find the important myslq-pam-tar in the depend-folder.

    But I don't know which OS You have?Maybe there are other things for it responsible.

    You need the both files,because without them,You have no login in the web-frontend.The user will not found in the mysql-db.
    Last edited by mayank; 11-12-2007 at 08:27 AM.

  5. #5
    mayank Guest

    Default

    yes,
    exactly , this is error .
    Even if i create user in db without IMAP authentication, i'll be able to Login OX GUI but E-mail feature is disabled. Also Admin GUI not working .
    what steps should i follow ?
    how can i solve this issue of IMAP auth. against mysql db?

    This is my mail logs entries :

    Nov 12 11:38:04 asterisk cyrus/master[12138]: about to exec /usr/lib/cyrus-imapd/imapd
    Nov 12 11:38:04 asterisk cyrus/imap[11615]: accepted connection
    Nov 12 11:38:04 asterisk cyrus/imap[11615]: badlogin: localhost [127.0.0.1] plaintext postmaster SASL(-13): authentication failure: checkpass failed
    Nov 12 11:38:04 asterisk cyrus/imap[12138]: executed
    Nov 12 11:38:39 asterisk postfix/smtpd[12257]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
    Nov 12 11:38:39 asterisk postfix/smtpd[12257]: fatal: unsupported dictionary type: mysql
    Nov 12 11:38:40 asterisk postfix/master[11354]: warning: process /usr/libexec/postfix/smtpd pid 12257 exit status 1
    Nov 12 11:38:40 asterisk postfix/master[11354]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
    Nov 12 11:39:19 asterisk cyrus/master[11604]: process 11615 exited, status 0
    Nov 12 11:39:40 asterisk postfix/smtpd[12291]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
    Nov 12 11:39:40 asterisk postfix/smtpd[12291]: fatal: unsupported dictionary type: mysql
    Nov 12 11:39:41 asterisk postfix/master[11354]: warning: process /usr/libexec/postfix/smtpd pid 12291 exit status 1
    Nov 12 11:39:41 asterisk postfix/master[11354]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
    Nov 12 11:40:41 asterisk postfix/smtpd[12350]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
    Nov 12 11:40:41 asterisk postfix/smtpd[12350]: fatal: unsupported dictionary type: mysql
    Nov 12 11:40:42 asterisk postfix/master[11354]: warning: process /usr/libexec/postfix/smtpd pid 12350 exit status 1
    Nov 12 11:40:42 asterisk postfix/master[11354]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
    Nov 12 11:41:42 asterisk postfix/smtpd[12379]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
    Nov 12 11:41:42 asterisk postfix/smtpd[12379]: fatal: unsupported dictionary type: mysql
    Nov 12 11:41:43 asterisk postfix/master[11354]: warning: process /usr/libexec/postfix/smtpd pid 12379 exit status 1
    Nov 12 11:41:43 asterisk postfix/master[11354]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
    Nov 12 11:42:05 asterisk cyrus/imap[11630]: accepted connection
    Nov 12 11:42:05 asterisk cyrus/master[12688]: about to exec /usr/lib/cyrus-imapd/imapd
    Nov 12 11:42:05 asterisk cyrus/imap[12688]: executed
    Nov 12 11:42:05 asterisk cyrus/imap[11630]: badlogin: localhost [127.0.0.1] plaintext postmaster SASL(-13): authentication failure: checkpass failed
    Nov 12 11:42:38 asterisk sendmail[11841]: lAC67cfg011841: timeout waiting for input from [127.0.0.1] during client greeting
    Nov 12 11:42:38 asterisk sendmail[11841]: lAC67cfg011841: to=root, ctladdr=root (0/0), delay=00:05:00, xdelay=00:05:00, mailer=relay, pri=30935, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection timed out with [127.0.0.1]
    Nov 12 11:42:43 asterisk postfix/smtpd[12906]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
    Nov 12 11:42:43 asterisk postfix/smtpd[12906]: fatal: unsupported dictionary type: mysql
    Nov 12 11:42:44 asterisk postfix/master[11354]: warning: process /usr/libexec/postfix/smtpd pid 12906 exit status 1
    Nov 12 11:42:44 asterisk postfix/master[11354]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling



    Quote Originally Posted by Martin Braun View Post
    It seems your IMAP Server is unable to authenticate against the mysql database.
    Last edited by mayank; 11-12-2007 at 08:23 AM.

  6. #6
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    The installation manual at the wiki has been written for ubuntu/debian. You're welcome to research how it needs to be set up at Fedora.

    Greetings

  7. #7
    mayank Guest

    Default

    This means that it is not made to work on FC 7 / RHEL ??
    only for Debian/Ubuntu ??

    Quote Originally Posted by Martin Braun View Post
    The installation manual at the wiki has been written for ubuntu/debian. You're welcome to research how it needs to be set up at Fedora.

    Greetings

  8. #8
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    It means the installation manual uses debian/ubuntu as reference. The software itself works on nearly every operating system but installation may require some customization and the installation may be different for the wiki.

  9. #9
    mayank Guest

    Default

    hello Martin
    can u list me all packg reqd by OX on FC 7 / RHEL ?
    i know im missing sth here in FC 7 but not able to locate prb.
    Actually, im not able to create users due to IMAP authc.. so i've created users without it and then im able to login OX GUI
    but e-mail feature is deactivated and im not able to send emails. when i compose e-mail, it shows this error :

    11-12-2007 03:15 PM-->Error code: Wrong or missing login data to access server localhost. (MSG-1001,-1499193636-113)

    i've already attached latest logs related....
    What should i do now??




    Quote Originally Posted by Martin Braun View Post
    It means the installation manual uses debian/ubuntu as reference. The software itself works on nearly every operating system but installation may require some customization and the installation may be different for the wiki.
    Last edited by mayank; 11-12-2007 at 11:39 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •