Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 9 of 9
  1. #1
    thewizzard Guest

    Default createcontext: access denied for user 'openexchange'@'localhost'

    Hi,

    I ran into a problem again: when running createcontext (through oxinstaller), I get a SQLException: access denied for user 'openexchange'@'localhost' (using password: YES)

    When I try the following: "mysql -h localhost -u openexchange -p configdb" the login succeeds and I get the standard mysql prompt. The createcontext tool also seems to ignore every change I make to /opt/open-xchange/etc/groupware/configdb.properties or /opt/open-xchange/etc/admindaemon/configdb.properties

    Has anybody got an idea what this error could be caused by?

    Regards

    Jonas

  2. #2
    neo Guest

    Default

    Quote Originally Posted by thewizzard View Post
    Hi,

    I ran into a problem again: when running createcontext (through oxinstaller), I get a SQLException: access denied for user 'openexchange'@'localhost' (using password: YES)

    When I try the following: "mysql -h localhost -u openexchange -p configdb" the login succeeds and I get the standard mysql prompt. The createcontext tool also seems to ignore every change I make to /opt/open-xchange/etc/groupware/configdb.properties or /opt/open-xchange/etc/admindaemon/configdb.properties

    Has anybody got an idea what this error could be caused by?

    Regards

    Jonas
    When you try to run the command "mysql ...." then you don't have to provide a password?

    But oxinstaller neeeds a passwort, that's why you get the error.

  3. #3
    skorpion564 Guest

    Default

    Hy,

    Same problem here.
    When i try to login in with "mysql -h localhost -u openexchange -p configdb" he asks for the password and with it i am able to connect to mysql.

    output from oxinstaller is:

    Configuring services
    setting readUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    (Re)Starting Admin Daemon done
    initializing database (step 2/2)Server response:
    java.sql.SQLException: Server connection failure during transaction. Due to underlying exception: 'java.sql.SQLException: Access denied for user 'openexchange'@'localhost' (using password: YES)'.

    ** BEGIN NESTED EXCEPTION **

    java.sql.SQLException
    MESSAGE: Access denied for user 'openexchange'@'localhost' (using password: YES)

    STACKTRACE:

    java.sql.SQLException: Access denied for user 'openexchange'@'localhost' (using password: YES)
    at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.ja va:2975)
    at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.ja va:798)
    at com.mysql.jdbc.MysqlIO.secureAuth411(MysqlIO.java: 3700)
    at com.mysql.jdbc.MysqlIO.doHandshake(MysqlIO.java:12 03)
    at com.mysql.jdbc.Connection.createNewIO(Connection.j ava:2709)
    at com.mysql.jdbc.Connection.<init>(Connection.java:1 485)
    at com.mysql.jdbc.NonRegisteringDriver.connect(NonReg isteringDriver.java:266)
    at java.sql.DriverManager.getConnection(DriverManager .java:525)
    at java.sql.DriverManager.getConnection(DriverManager .java:171)
    at com.openexchange.admin.tools.AdminCacheExtended.ge tSimpleSqlConnection(AdminCacheExtended.java:178)
    at com.openexchange.admin.storage.mysqlStorage.OXCont extMySQLStorage.createDatabase(OXContextMySQLStora ge.java:741)
    at com.openexchange.admin.storage.mysqlStorage.OXCont extMySQLStorage.create(OXContextMySQLStorage.java: 382)
    at com.openexchange.admin.rmi.impl.OXContextLightImpl .create(OXContextLightImpl.java:98)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastSe rverRef.java:294)
    at sun.rmi.transport.Transport$1.run(Transport.java:1 53)
    at java.security.AccessController.doPrivileged(Native Method)
    at sun.rmi.transport.Transport.serviceCall(Transport. java:149)
    at sun.rmi.transport.tcp.TCPTransport.handleMessages( TCPTransport.java:466)
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er.run(TCPTransport.java:707)
    at java.lang.Thread.run(Thread.java:595)


    ** END NESTED EXCEPTION **


    Attempted reconnect 3 times. Giving up.
    done

    system is debian/etch

    Regards

    Ruben

  4. #4
    neo Guest

    Default

    Quote Originally Posted by skorpion564 View Post
    Hy,

    Same problem here.
    When i try to login in with "mysql -h localhost -u openexchange -p configdb" he asks for the password and with it i am able to connect to mysql.

    Attempted reconnect 3 times. Giving up.
    done

    system is debian/etch

    Regards

    Ruben

    ok, what is the output from
    Code:
    mysql -u root -e "select user,host from mysql.user"
    May be you have to add the "-p" parameter if root is not able to login without a password.

    Which hosts and user do you see?

  5. #5
    skorpion564 Guest

    Default

    neptun:~# mysql -u root -e "select user,host from mysql.user"
    +------------------+-----------+
    | user | host |
    +------------------+-----------+
    | debian-sys-maint | localhost |
    | openexchange | localhost |
    | root | localhost |
    | root | neptun |
    +------------------+-----------+
    neptun:~#

    there is no password set for user root

    neptun:~# mysql -u root
    Welcome to the MySQL monitor. Commands end with ; or \g.
    Your MySQL connection id is 40
    Server version: 5.0.32-Debian_7-log Debian etch distribution

    Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

    mysql>

  6. #6
    thewizzard Guest

    Default

    I got a few more users but almost the same. I also tried setting the host to "%" for openexchange, but no luck with that either... (I'm on debian sarge btw with mysql packages from here: http://www.howto24.de/wiki/index.php...hp5_und_MySQL5)

  7. #7
    thewizzard Guest

    Default

    Does anybody know where createcontext takes its data for the database connection from? Changing configdb.properties doesn't change the behaviour of createcontext (when I change the username in configdb.properties, it still says access denied for openexchange).

    Regards

    Jonas

  8. #8
    Francisco Laguna Guest

    Default

    Could you try this for me:

    http://www.open-xchange.com/wiki/ind...atabase_access

    Maybe something wrong wound up in either /opt/open-xchange/admindaemon/configdb.properties or the tables.

  9. #9
    thewizzard Guest

    Default

    Thanks, that did it. It had "secret" in the password column of the db_pool table. Now I can continue to install Open-Xchange You made my day!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •