Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 3 of 3

Thread: IMAPS problem

  1. #1
    anYc Guest

    Default IMAPS problem

    Hi,

    I have installed the OX Hosting Edition on Debian stable. Everything works fine so far, except Webmail.

    We have a central mailserver with IMAPS-only policy. I set the necessary values in imap.properties for IMAPS but OX still tries to connect via unencrypted IMAP, resulting in the estimated "connection refused" error message.

    The interessting thing is, when i set imapLoginType to global, OX connects over IMAPS and I get the "password-wrong" error message because there is no master user.

    I monitored both cases with wireshark.

    I also tried to set user attribute "imapserver" to our.email-server.org:993 but it still wants to communicate over IMAP on the IMAPS port.

    Today I've installed a local imap proxy (perdition) that listens for incoming IMAP connections and uses IMAPS to our central email server and that way it works, but this can only be a temporary workaround.

    Any recommendations?

    Our shortened imap.properties:

    Code:
    # Sets the implementing class to Global (global login) or User (user-specific login)
    imapLoginType=user
    
    # The master password for IMAP Server. Only takes effect when property "imapLoginType" is set to "global"
    imapMasterPassword=<IMAPPW>
    
    # IMAP Server with or without IMAP Port: e.g. 192.168.32.133:8143
    imapServer=our.imap-server.org
    #imapServer=localhost
    
    # SMTP Server with or without SMTP Port: e.g. 192.168.32.133:125
    smtpServer=our.smtp-server.org
    
    # The localhost name that is going to be used on SMTP's HELO or EHLO command.
    # The default is set to InetAddress.getLocalHost().getHostName() but if either JDK or name service are not
    # configured properly, this routine fails and the HELO or EHLO command is send without a name which
    # leads to an error: "501 HELO requires domain address"
    # The value "null" falls back to InetAddress.getLocalHost().getHostName() which works in most cases.
    smtpLocalhost=null
    
    # Enable/Disable IMAPS and its port
    imaps=true
    imapsPort=993
    
    # Enable/Disable SMTPS and its port
    smtps=false
    smtpsPort=465

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    those "master" accounts and imap/smtpserver entries at imap.properties are not quite usable and are intended for testing.
    Did you set the port for each users mail account (--imapserver yourimap:993 for createuser and changeuser) and the "imaps=true" option at imap.properties? Note that you need to restart the groupware service if you change those property files.
    Would you post the CAPABILITY greeting of you imap server?

    Greetings.
    Last edited by Martin Heiland; 11-22-2007 at 12:10 AM.

  3. #3
    Andy Guest

    Default

    Hi all!

    I'm also having problems with imaps and webmail. OX hyperion runs fine on Debian etch, and webmail via imap is working, too. However, when changing to imaps, the ox webmail login hangs at 10%. I have changed

    /etc/cyrus.conf: enabled imaps
    /opt/open-xchange/etc/groupware/imap.properties: enabled imaps
    /opt/open-xchange/sbin/changeuser -c 1 -u test_user --imapserver localhost:993 [..]

    and then restarted everything. As mentioned above, the login for "test_user" hangs at 10%. Accessing mail via imaps using external clients (e.g. Thunderbird) works fine.

    Any help is highly appreciated!

    Best regards
    Andy

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •