Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 9 of 9
  1. #1

    Post OX Drive und UTF

    Hallo,

    OX Drive scheint genauso wie OX Guard Probleme mit der Kodierung zu haben.
    Wenn ein Dateinamen die Umlauten hat, dann wird er nach dem Hochladen falsch dargestellt, so dass die Suche nach dem Namen fehlschlägt. Bei sehr vielen Datein ist das natürlich unbrauchbar.

    Die Dateinamen in Cyrillic werden sehr lustig dargestellt, völlig unkenntlich.

    In der Datei drive.properties konnte ich keine Einstellungen bezüglich Zeichenkodierung finden.

    Gruß Johann

  2. #2

    Default

    Ich habe das Problem etwas weiter verfolgt. Die Tabele infostore_document, wo der Dateiname abgespeichert wird, hat die richtigen Parameter: Typ=InnoDB, Kollation=utf8_unicode_ci.

    Die Dateien, die mit der Version 7.6.0 abgespeichert waren, haben die richtigen Namen mit den Umlauten. Die Dateien, die mit der Version 7.6.1 hochgeladen sind, sind bereits in der Datenbank verkehrt dargestellt. Das würde bedeuten, das bei der Verarbeitung etwas schief läuft.

    Genauso ist es mit den OX Guard files mit der Endung *.grd. Die Namen sind bereits in der Datenbank falsch dargestellt.

    Für mich sieht das nach einem Bug aus.
    Vielleicht kann das jemand auf dem anderen OS bestätigen.

    Vielen Dank
    ------------------
    OS: Centos 6.5
    locale:
    LANG=de_DE.UTF-8
    LC_CTYPE="de_DE.UTF-8"
    LC_NUMERIC="de_DE.UTF-8"
    LC_TIME="de_DE.UTF-8"
    LC_COLLATE="de_DE.UTF-8"
    LC_MONETARY="de_DE.UTF-8"
    LC_MESSAGES="de_DE.UTF-8"
    LC_PAPER="de_DE.UTF-8"
    LC_NAME="de_DE.UTF-8"
    LC_ADDRESS="de_DE.UTF-8"
    LC_TELEPHONE="de_DE.UTF-8"
    LC_MEASUREMENT="de_DE.UTF-8"
    LC_IDENTIFICATION="de_DE.UTF-8"

    Appsuite: 7.6.1
    OX Guard: open-xchange-guard-1.0.0-4_7.1
    open-xchange-drive-7.6.1-5_6.1.noarch

  3. #3

    Default

    Heute habe ich über davfs2 versucht einige Files mit deutschen Umlauten und Cyrillic Buchstaben zu laden.
    Mit letzter Version von davfs2 1.5.2 unter CentOS 6.5 64 Bit funktioniert das ganz gut und relativ schnell. Die Files werden richtig verarbeitet und werden korrekt angezeigt sowohl im Frontend von Open-Xchange 7.6.1 als auch in MySQL DB.

    Es kann sich also nur um den Fehler beim Laden der Dateien über das Frontend handeln.
    Da OX Guard das gleiche Frontend benutzt, ist der Fehler auch dort eingeschlichen.

  4. #4

    Default

    Hallo,

    könnte bitte jemand Oxdrive Version 7.6.1 testen? Einfach eine Datei mit den deutschen Umlauten in Dateinamen über Browser hoch laden und dann berichten, ob der Name richtig dargestellt wird.

    Danke

  5. #5
    Join Date
    Sep 2007
    Location
    Germany
    Posts
    494

    Default

    Habs mal getestet. Scheint tatsächlich schief zu gehen.

  6. #6

    Default

    Hallo Wolfgang,

    vielen Dank für den Test. Wird dieses Problem in absehbare Zeit in Angriff genommen?

    Gruß Johann

  7. #7
    Join Date
    Sep 2007
    Location
    Germany
    Posts
    494

    Default

    Die "richtige Lösung" wird noch diskutiert. Ich habe einen Bug dazu aufgemacht.

    Ein möglicher Workaround ist, in ox-scriptconf.sh JAVA_XTRAOPTS "-Dfile.encoding=UTF-8" hinzuzufügen.
    Allerdings wirkt sich das offenbar nicht für bereits hochgeladene Files aus, sondern nur für neue.
    Bevorzugt bzw. reproduzierbar ist das Phänomen aber nur mit CentOS bisher. Offenbar läuft hier die Umgebung nicht per Default mit UTF-8 als character set.

  8. #8

    Default

    Hallo Wolfgang,

    erstmal besten Dank für die temporäre Lösung, ich habe sie gleich getestet. Für oxdrive und neue Dateien, die die Ulauten in Namen enthalten, funktioniert das prima. Die schon gespeicherten Files können nicht richtig dargestellt werden, weil sie in der MySQL-Datenbank bereits verkehrt gespeichert sind. Zum Glück haben wir nicht viele davon.

    Ich habe gleich mit OX Guard und mit der option JAVA_XTRAOPTS "-Dfile.encoding=UTF-8" im Script ox-scriptconf.sh im Verzeichnis "/opt/open-xchange/guard/etc" getestet. Das hat das Problem mit den Umlauten gelöst, nicht aber das Problem mit der Cyrillic-Schrift. Hier wird jeder Buchstabe durch ein Fragezeichen ersetzt.

    Ohne Verschlüsselung funktioniert die Cyrillic-Schrift richtig.

    Hättest Du eventuell noch ein Tipp für mich zur Lösung dieses Problems?

    Grüsse Johann

  9. #9
    Join Date
    Sep 2007
    Location
    Germany
    Posts
    494

    Default

    Hallo,

    habe jetzt leider auch keinen Tipp mehr. Ich würde bugs.open-xchange.com empfehlen.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •