Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 8 of 8
  1. #1
    Join Date
    Nov 2014
    Posts
    6

    Default Problemes with Installation on an Hosteurope VPS PLESK Ubuntu 12.04

    Hi,
    I've tried to install the OX on my VPS at Hosteurope.

    I tried a few guides and I always broke on the same.

    When I try:

    Code:
    root@mail:~# /opt/open-xchange/sbin/registerserver -n oxserver -A oxadminmaster -P admin_master_password
    I always got this

    Code:
    server could not be registered: 
    Server response:
     com.openexchange.admin.rmi.exceptions.PoolException: DBP-0001 Categories=SERVICE_DOWN Message='Cannot get connection to config DB.' exceptionID=2096692817-4
    	at com.openexchange.admin.storage.mysqlStorage.OXToolMySQLStorage.existsServerName(OXToolMySQLStorage.java:2137)
    	at com.openexchange.admin.storage.mysqlStorage.OXToolMySQLStorage.existsServerName(OXToolMySQLStorage.java:2161)
    	at com.openexchange.admin.rmi.impl.OXUtil.registerServer(OXUtil.java:413)
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    	at java.lang.reflect.Method.invoke(Method.java:606)
    	at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:322)
    	at sun.rmi.transport.Transport$1.run(Transport.java:177)
    	at sun.rmi.transport.Transport$1.run(Transport.java:174)
    	at java.security.AccessController.doPrivileged(Native Method)
    	at sun.rmi.transport.Transport.serviceCall(Transport.java:173)
    	at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:556)
    	at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run0(TCPTransport.java:811)
    	at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:670)
    	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
    	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
    	at java.lang.Thread.run(Thread.java:745)
    	at sun.rmi.transport.StreamRemoteCall.exceptionReceivedFromServer(StreamRemoteCall.java:275)
    	at sun.rmi.transport.StreamRemoteCall.executeCall(StreamRemoteCall.java:252)
    	at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:161)
    	at java.rmi.server.RemoteObjectInvocationHandler.invokeRemoteMethod(RemoteObjectInvocationHandler.java:194)
    	at java.rmi.server.RemoteObjectInvocationHandler.invoke(RemoteObjectInvocationHandler.java:148)
    	at com.sun.proxy.$Proxy0.registerServer(Unknown Source)
    	at com.openexchange.admin.console.util.server.RegisterServer.<init>(RegisterServer.java:83)
    	at com.openexchange.admin.console.util.server.RegisterServer.main(RegisterServer.java:91)
    I've tried with the default passwords and with my owns.
    Always the same...

    Anyone a idea?

    Thanks

    Sascha

  2. #2
    Join Date
    Sep 2007
    Location
    Germany
    Posts
    494

    Default

    So it says it cannot connect to the database.
    Any more information about the database. Are the database credentials correct? Did initconfigdb work correctly? Is MySQL running correctly?

  3. #3
    Join Date
    Nov 2014
    Posts
    6

    Default

    Quote Originally Posted by Wolfgang Rosenauer View Post
    So it says it cannot connect to the database.
    Any more information about the database. Are the database credentials correct? Did initconfigdb work correctly? Is MySQL running correctly?
    Yes. I think.
    There are new databases configdb and openexchange.

  4. #4
    Join Date
    Sep 2007
    Location
    Germany
    Posts
    494

    Default

    at com.openexchange.admin.storage.mysqlStorage.OXTool MySQLStorage.existsServerName(OXToolMySQLStorage.j ava:2137)

    hmm, wondering something:

    What does hostname -f say?

    In case it's empty please make sure that you have an entry in /etc/hosts for your actual hostname pointing to 127.0.0.1 (or 2)

  5. #5
    Join Date
    Nov 2014
    Posts
    6

    Default

    /etc/hosts/

    127.0.0.1 localhost.localdomain localhost
    ::1 localhost ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters

    # Auto-generated hostname. Please do not remove this comment.
    87.230.23.11 lvps87-230-23-11.dedicated.hosteurope.de lvps87-230-23-11
    hostname -f

    mail.irrsinn.cc

  6. #6
    Join Date
    Sep 2007
    Location
    Germany
    Posts
    494

    Default

    I'm running out of ideas now.
    Check configdb properties for the settings how to connect to configdb and change it to 127.0.0.1 or something like that.
    There must be a reason why OX cannot connect to the configdb.

  7. #7
    Join Date
    Nov 2014
    Posts
    6

    Default

    Quote Originally Posted by Wolfgang Rosenauer View Post
    I'm running out of ideas now.
    Check configdb properties for the settings how to connect to configdb and change it to 127.0.0.1 or something like that.
    There must be a reason why OX cannot connect to the configdb.
    But it can connect for initialize the database.
    I'm wondering.

    Sascha

  8. #8
    Join Date
    Jan 2013
    Location
    Stuttgart
    Posts
    10

    Default

    For my plesk installation I must add to mysql a previliged grand user. To go throw those steps without any issues. Plesk is changing the root user to admin and you cant know the password.

    Try:

    1. Login into mysql
    mysql -uadmin -p`cat /etc/psa/.psa.shadow`
    2. Generate user with privilage grant permissions
    CREATE USER 'sascha'@'localhost' IDENTIFIED BY 'some_pass';

    GRANT ALL PRIVILEGES ON *.* TO 'sascha'@'localhost'
    -> WITH GRANT OPTION;

    FLUSH PRIVILEGES;
    3. go throw the Installation steps with the new admin user

    /opt/open-xchange/sbin/initconfigdb --configdb-pass=db_password -a --mysql-root-user sascha --mysql-root-passwd some_pass -i

    /opt/open-xchange/sbin/oxinstaller --add-license=YOUR-OX-LICENSE-CODE \
    --servername=oxserver --configdb-pass=db_password \
    --master-pass=admin_master_password --network-listener-host=localhost --servermemory 5012

    /etc/init.d/open-xchange restart

    ...go smoking...

    /opt/open-xchange/sbin/registerserver -n oxserver -A oxadminmaster -P admin_master_password

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •