Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 10 of 10
  1. #1
    Join Date
    Dec 2014
    Posts
    9

    Default Subfolder werden (teilweise) nicht angezeigt

    Hallo zusammen,

    ich habe meine E-Mail-Konten via IMAP in die AppSuite eingebunden. Soweit funktioniert das auch.
    Es werden zunächst auch alle Ordner unterhalb "Meine Ordner" angezeigt. Viele der Unterordner fehlen jedoch. Im Server-Log sind keine Fehler ersichtlich. Die Ordner wurden alle mit Apple Mail bzw. Thunderbird angelegt. Andere E-Mail-Clients (Thunderbird, Outlook, Apple Mail, etc.) zeigen diese sauber an. Ist dieser Fehler bekannt und/oder gibt es sogar eine Lösung hierfür?

    Vielen Dank vorab!

    Gruß,
    Sebastian

  2. #2
    Join Date
    Aug 2008
    Posts
    107

    Default

    Quote Originally Posted by chili View Post
    Hallo zusammen,

    ich habe meine E-Mail-Konten via IMAP in die AppSuite eingebunden. Soweit funktioniert das auch.
    Es werden zunächst auch alle Ordner unterhalb "Meine Ordner" angezeigt. Viele der Unterordner fehlen jedoch. Im Server-Log sind keine Fehler ersichtlich. Die Ordner wurden alle mit Apple Mail bzw. Thunderbird angelegt. Andere E-Mail-Clients (Thunderbird, Outlook, Apple Mail, etc.) zeigen diese sauber an. Ist dieser Fehler bekannt und/oder gibt es sogar eine Lösung hierfür?

    Vielen Dank vorab!

    Gruß,
    Sebastian
    Hi und Willkommen im Forum,

    bitte sag uns die Version von backend und appsuite.

    VG Rene
    Viele Grüße
    Rene

    OS: Ubuntu Server amd64 12.4 LTS
    JRE: openjdk-7-jre, MySQL: 5.5, Apache 2.2, Dovecot 2.0.19
    OX-Server backend: OXSE latest
    OX-frontend: OXSE latest appsuite + ox6

  3. #3
    Join Date
    Dec 2014
    Posts
    9

    Default

    Hallo,

    danke für deine Antwort.
    Das habe ich in der Eile echt vergessen, sorry.

    Backend: 7.6.1 Rev16
    Frontend: 7.6.1 Rev12
    Das ganze läuft auf einem SLES 11 SP3

    Danke und Gruß
    Sebastian
    Last edited by chili; 02-26-2015 at 01:33 PM.

  4. #4
    Join Date
    Aug 2008
    Posts
    107

    Default

    Hallo Sebastian,

    im Frontend wurde mit der Version v7.6.1 Rev15 folgender Fehler gefixt:

    36356 Some mail folders are missing in folder tree
    Previous feature enhancements and bugfixes led to a situation where mail folders on certain IMAP hierarchy/configurations could not be displayed anymore. Specifically, this affected setups where folders can be created on the same level as ”Inbox” and below ”Inbox”. Folders below ”Inbox” were not shown by the UI anymore in this case. This has been solved by adapting display of folders to the ”altnamespace” hierarchy. Folders ”below” the Inbox folder are now orderly listed according to their hierarchy while folders on the same level as Inbox are displayed at ”Myfolders”.
    Ein Update sollte also helfen ;-)
    Viele Grüße
    Rene

    OS: Ubuntu Server amd64 12.4 LTS
    JRE: openjdk-7-jre, MySQL: 5.5, Apache 2.2, Dovecot 2.0.19
    OX-Server backend: OXSE latest
    OX-frontend: OXSE latest appsuite + ox6

  5. #5
    Join Date
    Dec 2014
    Posts
    9

    Default

    Hallo Rene,

    die Updates habe ich nun installiert. Mein Frontend hat nun die Version v7.6.1 Rev15.
    Leider werden die Unterordner noch immer nicht angezeigt. Den Server habe ich nach dem Update neu gestartet...
    Hast du weitere Lösungsansätze, an die ich anknüpfen kann?

    Danke und Gruß
    Sebastian

  6. #6
    Join Date
    Aug 2008
    Posts
    107

    Default

    Hi Sebastian,

    2 Fragen habe ich. Erstens, welchen IMAP Server verwendest du? Zweitens, hast du die Unterordner abonniert (Einstellungen/E-Mail)?

    VG Rene
    Viele Grüße
    Rene

    OS: Ubuntu Server amd64 12.4 LTS
    JRE: openjdk-7-jre, MySQL: 5.5, Apache 2.2, Dovecot 2.0.19
    OX-Server backend: OXSE latest
    OX-frontend: OXSE latest appsuite + ox6

  7. #7
    Join Date
    Dec 2014
    Posts
    9

    Default

    Hi Rene,

    ich nutze einen relativ aktuellen cyrus. Seit dem Update auf Rev15 tauchen dort, unter den abnierten Ordnern, tatsächlich die fehlenden Ordner auf. Soweit schon mal super allerdings sind die Ordner, die bisher nicht angezeigt wurden nicht ausgewählt. Ein entfernen und wieder setzen den Abonnements auf den übergeordneten Ordner, vererbt sich leider nicht rekursiv auf alle Unterordner. Gibt es eine Möglichkeit das zu forcieren? Würde mir das durchklicken meiner doch sehr zahlreichen Ordner gerne ersparen... :P

    Danke und Gruß
    Sebastian

  8. #8
    Join Date
    Aug 2008
    Posts
    107

    Default

    einen solchen Trick kenne ich leider nicht. Zukünftig wird aber leichter, da alle Ordner, die du mit OX anlegst sind automatisch abonniert ;-)
    Viele Grüße
    Rene

    OS: Ubuntu Server amd64 12.4 LTS
    JRE: openjdk-7-jre, MySQL: 5.5, Apache 2.2, Dovecot 2.0.19
    OX-Server backend: OXSE latest
    OX-frontend: OXSE latest appsuite + ox6

  9. #9
    Join Date
    Dec 2014
    Posts
    9

    Default

    schade, dann klick ich mich halt mal durch ;-)
    Danke nochmals für deine Hilfe!

    Gruß
    Sebastian

  10. #10
    Join Date
    Dec 2014
    Posts
    9

    Default

    Kleiner Nachtrag, da mir das keine Ruhe gelassen hat ;-)

    Es ist möglich sich alle Ordner eines Postfaches, unabhängig davon, ob diese aboniert sind/wurden, anzeigen zu lassen.
    In der Datei /opt/open-xchange/etc/mail.properties muss hierfür der Wert von com.openexchange.mail.ignoreSubscription von false auf true gesetzt werden.

    Gruß
    Sebastian

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •