Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1

    Default SLES 12 und OX 6.22 Fehler 404

    hi wollte mal den ox auf der sles 12 Plattform installieren

    alles läuft soweit, auch mit oxldapsync context konnten erstellt werden und zeigt sie mit listcontext auch an.

    jetzt habe ich das Problem will ich mich auf der ox seite einlogen kommt immer der fehler


    ox.jpg



    kennt jemand zufällig eine lösung oder hat das selber schon mal getestet??

    gruß
    amersand
    Last edited by amersand; 05-07-2015 at 04:34 PM.

  2. #2
    Join Date
    Sep 2007
    Location
    Germany
    Posts
    494

    Default

    SLES12 habe ich noch nicht selbst getestet.
    Aber bei einem 404 würde ich erstmal rausfinden, welche Datei(en) auf dem Webserver nicht gefunden werden. Dann kommt man dem Fehler evtl. auf die Spur.

  3. #3

    Default

    hi danke für deine antwort

    ich denke das ox noch nicht kompatible ist zu SLES 12 ich habe gestern mal zum testen für den Apache ein downgrade durchführt

    dann änder sich die Fehlermeldung in "Anmeldung zurzeit nicht möglich"

    ich habe auch die auth auf database imgestelt und den context neu erstell mit user

    ox sagt immer alle ok user in context angelegt aber die Anmeldung ist denoch nicht möglich

    gruß
    amersand

  4. #4

    Default

    hi also so wie es aussied läuft der Apache im Proxy mod nicht richtig

    evtl hat ja einer eine Idee bin nicht so fit in Apache :-)
    hab die Version 2.4.12-7.1

    hier mal die error_log

    [Wed May 13 10:02:36.154570 2015] [mpm_prefork:notice] [pid 5134] AH00163: Apache/2.4.10 (Linux/SUSE) OpenSSL/1.0.1i-fips PHP/5.6.1 configured -- resuming normal operations
    [Wed May 13 10:02:36.154600 2015] [core:notice] [pid 5134] AH00094: Command line: '/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -D FOREGROUND'
    [Wed May 13 10:07:10.376884 2015] [mpm_prefork:notice] [pid 5134] AH00169: caught SIGTERM, shutting down
    [Wed May 13 10:08:31.422744 2015] [ssl:warn] [pid 5668] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
    [Wed May 13 10:08:31.432222 2015] [mpm_prefork:notice] [pid 5668] AH00163: Apache/2.4.10 (Linux/SUSE) OpenSSL/1.0.1i-fips PHP/5.6.1 configured -- resuming normal operations
    [Wed May 13 10:08:31.432255 2015] [core:notice] [pid 5668] AH00094: Command line: '/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -D FOREGROUND'
    [Wed May 13 10:08:40.099457 2015] [access_compat:error] [pid 5685] [client 192.168.1.51:49954] AH01797: client denied by server configuration: /usr/share/apache2/error/HTTP_NOT_FOUND.html.var
    [Wed May 13 10:08:48.542688 2015] [access_compat:error] [pid 5685] [client 192.168.1.51:49954] AH01797: client denied by server configuration: /usr/share/apache2/error/HTTP_NOT_FOUND.html.var
    [Wed May 13 10:09:03.680295 2015] [mpm_prefork:notice] [pid 5668] AH00170: caught SIGWINCH, shutting down gracefully
    [Wed May 13 10:21:15.927744 2015] [core:warn] [pid 6419] AH00117: Ignoring deprecated use of DefaultType in line 144 of /etc/apache2/httpd.conf.
    [Wed May 13 10:21:15.928729 2015] [ssl:warn] [pid 6419] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
    [Wed May 13 10:21:15.937520 2015] [mpm_prefork:notice] [pid 6419] AH00163: Apache/2.4.12 (Linux/SUSE) OpenSSL/1.0.1i-fips PHP/5.6.1 configured -- resuming normal operations
    [Wed May 13 10:21:15.937563 2015] [core:notice] [pid 6419] AH00094: Command line: '/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -D FOREGROUND'
    [Wed May 13 10:21:39.966033 2015] [mpm_prefork:notice] [pid 6419] AH00170: caught SIGWINCH, shutting down gracefully
    [Wed May 13 10:22:50.060633 2015] [core:warn] [pid 1380] AH00117: Ignoring deprecated use of DefaultType in line 144 of /etc/apache2/httpd.conf.
    [Wed May 13 10:22:50.075799 2015] [ssl:warn] [pid 1380] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
    [Wed May 13 10:22:50.156290 2015] [mpm_prefork:notice] [pid 1380] AH00163: Apache/2.4.12 (Linux/SUSE) OpenSSL/1.0.1i-fips PHP/5.6.1 configured -- resuming normal operations
    [Wed May 13 10:22:50.156327 2015] [core:notice] [pid 1380] AH00094: Command line: '/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -D FOREGROUND'
    [Wed May 13 10:27:11.024157 2015] [mpm_prefork:notice] [pid 1380] AH00170: caught SIGWINCH, shutting down gracefully
    [Wed May 13 10:27:11.153557 2015] [core:warn] [pid 2099] AH00117: Ignoring deprecated use of DefaultType in line 144 of /etc/apache2/httpd.conf.
    [Wed May 13 10:27:11.154435 2015] [ssl:warn] [pid 2099] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
    [Wed May 13 10:27:11.162788 2015] [mpm_prefork:notice] [pid 2099] AH00163: Apache/2.4.12 (Linux/SUSE) OpenSSL/1.0.1i-fips PHP/5.6.1 configured -- resuming normal operations
    [Wed May 13 10:27:11.162821 2015] [core:notice] [pid 2099] AH00094: Command line: '/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -D FOREGROUND'
    [Wed May 13 10:28:22.845614 2015] [mpm_prefork:notice] [pid 2099] AH00170: caught SIGWINCH, shutting down gracefully
    [Wed May 13 10:28:22.981651 2015] [core:warn] [pid 2179] AH00117: Ignoring deprecated use of DefaultType in line 144 of /etc/apache2/httpd.conf.
    [Wed May 13 10:28:22.982601 2015] [ssl:warn] [pid 2179] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
    [Wed May 13 10:28:22.991556 2015] [mpm_prefork:notice] [pid 2179] AH00163: Apache/2.4.12 (Linux/SUSE) OpenSSL/1.0.1i-fips PHP/5.6.1 configured -- resuming normal operations
    [Wed May 13 10:28:22.991588 2015] [core:notice] [pid 2179] AH00094: Command line: '/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -D FOREGROUND'
    [Wed May 13 10:29:19.059838 2015] [mpm_prefork:notice] [pid 2179] AH00170: caught SIGWINCH, shutting down gracefully
    [Wed May 13 10:29:19.191772 2015] [ssl:warn] [pid 2282] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
    [Wed May 13 10:29:19.200184 2015] [mpm_prefork:notice] [pid 2282] AH00163: Apache/2.4.12 (Linux/SUSE) OpenSSL/1.0.1i-fips PHP/5.6.1 configured -- resuming normal operations
    [Wed May 13 10:29:19.200216 2015] [core:notice] [pid 2282] AH00094: Command line: '/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -D FOREGROUND'
    [Wed May 13 10:30:58.387017 2015] [mpm_prefork:notice] [pid 2282] AH00170: caught SIGWINCH, shutting down gracefully
    [Wed May 13 10:30:58.528314 2015] [ssl:warn] [pid 2450] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
    [Wed May 13 10:30:58.535039 2015] [proxy:crit] [pid 2450] AH02432: Cannot find LB Method: byrequests
    [Wed May 13 10:30:58.535056 2015] [proxy_balancer:emerg] [pid 2450] (22)Invalid argument: AH01183: Cannot share balancer
    [Wed May 13 10:30:58.535066 2015] [:emerg] [pid 2450] AH00020: Configuration Failed, exiting
    [Wed May 13 10:32:30.135620 2015] [ssl:warn] [pid 2539] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
    [Wed May 13 10:32:30.142845 2015] [proxy:crit] [pid 2539] AH02432: Cannot find LB Method: byrequests
    [Wed May 13 10:32:30.142864 2015] [proxy_balancer:emerg] [pid 2539] (22)Invalid argument: AH01183: Cannot share balancer
    [Wed May 13 10:32:30.142873 2015] [:emerg] [pid 2539] AH00020: Configuration Failed, exiting
    [Wed May 13 10:33:08.427256 2015] [ssl:warn] [pid 2627] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
    [Wed May 13 10:33:08.436409 2015] [mpm_prefork:notice] [pid 2627] AH00163: Apache/2.4.12 (Linux/SUSE) OpenSSL/1.0.1i-fips PHP/5.6.1 configured -- resuming normal operations
    [Wed May 13 10:33:08.436444 2015] [core:notice] [pid 2627] AH00094: Command line: '/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -D FOREGROUND'
    [Wed May 13 10:34:46.040829 2015] [mpm_prefork:notice] [pid 2627] AH00170: caught SIGWINCH, shutting down gracefully
    [Wed May 13 10:34:46.189313 2015] [ssl:warn] [pid 2727] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
    [Wed May 13 10:34:46.196170 2015] [proxy:crit] [pid 2727] AH02432: Cannot find LB Method: byrequests
    [Wed May 13 10:34:46.196188 2015] [proxy_balancer:emerg] [pid 2727] (22)Invalid argument: AH01183: Cannot share balancer
    [Wed May 13 10:34:46.196198 2015] [:emerg] [pid 2727] AH00020: Configuration Failed, exiting
    [Wed May 13 10:49:54.418985 2015] [ssl:warn] [pid 3322] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
    [Wed May 13 10:49:54.426171 2015] [proxy:crit] [pid 3322] AH02432: Cannot find LB Method: byrequests
    [Wed May 13 10:49:54.426189 2015] [proxy_balancer:emerg] [pid 3322] (22)Invalid argument: AH01183: Cannot share balancer
    [Wed May 13 10:49:54.426199 2015] [:emerg] [pid 3322] AH00020: Configuration Failed, exiting
    [Wed May 13 10:51:54.285662 2015] [ssl:warn] [pid 1373] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
    [Wed May 13 10:51:54.404376 2015] [proxy:crit] [pid 1373] AH02432: Cannot find LB Method: byrequests
    [Wed May 13 10:51:54.404396 2015] [proxy_balancer:emerg] [pid 1373] (22)Invalid argument: AH01183: Cannot share balancer
    [Wed May 13 10:51:54.404409 2015] [:emerg] [pid 1373] AH00020: Configuration Failed, exiting
    [Wed May 13 10:53:24.584095 2015] [ssl:warn] [pid 2054] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
    [Wed May 13 10:53:24.593643 2015] [mpm_prefork:notice] [pid 2054] AH00163: Apache/2.4.12 (Linux/SUSE) OpenSSL/1.0.1i-fips PHP/5.6.1 configured -- resuming normal operations
    [Wed May 13 10:53:24.593673 2015] [core:notice] [pid 2054] AH00094: Command line: '/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -D FOREGROUND'
    Last edited by amersand; 05-13-2015 at 10:10 AM.

  5. #5
    Join Date
    Sep 2007
    Location
    Germany
    Posts
    494

    Default

    Wie sieht denn die proxy_http.conf konkret aus?

  6. #6

    Default

    hi die sied so aus

    lade ich a2enmod Proxy_balancer dazu startet er garnicht mehr

    meine proxy_http.conf

    <Location /webservices>
    # Please note that the servlet path to the soap API has changed:
    # restrict access to the soap provisioning API
    Order Deny,Allow
    Deny from all
    Allow from 127.0.0.1
    # you might add more ip addresses / networks here
    # Allow from 192.168 10 172.16
    </Location>
    # the old path is kept for compatibility reasons
    <Location /servlet/axis2/services>
    # restrict access to the soap provisioning API
    Order Deny,Allow
    Deny from all
    Allow from 127.0.0.1
    # you might add more ip addresses / networks here
    # Allow from 192.168 10 172.16
    </Location>



    <IfModule mod_proxy_http.c>
    ProxyRequests Off
    # When enabled, this option will pass the Host: line from the incoming request to the proxied host.
    ProxyPreserveHost On
    <Proxy balancer://oxcluster>
    Order deny,allow
    Allow from all
    # multiple server setups need to have the hostname inserted instead localhost
    BalancerMember http://localhost:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=OX1
    # Enable and maybe add additional hosts running OX here
    # BalancerMember http://oxhost2:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=OX2
    ProxySet stickysession=JSESSIONID|jsessionid scolonpathdelim=On
    SetEnv proxy-initial-not-pooled
    SetEnv proxy-sendchunked
    </Proxy>
    # Define another Proxy Container with different timeout for the sync clients. Microsoft recommends a minimum value of 15 minutes.
    # Setting the value lower than the one defined as com.openexchange.usm.eas.ping.max_heartbeat in eas.properties will lead to connection
    # timeouts for clients. See http://support.microsoft.com/?kbid=905013 for additional information.
    #
    # NOTE for Apache versions < 2.4:
    # When using a single node system or using BalancerMembers that are assigned to other balancers please add a second hostname for that
    # BalancerMember's IP so Apache can treat it as additional BalancerMember with a different timeout.
    #
    # Example from /etc/hosts: 127.0.0.1 localhost localhost_sync
    #
    # Alternatively select one or more hosts of your cluster to be restricted to handle only eas/usm requests
    <Proxy balancer://{{{syncProxyName}}}>
    Order deny,allow
    Allow from all
    # multiple server setups need to have the hostname inserted instead localhost
    BalancerMember http://localhost_sync:8009 timeout=1900 smax=0 ttl=60 retry=60 loadfactor=50 route=OX1
    # Enable and maybe add additional hosts running OX here
    # BalancerMember http://oxhost2:8009 timeout=1900 smax=0 ttl=60 retry=60 loadfactor=50 route=OX2
    ProxySet stickysession=JSESSIONID|jsessionid scolonpathdelim=On
    SetEnv proxy-initial-not-pooled
    SetEnv proxy-sendchunked
    </Proxy>
    # OX frontend
    <Proxy /ajax>
    ProxyPass balancer://oxcluster/ajax
    </Proxy>
    <Proxy /servlet>
    ProxyPass balancer://oxcluster/servlet
    </Proxy>
    <Proxy /infostore>
    ProxyPass balancer://oxcluster/infostore
    </Proxy>
    <Proxy /publications>
    ProxyPass balancer://oxcluster/publications
    </Proxy>
    # USM
    <Proxy /usm-json>
    ProxyPass balancer://oxcluster/usm-json
    </Proxy>
    # SOAP
    <Proxy /webservices>
    ProxyPass balancer://oxcluster/webservices
    </Proxy>
    <Proxy /realtime>
    ProxyPass balancer://oxcluster/realtime
    </Proxy>
    # OXtender/EAS specific proxy container with higher timeout
    <Proxy /Microsoft-Server-ActiveSync>
    ProxyPass balancer://eas_oxcluster/Microsoft-Server-ActiveSync
    </Proxy>
    </IfModule>


    meine ox.conf
    <VirtualHost *:80>
    ServerAdmin webmaster@localhost

    DocumentRoot /srv/www/htdocs/

    <Directory /srv/www/htdocs/>
    AllowOverride None
    Order allow,deny
    allow from all
    RedirectMatch ^/$ /ox6/
    Options +FollowSymLinks +SymLinksIfOwnerMatch
    </Directory>
    # deflate
    AddOutputFilterByType DEFLATE text/html text/plain text/javascript application/javascript text/css text/xml application/xml text/x-js application/x-javascript

    # pre-compressed files
    AddType text/javascript .jsz
    AddType text/css .cssz
    AddType text/xml .xmlz
    AddType text/plain .po

    AddEncoding gzip .jsz .cssz .xmlz
    SetEnvIf Request_URI "\.(jsz|cssz|xmlz)$" no-gzip

    ExpiresActive On

    <Location /ox6>
    # Expires (via ExpiresByType to override global settings)
    ExpiresByType image/gif "access plus 6 months"
    ExpiresByType image/png "access plus 6 months"
    ExpiresByType image/jpg "access plus 6 months"
    ExpiresByType image/jpeg "access plus 6 months"
    ExpiresByType text/css "access plus 6 months"
    ExpiresByType text/html "access plus 6 months"
    ExpiresByType text/xml "access plus 6 months"
    ExpiresByType text/javascript "access plus 6 months"
    ExpiresByType text/x-js "access plus 6 months"
    ExpiresByType application/x-javascript "access plus 6 months"
    ExpiresDefault "access plus 6 months"
    Header append Cache-Control "private"
    Header unset Last-Modified
    Header unset Vary
    # Strip version
    RewriteEngine On
    RewriteRule v=\w+/(.+) $1 [L]
    # Turn off ETag
    Header unset ETag
    FileETag None
    </Location>

    <Location /ox6/ox.html>
    ExpiresByType text/html "now"
    ExpiresDefault "now"
    Header unset Last-Modified
    Header set Cache-Control "no-store, no-cache, must-revalidate, post-check=0, pre-check=0"
    # Turn off ETag
    Header unset ETag
    FileETag None
    </Location>


    dug
    amersand

  7. #7
    Join Date
    Sep 2007
    Location
    Germany
    Posts
    494

    Default

    Quote Originally Posted by amersand View Post

    meine proxy_http.conf

    # NOTE for Apache versions < 2.4:
    # When using a single node system or using BalancerMembers that are assigned to other balancers please add a second hostname for that
    # BalancerMember's IP so Apache can treat it as additional BalancerMember with a different timeout.
    #
    # Example from /etc/hosts: 127.0.0.1 localhost localhost_sync
    #
    # Alternatively select one or more hosts of your cluster to be restricted to handle only eas/usm requests
    <Proxy balancer://{{{syncProxyName}}}>
    Order deny,allow
    Allow from all
    # multiple server setups need to have the hostname inserted instead localhost
    BalancerMember http://localhost_sync:8009 timeout=1900 smax=0 ttl=60 retry=60 loadfactor=50 route=OX1
    # Enable and maybe add additional hosts running OX here
    # BalancerMember http://oxhost2:8009 timeout=1900 smax=0 ttl=60 retry=60 loadfactor=50 route=OX2
    ProxySet stickysession=JSESSIONID|jsessionid scolonpathdelim=On
    SetEnv proxy-initial-not-pooled
    SetEnv proxy-sendchunked
    </Proxy>
    Ok, da ist schonmal ein Fehler balancer://{{{syncProxyName}}}
    Da ist irgendein Template im Wiki, welches den Wert nicht korrekt ersetzt hat.
    Kannst du nachvollziehen, welche Wiki Page das war, damit man das korrigieren kann?
    Da sollte sowas stehen wie balancer://oxcluster_eas oder ähnlich. Jedenfalls ein anderer Identifier, wie vorher.

    Und dann steht da noch die NOTE für Apache, wobei die sogar verkehrt rum da steht?
    Die sollte wohl eher für Apache Versionen >= 2.4 gedacht sein und somit entsprechend beachtet werden.

  8. #8

    Default

    hier auch noch die loadmodule.conf

    LoadModule actions_module /usr/lib64/apache2-prefork/mod_actions.so
    LoadModule alias_module /usr/lib64/apache2-prefork/mod_alias.so
    LoadModule auth_basic_module /usr/lib64/apache2-prefork/mod_auth_basic.so
    LoadModule authn_file_module /usr/lib64/apache2-prefork/mod_authn_file.so
    LoadModule authz_host_module /usr/lib64/apache2-prefork/mod_authz_host.so
    LoadModule authz_groupfile_module /usr/lib64/apache2-prefork/mod_authz_groupfile.so
    LoadModule authz_user_module /usr/lib64/apache2-prefork/mod_authz_user.so
    LoadModule autoindex_module /usr/lib64/apache2-prefork/mod_autoindex.so
    LoadModule cgi_module /usr/lib64/apache2-prefork/mod_cgi.so
    LoadModule dir_module /usr/lib64/apache2-prefork/mod_dir.so
    LoadModule env_module /usr/lib64/apache2-prefork/mod_env.so
    LoadModule expires_module /usr/lib64/apache2-prefork/mod_expires.so
    LoadModule include_module /usr/lib64/apache2-prefork/mod_include.so
    LoadModule log_config_module /usr/lib64/apache2-prefork/mod_log_config.so
    LoadModule mime_module /usr/lib64/apache2-prefork/mod_mime.so
    LoadModule negotiation_module /usr/lib64/apache2-prefork/mod_negotiation.so
    LoadModule setenvif_module /usr/lib64/apache2-prefork/mod_setenvif.so
    LoadModule ssl_module /usr/lib64/apache2-prefork/mod_ssl.so
    LoadModule socache_shmcb_module /usr/lib64/apache2-prefork/mod_socache_shmcb.so
    LoadModule userdir_module /usr/lib64/apache2-prefork/mod_userdir.so
    LoadModule reqtimeout_module /usr/lib64/apache2-prefork/mod_reqtimeout.so
    LoadModule authn_core_module /usr/lib64/apache2-prefork/mod_authn_core.so
    LoadModule authz_core_module /usr/lib64/apache2-prefork/mod_authz_core.so
    LoadModule rewrite_module /usr/lib64/apache2-prefork/mod_rewrite.so
    LoadModule headers_module /usr/lib64/apache2-prefork/mod_headers.so
    LoadModule filter_module /usr/lib64/apache2-prefork/mod_filter.so
    LoadModule php5_module /usr/lib64/apache2/mod_php5.so
    LoadModule authn_dbm_module /usr/lib64/apache2-prefork/mod_authn_dbm.so
    LoadModule proxy_module /usr/lib64/apache2-prefork/mod_proxy.so
    LoadModule deflate_module /usr/lib64/apache2-prefork/mod_deflate.so
    LoadModule slotmem_shm_module /usr/lib64/apache2-prefork/mod_slotmem_shm.so
    LoadModule proxy_http_module /usr/lib64/apache2-prefork/mod_proxy_http.so

  9. #9

    Default

    hi danke für die schnelle antwort

    die conf info hatte ich von
    http://oxpedia.org/wiki/index.php?ti...for_SLES11_622

    ich ändere das mal

    muss dann der Proxy_balancer wieder dazugeladen werden???

  10. #10

    Default

    also wenn ich das richtig verstanden habe brauche ich ab < 2.4 einen zweiten alias in der host Datei

    den hatte ich aber schon eingerichtet und ist auflösbar meine host Datei ist so mom

    127.0.0.1 localhost localhost_sync

    # special IPv6 addresses
    ::1 localhost ipv6-localhost ipv6-loopback

    fe00::0 ipv6-localnet

    ff00::0 ipv6-mcastprefix
    ff02::1 ipv6-allnodes
    ff02::2 ipv6-allrouters
    ff02::3 ipv6-allhosts
    192.168.0.204 test-ox.calimero test-ox


    und hab auch in der Proxy_http.conf auf
    balancer://oxcluster_eas geändert immer noch die gleichen fehler

    wo wäre den eine richtige Anleitung für den Apache?????


    dug amersand
    Last edited by amersand; 05-13-2015 at 11:18 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •