Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: CalDav/CardDav

  1. #1
    Join Date
    May 2015
    Posts
    21

    Question CalDav/CardDav

    Hello,


    I just installed CalDav/CardDav support to OX 7.6.2 on two machines, one with Debian Stretch (x) and another with Debian Jessie (y). I see this behaviour:

    1. I can access (with Dolphin file manger) webdavs://dav.mail2.x.it/servlet/webdav.infostore/ and see files
    I can access (with Dolphin file manger) webdavs://dav.www.y.it/servlet/webdav.infostore/ and see files

    2. I can acces webdavs://dav.mail2.x.it/ and see caldav, carddav and principals folders
    I cannot acces webdavs://dav.www.y.it/ and I cannot see caldav, carddav and principals folders

    I'm quite sure installation is identical on both machines (they are on two different LANs).

    I Can't see particular errors in OX: how can I find the problem?

    Because of point 1 above network configuration seems to be ok and OX and DAV too: why only caldav/carddav doesn't work, while webdav does?


    Thanks,
    Matteo

  2. #2
    Join Date
    May 2015
    Posts
    21

    Default

    Note: with Dolphin I get the error "File or folder webdavs://dav.www.y.net/ doesn't exist", while with Cadaver command line client:

    Impossible to access to / (non enabled for WebDAV?):
    405 Method Not Allowed
    Connection to "dav.www.y.net" closed.

  3. #3
    Join Date
    May 2015
    Posts
    21

    Default

    Any ideas?

  4. #4
    Join Date
    May 2015
    Posts
    21

    Default

    From logs I can see all this:

    ==> /tmp/dav.access.log (on working server) <==
    - - [10/Jul/2015:09:53:43 +0200] "PROPFIND /servlet/ HTTP/1.1" 404 412
    - - [10/Jul/2015:09:53:44 +0200] "PROPFIND / HTTP/1.1" 207 486
    - - [10/Jul/2015:09:53:45 +0200] "PROPFIND / HTTP/1.1" 207 426
    - - [10/Jul/2015:09:53:45 +0200] "PROPFIND / HTTP/1.1" 207 426
    - - [10/Jul/2015:09:53:46 +0200] "PROPFIND / HTTP/1.1" 207 426
    - - [10/Jul/2015:09:53:46 +0200] "PROPFIND / HTTP/1.1" 207 426

    ==> /tmp/dav.access.log (on NOT working server) <==
    - - [10/Jul/2015:09:51:10 +0200] "PROPFIND /servlet/webdav.infostore HTTP/1.1" 207 1111
    - - [10/Jul/2015:09:51:13 +0200] "PROPFIND /servlet/webdav.infostore HTTP/1.1" 207 1111
    - - [10/Jul/2015:09:51:15 +0200] "PROPFIND /servlet/ HTTP/1.1" 404 1068
    - - [10/Jul/2015:09:51:15 +0200] "PROPFIND / HTTP/1.1" 405 312
    - - [10/Jul/2015:09:51:16 +0200] "PROPFIND / HTTP/1.1" 405 312
    - - [10/Jul/2015:09:51:16 +0200] "PROPFIND / HTTP/1.1" 405 312
    - - [10/Jul/2015:09:51:16 +0200] "PROPFIND / HTTP/1.1" 405 312
    - - [10/Jul/2015:09:51:17 +0200] "PROPFIND / HTTP/1.1" 405 312


    PS: for configuration I followed this document: http://oxpedia.org/wiki/index.php?ti...arddav_Bundles

    Matteo

  5. #5
    Join Date
    Jul 2015
    Posts
    8

    Default

    I was wondering if you solved this problem, I'm experiencing the same issues with Caldav.

  6. #6
    Join Date
    May 2015
    Posts
    21

    Default

    Unfortunately no. If you solve it, please, post your solution.

  7. #7
    Join Date
    Jul 2015
    Posts
    8

    Default

    Quote Originally Posted by MatteoC View Post
    Unfortunately no. If you solve it, please, post your solution.
    It is not really solved, but more or less a work-around.

    I changed from Ubuntu 14.04 to Debian 7.8 and everything was working right away after following the wiki.

    I think that the problem are caused by Apache 2.4 (default on the Ubuntu repositories), Debian is running default Apache 2.2.
    Looking at this site http://httpd.apache.org/docs/2.4/upgrading.html it seems there are some fundamental changes between the two versions, I tried to resolve them, but unfortunately failed.

    Maybe another way would be downgrading Apache on Ubuntu.

  8. #8
    Join Date
    May 2015
    Posts
    21

    Default

    Quote Originally Posted by BlackBurn View Post
    I think that the problem are caused by Apache 2.4 (default on the Ubuntu repositories), Debian is running default Apache 2.2.
    Looking at this site http://httpd.apache.org/docs/2.4/upgrading.html it seems there are some fundamental changes between the two versions, I tried to resolve them, but unfortunately failed.
    Thanks, yes, it could be that:
    * my working configuration is on Debian 7.9 with Apache 2.2.22;
    * my not working configuration is on Debian stretch/sid with Apache 2.4.16.

    I'll take a look to these documents ASAP:
    * https://forum.open-xchange.com/showt...d-Apache2-v2-4
    * http://oxpedia.org/wiki/index.php?ti..._configuration

  9. #9
    Join Date
    Apr 2011
    Posts
    27

    Default

    Hello,

    I'm getting the same problem, did you finally solved it?

    Jérôme.

  10. #10
    Join Date
    Apr 2011
    Posts
    27

    Default

    We finally found the solution, the cause is apache configuration changes, here's an example of working configuration with apache 2.4 on debian Jessie (1 file for proxy configuration and a virtualhost for caldav/carddav):

    proxy configuration (in /etc/apache2/mods-available/proxy_ox.conf)

    Code:
    # open-xchange proxy configuration
    <Location /webservices>
        # restrict access to the soap provisioning API
        Require host 127.0.0.1
        Require ip 192.168.15
    </Location>
    
    # the old path is kept for compatibility reasons
    <Location /servlet/axis2/services>
        Require host 127.0.0.1
    </Location>
    
    # Enable the balancer manager mentioned in
    # http://oxpedia.org/wiki/index.php?title=AppSuite:Running_a_cluster#Updating_a_Cluster                                                                                                                                                                                        
    <IfModule mod_status.c>                                                                                                                                                                                                                                                        
        <Location /balancer-manager>                                                                                                                                                                                                                                               
            SetHandler balancer-manager                                                                                                                                                                                                                                            
            Require host 127.0.0.1                                                                                                                                                                                                                                                 
        </Location>                                                                                                                                                                                                                                                                
    </IfModule>                                                                                                                                                                                                                                                                    
                                                                                                                                                                                                                                                                                   
    <IfModule mod_proxy_http.c>                                                                                                                                                                                                                                                    
        ProxyRequests Off                                                                                                                                                                                                                                                          
        # When enabled, this option will pass the Host: line from the incoming request to the proxied host.                                                                                                                                                                        
        ProxyPreserveHost On
        <Proxy balancer://oxcluster>
            Require all granted
            # multiple server setups need to have the hostname inserted instead localhost
            BalancerMember http://localhost:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=APP1
            # Enable and maybe add additional hosts running OX here
            # BalancerMember http://oxhost2:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=APP2
            ProxySet stickysession=JSESSIONID|jsessionid scolonpathdelim=On
            SetEnv proxy-initial-not-pooled
            SetEnv proxy-sendchunked
        </Proxy>
    
        ProxyPass /ajax balancer://oxcluster/ajax
        ProxyPass /appsuite/api balancer://oxcluster/ajax
        ProxyPass /drive balancer://oxcluster/drive
        ProxyPass /infostore balancer://oxcluster/infostore
        ProxyPass /publications balancer://oxcluster/publications
        ProxyPass /realtime balancer://oxcluster/realtime
        ProxyPass /servlet balancer://oxcluster/servlet
        ProxyPass /webservices balancer://oxcluster/webservices
    
        #ProxyPass /documentconverterws balancer://oxcluster_docs/documentconverterws
    
        ProxyPass /usm-json balancer://eas_oxcluster/usm-json
        ProxyPass /Microsoft-Server-ActiveSync balancer://eas_oxcluster/Microsoft-Server-ActiveSync
    </IfModule>
    Caldav/Carddav virtualhost (adapt it for https if needed):

    Code:
    <VirtualHost *:80>
      ServerName dav.yourdomain.org
      ServerSignature Off
      CustomLog ${APACHE_LOG_DIR}/dav-access.log combined
      ErrorLog ${APACHE_LOG_DIR}/dav-error.log
    
      # proxy configuration include
      Include /etc/apache2/conf-available/proxy_http.conf
    
      <Proxy balancer://oxserver-sync>
        Require all granted
        # for grizzly http service
        BalancerMember http://localhost:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=OX1
        # uncomment this entry if you have a clustered setup and want to use the other nodes too
        # BalancerMember http://<ip-of-other-host>:3008 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=OX2
        # for ajp http service (on systems < 7.6.0)
        # BalancerMember ajp://localhost:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=OX1
        SetEnv proxy-initial-not-pooled
        SetEnv proxy-sendchunked
      </Proxy>
    
      ProxyPass / balancer://oxserver-sync/servlet/dav/
    </VirtualHost>
    Tell me if it's solving your problems please.

    Jérôme.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •