With the upcoming version 7.8.0 we depend on a Java 7 compatible JVM configured as the default system JVM. This has to be set up before starting the update process or the update will fail with

ERROR:

Your current system JVM doesn't meet our minimum requirements.
Please select a Java 7 compatible system JVM as your default.

Furthermore the startup of the server will fail and log the same error to open-xchange-console.log if an incompatible JVM is detected during startup.