Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34
  1. #1
    altariq Guest

    Default ox-gui build failed

    I tried to setup ox on a new server. Before i had different errormessages and now i still have errors. I have 3 times to set up ox but every time i try this, i got different error messages.

    1. error
    Code:
    /opt/open-xchange/sbin/oxinstaller --oxdb-pass=mypass --admin-pass=mypass --maildomain wullbrandtundseele.de
    initializing database (step 1/2) done
    Configuring services
    setting readUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/admindaemon/configdb.properties
    setting readUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeUrl in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting readProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.1 in /opt/open-xchange/etc/groupware/configdb.properties
    setting writeProperty.2 in /opt/open-xchange/etc/groupware/configdb.properties
    (Re)Starting Admin Daemon done
    initializing database (step 2/2)Server response:
     java.sql.SQLException: Server connection failure during transaction. Due to underlying exception: 'java.sql.SQLException: Access denied for user 'openexchange'@'localhost' (using password: YES)'.
    
    ** BEGIN NESTED EXCEPTION ** 
    
    java.sql.SQLException
    MESSAGE: Access denied for user 'openexchange'@'localhost' (using password: YES)
    
    STACKTRACE:
    
    java.sql.SQLException: Access denied for user 'openexchange'@'localhost' (using password: YES)
            at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:2975)
            at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:798)
            at com.mysql.jdbc.MysqlIO.secureAuth411(MysqlIO.java:3715)
            at com.mysql.jdbc.MysqlIO.doHandshake(MysqlIO.java:1203)
            at com.mysql.jdbc.Connection.createNewIO(Connection.java:2693)
            at com.mysql.jdbc.Connection.<init>(Connection.java:1485)
            at com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDriver.java:266)
            at java.sql.DriverManager.getConnection(DriverManager.java:525)
            at java.sql.DriverManager.getConnection(DriverManager.java:171)
            at com.openexchange.admin.tools.AdminCacheExtended.getSimpleSqlConnection(AdminCacheExtended.java:178)
            at com.openexchange.admin.storage.mysqlStorage.OXContextMySQLStorage.createDatabase(OXContextMySQLStorage.java:741)
            at com.openexchange.admin.storage.mysqlStorage.OXContextMySQLStorage.create(OXContextMySQLStorage.java:382)
            at com.openexchange.admin.rmi.impl.OXContextLightImpl.create(OXContextLightImpl.java:98)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:585)
            at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:294)
            at sun.rmi.transport.Transport$1.run(Transport.java:153)
            at java.security.AccessController.doPrivileged(Native Method)
            at sun.rmi.transport.Transport.serviceCall(Transport.java:149)
            at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:466)
            at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:707)
            at java.lang.Thread.run(Thread.java:595)
    
    
    ** END NESTED EXCEPTION **
    
    
    Attempted reconnect 3 times. Giving up.
     done
    2. error
    Code:
     ant -Dlib.dir=/opt/open-xchange/lib/ -lib /opt/open-xchange/lib deploy
    Buildfile: build.xml
    
    css:
         [xslt] DEPRECATED - xalan processor is deprecated. Use trax instead.
         [xslt] DEPRECATED - xslp processor is deprecated. Use trax instead.
         [xslt] java.lang.ClassNotFoundException: org.apache.tools.ant.taskdefs.optional.XslpLiaison
         [xslt]     at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
         [xslt]     at java.security.AccessController.doPrivileged(Native Method)
         [xslt]     at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
         [xslt]     at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
         [xslt]     at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
         [xslt]     at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
         [xslt]     at java.lang.Class.forName0(Native Method)
         [xslt]     at java.lang.Class.forName(Class.java:164)
         [xslt]     at org.apache.tools.ant.taskdefs.XSLTProcess.loadClass(XSLTProcess.java:419)
         [xslt]     at org.apache.tools.ant.taskdefs.XSLTProcess.resolveProcessor(XSLTProcess.java:397)
         [xslt]     at org.apache.tools.ant.taskdefs.XSLTProcess.getLiaison(XSLTProcess.java:619)
         [xslt]     at org.apache.tools.ant.taskdefs.XSLTProcess.execute(XSLTProcess.java:212)
         [xslt]     at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
         [xslt]     at org.apache.tools.ant.Task.perform(Task.java:364)
         [xslt]     at org.apache.tools.ant.Target.execute(Target.java:341)
         [xslt]     at org.apache.tools.ant.Target.performTasks(Target.java:369)
         [xslt]     at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
         [xslt]     at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
         [xslt]     at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:40)
         [xslt]     at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
         [xslt]     at org.apache.tools.ant.Main.runBuild(Main.java:668)
         [xslt]     at org.apache.tools.ant.Main.startAnt(Main.java:187)
         [xslt]     at org.apache.tools.ant.launch.Launcher.run(Launcher.java:246)
         [xslt]     at org.apache.tools.ant.launch.Launcher.main(Launcher.java:67)
         [xslt] java.lang.ClassNotFoundException: org.apache.tools.ant.taskdefs.optional.XalanLiaison
         [xslt]     at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
         [xslt]     at java.security.AccessController.doPrivileged(Native Method)
         [xslt]     at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
         [xslt]     at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
         [xslt]     at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
         [xslt]     at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
         [xslt]     at java.lang.Class.forName0(Native Method)
         [xslt]     at java.lang.Class.forName(Class.java:164)
         [xslt]     at org.apache.tools.ant.taskdefs.XSLTProcess.loadClass(XSLTProcess.java:419)
         [xslt]     at org.apache.tools.ant.taskdefs.XSLTProcess.resolveProcessor(XSLTProcess.java:402)
         [xslt]     at org.apache.tools.ant.taskdefs.XSLTProcess.getLiaison(XSLTProcess.java:616)
         [xslt]     at org.apache.tools.ant.taskdefs.XSLTProcess.execute(XSLTProcess.java:212)
         [xslt]     at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
         [xslt]     at org.apache.tools.ant.Task.perform(Task.java:364)
         [xslt]     at org.apache.tools.ant.Target.execute(Target.java:341)
         [xslt]     at org.apache.tools.ant.Target.performTasks(Target.java:369)
         [xslt]     at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
         [xslt]     at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
         [xslt]     at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:40)
         [xslt]     at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
         [xslt]     at org.apache.tools.ant.Main.runBuild(Main.java:668)
         [xslt]     at org.apache.tools.ant.Main.startAnt(Main.java:187)
         [xslt]     at org.apache.tools.ant.launch.Launcher.run(Launcher.java:246)
         [xslt]     at org.apache.tools.ant.launch.Launcher.main(Launcher.java:67)
    
    BUILD FAILED
    /tmp/open-xchange-gui/build.xml:57: java.lang.ClassNotFoundException: org.apache.tools.ant.taskdefs.optional.TraXLiaison
    
    Total time: 0 seconds
    root@wullbrandtundseele:/tmp/open-xchange-gui#
    Then there is a bug report here:
    http://www.open-xchange.org/bugzilla...ug.cgi?id=6344
    But sorry, what does Frederic Beuserie in message 6 mean? I dont know what to do now.

  2. #2
    altariq Guest

    Default

    Whats with this:

    Check the open-xchange-groupware configdb configuration file and modify it to your needs (database user / passwords)

    & /opt/open-xchange/etc/groupware/configdb.properties

    Which user and which password?


    /opt/open-xchange/sbin/open-xchange-groupware

    Here i have the same problem i had before:

    http://www.open-xchange.org/bugzilla...ug.cgi?id=6341

  3. #3
    altariq Guest

    Default

    is anybody still alive here?

  4. #4
    oprocopio Guest

    Default

    hi,

    I hope I can help you...

    1. error

    can you check if open-xchange-admin is running?
    pls check also if open-change-groupware is running.

    2. error

    do you have the correct mysql-lib version?

    orlando

  5. #5
    altariq Guest

    Default

    What do you mean with mysql-lib? Which package?

    admin and groupware are not realy running.
    I can start both without problems but when i try to stop it i got this error:


    Stopping Open-Xchange Groupware: start-stop-daemon: warning: failed to kill 14374: No such process
    1 pids were not killed
    No process in pidfile `/var/run/open-xchange-groupware.pid' found running; none killed.
    open-xchange-groupware

  6. #6
    oprocopio Guest

    Talking

    i'm not sure, but if open-xchange-admin doesn't run you can't start the oxinstaller.

    You need mysql-connector-java-3.1.13-bin.jar. if you use mysql-connector-java-3.1.14-bin.jar the you need to create a symlink.

    Try to download mysql-connector-java-3.1.13-bin.jar and the re-compile the admin and the groupware part.

    orlando

    ps: do you have stored all you libs in /opt/open-xchange/lib ?
    ps2: sorry for my bad english

  7. #7
    altariq Guest

    Default

    2 weeks ago i started with my first installation. so i took these files. i will download all files again and try it again. i hope it will work then.

    and sorry for my bad english to i think most of the members here arent nativ speakers. but its better than spanish or frensh

  8. #8
    altariq Guest

    Default Close pls

    okay now it works fine but next error:

    oxadmin cant login. error message is, that username or password is wrong.
    when i want to create a new user i got this:

    /opt/open-xchange/sbin/createuser -A oxadmin -P "mypass" --username andreas.muenten --displayname "Andreas Muenten" --password userpass --email andreas.muenten@mycomp.de --givenname Andreas --surname Muenten --language de_DE --timezone Europe/Berlin --department Decryption --company "My Comp GmbH & Co. KG"
    Server response:
    com.openexchange.admin.exceptions.PoolException: DBP-0002 Category=8 Message=Resolving database for context 1 and server 2 not possible! exceptionID=789480766-1
    Last edited by altariq; 03-20-2007 at 04:18 PM.

  9. #9
    altariq Guest

    Default

    And here is something interesting:

    Build: 0, 2007-03-20 14:09:39

    what can i do?

  10. #10
    altariq Guest

    Default

    I've only time tomorrow to finish my work with ox.
    It doesnt work and i have to add more than 100 users to ox and cyrus. Please give me tipps and hints so i can solve my problems.
    On Thursday a sister company of our company needs the server.


    Im back here tomorrow morning. So here a few logs and hints. Maybe it willl help you.

    your compiling open-xchange-gui i have to use he second command:

    & ant -Dlib.dir=/opt/open-xchange/lib/ -lib /opt/open-xchange/lib deploy

    because of the XSLT errors.
    Last edited by altariq; 03-20-2007 at 06:24 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •