Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 4 of 4
  1. #1
    Join Date
    Oct 2014
    Posts
    15

    Default OX AppSuite 7.8 Update: Auth Ldap doesn't work anymore

    Hi everyone,

    I've got a Problem on our testing infrastructure: The update Ox to the latest release breaks the LoginSystem and so on makes ox useless:

    1) Webinterface reports "A necessarcy service is not available (SRV-0001)"
    2) Open-xchange.log.x reports "The required service com.openexchange.authentication.AuthenticationServ ice is temporary not available. Please try again later."
    3) listbundles lists
    com.openexchange.admin status: RESOLVED
    com.openexchange.authentication.ldap status: RESOLVED
    3) open-xchange-osgi.log reports:
    !ENTRY com.openexchange.admin 4 0 2015-10-10 13:18:57.516
    !MESSAGE FrameworkEvent ERROR
    !STACK 0
    java.lang.IllegalStateException: BundleContext is no longer valid
    at org.eclipse.osgi.internal.framework.BundleContextI mpl.checkValid(BundleContextImpl.java:983)
    at org.eclipse.osgi.internal.framework.BundleContextI mpl.ungetService(BundleContextImpl.java:659)
    at org.osgi.util.tracker.ServiceTracker.removedServic e(ServiceTracker.java:459)
    at com.openexchange.osgi.DeferredActivator$DeferredSe rviceTracker.removedService(DeferredActivator.java :196)
    at org.osgi.util.tracker.ServiceTracker$Tracked.custo mizerRemoved(ServiceTracker.java:967)
    at org.osgi.util.tracker.ServiceTracker$Tracked.custo mizerRemoved(ServiceTracker.java:1)
    at org.osgi.util.tracker.AbstractTracked.trackAdding( AbstractTracked.java:286)
    at org.osgi.util.tracker.AbstractTracked.track(Abstra ctTracked.java:229)
    at org.osgi.util.tracker.ServiceTracker$Tracked.servi ceChanged(ServiceTracker.java:901)
    at org.eclipse.osgi.internal.serviceregistry.Filtered ServiceListener.serviceChanged(FilteredServiceList ener.java:109)
    at org.eclipse.osgi.internal.framework.BundleContextI mpl.dispatchEvent(BundleContextImpl.java:914)
    at org.eclipse.osgi.framework.eventmgr.EventManager.d ispatchEvent(EventManager.java:230)
    at org.eclipse.osgi.framework.eventmgr.ListenerQueue. dispatchEventSynchronous(ListenerQueue.java:148)
    at org.eclipse.osgi.internal.serviceregistry.ServiceR egistry.publishServiceEventPrivileged(ServiceRegis try.java:862)
    at org.eclipse.osgi.internal.serviceregistry.ServiceR egistry.publishServiceEvent(ServiceRegistry.java:8 01)
    at org.eclipse.osgi.internal.serviceregistry.ServiceR egistrationImpl.register(ServiceRegistrationImpl.j ava:127)
    at org.eclipse.osgi.internal.serviceregistry.ServiceR egistry.registerService(ServiceRegistry.java:225)
    at org.eclipse.osgi.internal.framework.BundleContextI mpl.registerService(BundleContextImpl.java:464)
    at org.eclipse.osgi.internal.framework.BundleContextI mpl.registerService(BundleContextImpl.java:482)
    at org.eclipse.osgi.internal.framework.BundleContextI mpl.registerService(BundleContextImpl.java:998)
    at com.openexchange.osgi.HousekeepingActivator.regist erService(HousekeepingActivator.java:275)
    at com.openexchange.config.osgi.ConfigActivator.start Bundle(ConfigActivator.java:96)
    at com.openexchange.osgi.DeferredActivator.startUp(De ferredActivator.java:542)
    at com.openexchange.osgi.DeferredActivator.init(Defer redActivator.java:305)
    at com.openexchange.osgi.DeferredActivator.start(Defe rredActivator.java:514)
    at com.openexchange.osgi.HousekeepingActivator.start( HousekeepingActivator.java:202)
    at org.eclipse.osgi.internal.framework.BundleContextI mpl$3.run(BundleContextImpl.java:771)
    at org.eclipse.osgi.internal.framework.BundleContextI mpl$3.run(BundleContextImpl.java:1)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.eclipse.osgi.internal.framework.BundleContextI mpl.startActivator(BundleContextImpl.java:764)
    at org.eclipse.osgi.internal.framework.BundleContextI mpl.start(BundleContextImpl.java:721)
    at org.eclipse.osgi.internal.framework.EquinoxBundle. startWorker0(EquinoxBundle.java:936)
    at org.eclipse.osgi.internal.framework.EquinoxBundle$ EquinoxModule.startWorker(EquinoxBundle.java:319)
    at org.eclipse.osgi.container.Module.doStart(Module.j ava:571)
    at org.eclipse.osgi.container.Module.start(Module.jav a:439)
    at org.eclipse.osgi.container.ModuleContainer$Contain erStartLevel.incStartLevel(ModuleContainer.java:15 82)
    at org.eclipse.osgi.container.ModuleContainer$Contain erStartLevel.incStartLevel(ModuleContainer.java:15 62)
    at org.eclipse.osgi.container.ModuleContainer$Contain erStartLevel.doContainerStartLevel(ModuleContainer .java:1533)
    at org.eclipse.osgi.container.ModuleContainer$Contain erStartLevel.dispatchEvent(ModuleContainer.java:14 76)
    at org.eclipse.osgi.container.ModuleContainer$Contain erStartLevel.dispatchEvent(ModuleContainer.java:1)
    at org.eclipse.osgi.framework.eventmgr.EventManager.d ispatchEvent(EventManager.java:230)
    at org.eclipse.osgi.framework.eventmgr.EventManager$E ventThread.run(EventManager.java:340)

    !ENTRY org.eclipse.osgi 4 0 2015-10-10 13:19:05.800
    !MESSAGE Bundle com.openexchange.admin_7.8.0 [12] is not active.

    !ENTRY org.eclipse.osgi 4 0 2015-10-10 13:19:05.800
    !MESSAGE Bundle com.openexchange.authentication.ldap_7.8.0 [18] is not active.
    The stack is the same for the ldap bundle...
    4) listcontext fails with
    contexts could not be listed:
    Server response:
    Look-up failed. Service "OXContext_V2" is not available.
    at sun.rmi.registry.RegistryImpl.lookup(RegistryImpl. java:137)
    at sun.rmi.registry.RegistryImpl_Skel.dispatch(Unknow n Source)
    at sun.rmi.server.UnicastServerRef.oldDispatch(Unicas tServerRef.java:409)
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastSe rverRef.java:267)
    at sun.rmi.transport.Transport$2.run(Transport.java:2 02)
    at sun.rmi.transport.Transport$2.run(Transport.java:1 99)
    at java.security.AccessController.doPrivileged(Native Method)
    at sun.rmi.transport.Transport.serviceCall(Transport. java:198)
    at sun.rmi.transport.tcp.TCPTransport.handleMessages( TCPTransport.java:567)
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er.run0(TCPTransport.java:828)
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er.access$400(TCPTransport.java:619)
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er$1.run(TCPTransport.java:684)
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er$1.run(TCPTransport.java:681)
    at java.security.AccessController.doPrivileged(Native Method)
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandl er.run(TCPTransport.java:681)
    at java.util.concurrent.ThreadPoolExecutor.runWorker( ThreadPoolExecutor.java:1145)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:615)
    at java.lang.Thread.run(Thread.java:745)
    at sun.rmi.transport.StreamRemoteCall.exceptionReceiv edFromServer(StreamRemoteCall.java:275)
    at sun.rmi.transport.StreamRemoteCall.executeCall(Str eamRemoteCall.java:252)
    at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:3 78)
    at sun.rmi.registry.RegistryImpl_Stub.lookup(Unknown Source)
    at java.rmi.Naming.lookup(Naming.java:101)
    at com.openexchange.admin.console.context.List.mainca ll(List.java:79)
    at com.openexchange.admin.console.context.ListCore.co mmonfunctions(ListCore.java:102)
    at com.openexchange.admin.console.context.List.<init> (List.java:70)
    at com.openexchange.admin.console.context.List.main(L ist.java:74)
    ------------------------------------------------------

    Accordingly to the update notes I already rerun generatempasswd, however, without success

    Does anybody has a idea?
    Last edited by KeepXtreme; 10-10-2015 at 03:04 PM.

  2. #2
    Join Date
    Feb 2014
    Posts
    21

    Default

    hi

    have a look at

    /opt/open-xchange/etc/ldapauth.properties

    and look at the new option "bindOnly=false" and "ldapScope=subtree"
    and "subtreeSearch=true" died

    for me that works.

    mfg.
    A.Hingerl

  3. #3
    Join Date
    Oct 2014
    Posts
    15

    Default

    thanks for the hint. This solved the problem relating the ldap-auth. However, the admin-bundle still isn't working. Any idea which changed parameter causes this?

    btw. I'll definitly hope for a configtest for ox, too often I'got trouble about changed paramters...

  4. #4
    Join Date
    Jul 2015
    Posts
    8

    Default

    Where you able to solve the admin-bundle issue?
    Got exactly the same problem.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •