Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2008
    Posts
    107

    Default OX-Guard combined with Apache 2.4

    Hello,

    for testing reasons I've got a Debian 8 Server (with Apache 2.4 and OX incl. Guard) besides my productive Server, that is running with Ubuntu 12.04 (Apache 2.2).

    The Installation of OX was in both cases done by an Install Script, so there should be no miss configuration happened.

    Everything works fine on both systems, but Guard on Debian. I can't change the security credentials. Guard suggests, that everything is ok, but I can't give in my initial password etc. It seems, as if the initial user setup is already complete, but it isn't.

    As everything else is the same, can Apache (resp. the "proxy_http.conf") cause the trouble?

    Here is the content of my /etc/apache2/conf-available:
    Code:
    <Location /webservices>
        Require all denied
        Allow from 127.0.0.1
    </Location>
    
    <Location /servlet/axis2/services>
        Require all denied
        Allow from 127.0.0.1
    </Location>
    
    
    
    <IfModule mod_proxy_http.c>
       ProxyRequests Off
       # When enabled, this option will pass the Host: line from the incoming request to the proxied host.
    #  ProxyPreserveHost On
       ProxyPreserveHost Off
       <Proxy balancer://oxcluster>
           Require all granted
           # multiple server setups need to have the hostname inserted instead localhost
           BalancerMember http://localhost:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=OX1
           # Enable and maybe add additional hosts running OX here
           # BalancerMember http://oxhost2:8009 timeout=100  smax=0 ttl=60 retry=60 loadfactor=50 route=OX2
          ProxySet stickysession=JSESSIONID|jsessionid scolonpathdelim=On
          SetEnv proxy-initial-not-pooled
          SetEnv proxy-sendchunked
       </Proxy>
       # Microsoft recommends a minimum timeout value of 15 minutes for eas connections
       <Proxy balancer://eas_oxcluster>
          Require all granted
          # multiple server setups need to have the hostname inserted instead localhost
          BalancerMember http://localhost:8009 timeout=1800 smax=0 ttl=60 retry=60 loadfactor=50 route=OX1
          # Enable and maybe add additional hosts running OX here
          # BalancerMember http://oxhost2:8009 timeout=1800  smax=0 ttl=60 retry=60 loadfactor=50 route=OX2
          ProxySet stickysession=JSESSIONID|jsessionid scolonpathdelim=On
          SetEnv proxy-initial-not-pooled
          SetEnv proxy-sendchunked
       </Proxy>
       #
       <Proxy balancer://oxguard>
           Require all granted
           BalancerMember http://localhost:8080/oxguard timeout=1800 smax=0 ttl=60 retry=60 loadfactor=100 route=OX1
           ProxySet stickysession=JSESSIONID|jsessionid scolonpathdelim=ON
           SetEnv proxy-initial-not-pooled
           SetEnv proxy-sendchunked
       </Proxy>
    
    
    ProxyPass /appsuite/api/oxguard balancer://oxguard
    
       # OX AppSuite frontend
       <Location /appsuite/api>
           ProxyPass balancer://oxcluster/ajax
       </Location>
    
       # OX frontend
       <Location /ajax>
           ProxyPass balancer://oxcluster/ajax
       </Location>
       <Location /servlet>
           ProxyPass balancer://oxcluster/servlet
       </Location>
       <Location /infostore>
           ProxyPass balancer://oxcluster/infostore
       </Location>
       <Location /publications>
           ProxyPass balancer://oxcluster/publications
       </Location>
       # USM
       <Location /usm-json>
           ProxyPass balancer://oxcluster/usm-json
       </Location>
       # SOAP
       <Location /webservices>
           ProxyPass balancer://oxcluster/webservices
      </Location>
      <Location /realtime>
           ProxyPass balancer://oxcluster/realtime
      </Location>
       # OXtender/EAS specific proxy container with higher timeout
       <Location /Microsoft-Server-ActiveSync>
           ProxyPass balancer://eas_oxcluster/Microsoft-Server-ActiveSync
       </Location>
    </IfModule>
    Please help - I've got no further idea. If additional information is required, please post.

    Many thanks in advance.
    Viele Gre
    Rene

    OS: Ubuntu Server amd64 12.4 LTS
    JRE: openjdk-7-jre, MySQL: 5.5, Apache 2.2, Dovecot 2.0.19
    OX-Server backend: OXSE latest
    OX-frontend: OXSE latest appsuite + ox6

  2. #2
    Join Date
    Sep 2007
    Location
    Germany
    Posts
    494

    Default

    Do you find any errors in OX, guard or apache logs?
    Can you check with Firebug if you see AJAX requests failing?

  3. #3
    Join Date
    Aug 2008
    Posts
    107

    Default

    Thanks Wolfgang for your reply.

    Meanwhile I change some things in my /etc/apache2/conf-available/proxy_http.conf

    This is the new one, with which it works fine in combination with Apache2 v2.4:
    Code:
    <IfModule mod_proxy_http.c>
       ProxyRequests Off
       ProxyStatus On
       # When enabled, this option will pass the Host: line from the incoming request to the proxied host.
       ProxyPreserveHost On
       # Please note that the servlet path to the soap API has changed:
       <Location /webservices>
           # restrict access to the soap provisioning API
           Order Deny,Allow
           Deny from all
           Allow from 127.0.0.1
           # you might add more ip addresses / networks here
           # Allow from 192.168 10 172.16
       </Location>
     
       # The old path is kept for compatibility reasons
       <Location /servlet/axis2/services>
           Order Deny,Allow
           Deny from all
           Allow from 127.0.0.1
       </Location>
       
       # Enable the balancer manager mentioned in
       # http://oxpedia.org/wiki/index.php?title=AppSuite:Running_a_cluster#Updating_a_Cluster
       <IfModule mod_status.c>
         <Location /balancer-manager>
           SetHandler balancer-manager
           Order Deny,Allow
           Deny from all
           Allow from 127.0.0.1
         </Location>
       </IfModule>
    
       <Proxy balancer://oxguard>
           Order deny,allow
           Allow from all
           BalancerMember http://localhost:8080/oxguard timeout=1800 smax=0 ttl=60 retry=60 loadfactor=100 route=OX1
           ProxySet stickysession=JSESSIONID|jsessionid scolonpathdelim=ON
           SetEnv proxy-initial-not-pooled
           SetEnv proxy-sendchunked
       </Proxy>
       
       <Proxy balancer://oxcluster>
           Order deny,allow
           Allow from all
           # multiple server setups need to have the hostname inserted instead localhost
           BalancerMember http://localhost:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=APP1
           # Enable and maybe add additional hosts running OX here
           # BalancerMember http://oxhost2:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 route=APP2
          ProxySet stickysession=JSESSIONID|jsessionid scolonpathdelim=On
          SetEnv proxy-initial-not-pooled
          SetEnv proxy-sendchunked
       </Proxy>
       
       # The standalone documentconverter(s) within your setup (if installed)
       # Make sure to restrict access to backends only
       # See: http://httpd.apache.org/docs/$YOUR_VERSION/mod/mod_authz_host.html#allow for more infos
       #<Proxy balancer://oxcluster_docs>
       #    Order Deny,Allow
       #    Deny from all
       #    Allow from backend1IP
       #    BalancerMember http://converter_host:8009 timeout=100 smax=0 ttl=60 retry=60 loadfactor=50 keepalive=On route=APP3
       #    ProxySet stickysession=JSESSIONID|jsessionid scolonpathdelim=On
       #	   SetEnv proxy-initial-not-pooled
       #    SetEnv proxy-sendchunked
       #</Proxy>
       # Define another Proxy Container with different timeout for the sync clients. Microsoft recommends a minimum value of 15 minutes.
       # Setting the value lower than the one defined as com.openexchange.usm.eas.ping.max_heartbeat in eas.properties will lead to connection
       # timeouts for clients.  See http://support.microsoft.com/?kbid=905013 for additional information.
       #
       # NOTE for Apache versions < 2.4:
       # When using a single node system or using BalancerMembers that are assigned to other balancers please add a second hostname for that
       # BalancerMember's IP so Apache can treat it as additional BalancerMember with a different timeout.
       #
       # Example from /etc/hosts: 127.0.0.1	localhost localhost_sync
       #
       # Alternatively select one or more hosts of your cluster to be restricted to handle only eas/usm requests
       <Proxy balancer://eas_oxcluster>
          Order deny,allow
          Allow from all
          # multiple server setups need to have the hostname inserted instead localhost
          BalancerMember http://localhost_sync:8009 timeout=1900 smax=0 ttl=60 retry=60 loadfactor=50 route=APP1
          # Enable and maybe add additional hosts running OX here
          # BalancerMember http://oxhost2:8009 timeout=1900  smax=0 ttl=60 retry=60 loadfactor=50 route=APP2
          ProxySet stickysession=JSESSIONID|jsessionid scolonpathdelim=On
          SetEnv proxy-initial-not-pooled
          SetEnv proxy-sendchunked
       </Proxy>
       
       # When specifying additional mappings via the ProxyPass directive be aware that the first matching rule wins. Overlapping urls of
       # mappings have to be ordered from longest URL to shortest URL.
       # 
       # Example:
       #   ProxyPass /ajax      balancer://oxcluster_with_100s_timeout/ajax
       #   ProxyPass /ajax/test balancer://oxcluster_with_200s_timeout/ajax/test
       #
       # Requests to /ajax/test would have a timeout of 100s instead of 200s 
       #   
       # See:
       # - http://httpd.apache.org/docs/current/mod/mod_proxy.html#proxypass Ordering ProxyPass Directives
       # - http://httpd.apache.org/docs/current/mod/mod_proxy.html#workers Worker Sharing
       ProxyPass /appsuite/api/oxguard balancer://oxguard
       ProxyPass /ajax balancer://oxcluster/ajax
       ProxyPass /appsuite/api balancer://oxcluster/ajax
       ProxyPass /drive balancer://oxcluster/drive
       ProxyPass /infostore balancer://oxcluster/infostore
       ProxyPass /publications balancer://oxcluster/publications
       ProxyPass /realtime balancer://oxcluster/realtime
       ProxyPass /servlet balancer://oxcluster/servlet
       ProxyPass /webservices balancer://oxcluster/webservices
    
       #ProxyPass /documentconverterws balancer://oxcluster_docs/documentconverterws
     
       ProxyPass /usm-json balancer://eas_oxcluster/usm-json
       ProxyPass /Microsoft-Server-ActiveSync balancer://eas_oxcluster/Microsoft-Server-ActiveSync
    
    </IfModule>
    Viele Gre
    Rene

    OS: Ubuntu Server amd64 12.4 LTS
    JRE: openjdk-7-jre, MySQL: 5.5, Apache 2.2, Dovecot 2.0.19
    OX-Server backend: OXSE latest
    OX-frontend: OXSE latest appsuite + ox6

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •