Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 3 of 3
  1. #1
    Join Date
    May 2015
    Posts
    21

    Default Problems with OX 7.8.0 and apache 2.4.18

    Hello,


    on Debian Stretch since a week I have a problem with updated versions of OX and Apache, while before it worked perfectly.

    When I go to OX home I get this error: "Forbidden - You don't have permission to access /appsuite/ on this server."

    In /var/log/apache2/error.log I can see: "[Mon Mar 21 09:49:17.728070 2016] [autoindex:error] [pid 32717] [client 80.16.158.206:3484] AH01276: Cannot serve directory /var/www/appsuite/: No matching DirectoryIndex (index.html,index.cgi,index.pl,index.php,index.xht ml,index.htm) found, and server-generated directory index forbidden by Options directive"

    This is part of my apache configuration:
    Code:
            DocumentRoot /var/www
            <Directory />
                    Options FollowSymLinks
                    AllowOverride None
            </Directory>
            <Directory /var/www/>
                    Options Indexes FollowSymLinks MultiViews
                    AllowOverride None
                    Order allow,deny
                    allow from all
                    RedirectMatch ^/$ /appsuite/
            </Directory>
            <Directory /var/www/appsuite>
                    Options None +SymLinksIfOwnerMatch # (*)
                    AllowOverride Indexes FileInfo
            </Directory>
    Any idea?

    If I add +Indexes here (*) I can see directory content, but nothing more...


    Thanks,
    Matteo

  2. #2
    Join Date
    Jul 2016
    Posts
    4

    Default

    Having the same issues... Any updates?

  3. #3
    Join Date
    Jul 2016
    Posts
    4

    Default

    Don't know if it was related but as my setup is not in production it was probably just the appsuite update along with Ubuntu 8 updates.. The Debian Jessie 8.0 install guide had the solution:

    Code:
    <VirtualHost *:80>
           ServerAdmin webmaster@localhost
    
           DocumentRoot /var/www/html
           <Directory /var/www/html>
                   Options Indexes FollowSymLinks MultiViews
                   AllowOverride None
                   Order allow,deny
                   allow from all
                   RedirectMatch ^/$ /appsuite/
           </Directory>
    
           <Directory /var/www/html/appsuite>
                   Options None +SymLinksIfOwnerMatch
                   AllowOverride Indexes FileInfo
           </Directory>
    </VirtualHost>
    Thus the /html needed to be added..

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •