No announcement yet.

calcengine worker does not start

  • Filter
  • Time
  • Show
Clear All
new posts

  • calcengine worker does not start

    hi all,
    if I try top open calc application in ox appsuite, I'm getting an "error occured" message.

    These are the error messages in the log file:
    2015-06-11T13:00:47,851+0200 INFO [Thread-38567] cEngineWorkerLogSink.impl_log(CalcEngineWorkerLogS
    define memory limit : 3145728 KB ...

    2015-06-11T13:00:47,963+0200 ERROR [Thread-38568] cEngineWorkerLogSink.impl_log(CalcEngineWorkerLogS
    Could not create the Java virtual machine.

    2015-06-11T13:00:47,963+0200 INFO [Thread-38567] cEngineWorkerLogSink.impl_log(CalcEngineWorkerLogS
    Error occurred during initialization of VM

    2015-06-11T13:00:47,963+0200 INFO [Thread-38567] cEngineWorkerLogSink.impl_log(CalcEngineWorkerLogS
    Could not reserve enough space for object heap

    2015-06-11T13:01:06,857+0200 ERROR [message-handler-0] vateJob(
    Worker not started in time.

    The config file "/opt/open-xchange/etc/" looks like this:
    # Defines the Java options for the groupware Java virtual machine.
    JAVA_XTRAOPTS=" -Dnetworkaddress.cache.ttl=3600 -Dnetworkaddress.cache.negative.ttl=10 -Dlogback.threadlocal.put.duplicate=false -server -Djava.awt.headless=true -Xmx2048M -XX:MaxPermSize=256m -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:NewRatio=3 -XX:+UseTLAB -XX:+DisableExplicitGC -Dosgi.compatibility.bootdelegation=false -XX:-OmitStackTraceInFastThrow"

    # Defines the Java options for all command line tools. CLTs need much less memory compared to the groupware process.

    Environment is:
    Version der Benutzeroberfläche: 7.6.2 Rev17
    Server-Version: 7.6.2-Rev18
    Runnning on Debian 7 64bit with 12Gb RAM

    Is there a way to increase the heap size?

    Thanks for any help!
    Regards Peter