No announcement yet.

Error: option -c not recognized when running createcontext

  • Filter
  • Time
  • Show
Clear All
new posts

  • Error: option -c not recognized when running createcontext


    When I run:

    /opt/open-xchange/sbin/createcontext -A oxadminmaster -P admin_master_password -c 1 \
    -u oxadmin -d "Context Admin" -g Admin -s User -p admin_password -L defaultcontext \
    -e -q 1024 --access-combination-name=all
    I get:

    Error: Unrecognized options on the command line: Unknown option ``-c'
    And if I run it without -c I get:

    com.openexchange.admin.plugins.PluginException: com.openexchange.admin.rmi.exceptions.StorageException: Table 'configdb.sequence_context' doesn't exist
    What can I do?

  • #2
    Please take care, that you follow our installation instructions. If you install packages not listed in these instructions, only do that, if you know what you are doing.

    You did install at least package open-xchange-admin-plugin-autocontextid, which is not required in most cases.


    • #3
      I might have installed it, but I didn't know it was going to give me this kind of problem, thanks for letting me know.


      • #4
        OK I got in uninstalled, configure it using ldap everything looks like it's working but when I try to login as the test user I created after I press login I get an Error 404: Not Found, what can cause this?


        • #5

          please check the Apache access.log file - or use firebug - to find out what resource cannot be found. Does the login itself work? Where and how do you get this error?


          • #6
            Yes, the login itself works, but when I put the info of the users it gives me a window that says 404 - Not found, I'll check the Logs and let you know what it says.


            • #7
              Here is the thing,

              I found the problem was with the proxy_ajp.conf location, so I moved it where it was supposed to go but now I get an error 503 with the following in the logs:

              [Mon Mar 07 20:11:58 2011] [error] (111)Connection refused: proxy: AJP: attempt to connect to (localhost) failed
              [Mon Mar 07 20:11:58 2011] [error] ap_proxy_connect_backend disabling worker for (localhost)
              Any idea?


              • #8
                Please stay with the configuration we propose at OXPedia. Checking for 404 errors simply requres checking with firebug or monitoring apache mod_access files.


                • #9
                  I did and I did not have any problems configuring Open Xchange using database authentication, so I'm trying to set it up using ldap authentication and I'm getting these errors, besides, it's no fun when everything goes the way it's supposed to and you don't learn anything from it.

                  So, please, help me find out where the problem can be, I fixed the 404 error, but I have now a 503 with the error log I put below.

                  Thanks for all your help.


                  • #10
                    Well, judging from the error message i'd say that the OX AJP Service is not running which means the groupware process is not running, maybe not listening on localhost port 8009