Announcement

Collapse
No announcement yet.

No german "÷" in ox-Basic-Folders

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Guest's Avatar
    Guest replied
    after a restart of both ox daemons, b)

    for testing, I downgraded and restarted both daemons again and the Umlaute were correct. After a second upgrade to 6.7 and now 6.8 and restart they are now incorrect again.
    Last edited by cornfelt; 01-16-2009, 04:48 PM.

    Leave a comment:


  • Carsten Hoeger
    replied
    2. When are the Umlaute broken?
    a) after a system reboot
    b) after a restart of the server on the commandline

    Leave a comment:


  • Guest's Avatar
    Guest replied
    hi carsten,

    1. we use open suse 11.0.
    2. after an upgrade from ox version 6.6 to 6.7
    I've upgraded ox because the sending of emails with atachment faild at version 6.6 with the java-1_6_0-openjdk.
    There was a conflict between java- and ox-classes.
    3. `env | grep 'L\(C\|ANG\).*'`returns
    Code:
    LANG=POSIX
    LC_CTYPE=de_DE.UTF-8
    greetings

    cornfelt
    Last edited by cornfelt; 01-16-2009, 02:07 PM.

    Leave a comment:


  • Carsten Hoeger
    replied
    1. What OS do you use?
    2. When are the Umlaute broken?
    a) after a system reboot
    b) after a restart of the server on the commandline
    3. What is the output of the command
    Code:
    env | grep 'L\(C\|ANG\).*'

    Leave a comment:


  • Guest's Avatar
    Guest replied
    thanks for your postings.
    now I've installed 6.8.0-1.1 but the problem is still there.
    I also tested some env var settings (LANG, LC_ALL), but nothing happens.

    greetings

    cornfelt

    Leave a comment:


  • outlow
    replied
    Hi,

    zur Zeit haben wir 2 unserer Server mit der Beta 6.7.0-6704 am laufen, beides Debian Installationen, Sie unterscheiden sich lediglich in der Hardware.

    Das oben beschriebene Problem haben wir ebenfalls (wie Martin sagt ist dies ja auch in der Beta bekannt), jedoch nur auf einem der beiden Server.

    Wieso Weshalb Warum kann ich nicht sagen, also wenn ich helfen kann werde ich dies gerne tun.

    MfG

    outlow

    Leave a comment:


  • mmlitz
    replied
    Nach dem aktuellen Update auf 6.7.0-6.705 sind auch die "÷`s" wieder da Build: 2009-01-14 00:01:16

    Gruss
    mmlitz

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Hello Martin

    what else could I do? Have you any other ideas?

    Greetings

    cornfelt

    Leave a comment:


  • Guest's Avatar
    Guest replied
    first, thanks for your help.

    ┤file┤ says:
    Code:
    # file /opt/open-xchange/i18n/server.de_DE.po
    /opt/open-xchange/i18n/server.de_DE.po: UTF-8 Unicode PO (gettext message catalogue) text
    Versions:
    Code:
    i | open-xchange                          | package | 6.7.0-62.1  | noarch | server:OX:snapshot
    i | open-xchange-admin                    | package | 6.7.0-38.1  | noarch | server:OX:snapshot
    i | open-xchange-admin-client             | package | 6.7.0-38.1  | noarch | server:OX:snapshot
    i | open-xchange-admin-doc                | package | 6.7.0-38.1  | noarch | server:OX:snapshot
    i | open-xchange-admin-plugin-hosting     | package | 6.7.0-21.3  | noarch | server:OX:snapshot
    i | open-xchange-admin-plugin-hosting-doc | package | 6.7.0-21.3  | noarch | server:OX:snapshot
    i | open-xchange-authentication-database  | package | 6.7.0-17.3  | noarch | server:OX:snapshot
    i | open-xchange-cache                    | package | 6.7.0-17.3  | noarch | server:OX:snapshot
    i | open-xchange-charset                  | package | 6.7.0-16.1  | noarch | server:OX:snapshot
    i | open-xchange-common                   | package | 6.7.0-22.1  | noarch | server:OX:snapshot
    i | open-xchange-configjump-generic       | package | 6.7.0-16.3  | noarch | server:OX:snapshot
    i | open-xchange-configread               | package | 6.7.0-16.3  | noarch | server:OX:snapshot
    i | open-xchange-contactcollector         | package | 6.7.0-27.3  | noarch | server:OX:snapshot
    i | open-xchange-control                  | package | 6.7.0-15.3  | noarch | server:OX:snapshot
    i | open-xchange-conversion               | package | 6.7.0-20.3  | noarch | server:OX:snapshot
    i | open-xchange-conversion-engine        | package | 6.7.0-18.3  | noarch | server:OX:snapshot
    i | open-xchange-conversion-servlet       | package | 6.7.0-18.3  | noarch | server:OX:snapshot
    i | open-xchange-data-conversion-ical4j   | package | 6.7.0-21.3  | noarch | server:OX:snapshot
    i | open-xchange-global                   | package | 6.7.0-27.1  | noarch | server:OX:snapshot
    i | open-xchange-group-managerequest      | package | 6.7.0-15.3  | noarch | server:OX:snapshot
    i | open-xchange-gui                      | package | 6.7.0-58.1  | noarch | server:OX:snapshot
    i | open-xchange-i18n                     | package | 6.7.0-26.3  | noarch | server:OX:snapshot
    i | open-xchange-imap                     | package | 6.7.0-28.1  | noarch | server:OX:snapshot
    i | open-xchange-jcharset                 | package | 1.3.0-106.1 | noarch | server:OX:snapshot
    i | open-xchange-mailfilter               | package | 6.7.0-19.3  | noarch | server:OX:snapshot
    i | open-xchange-management               | package | 6.7.0-17.3  | noarch | server:OX:snapshot
    i | open-xchange-monitoring               | package | 6.7.0-17.3  | noarch | server:OX:snapshot
    i | open-xchange-online-help-de           | package | 6.7.0-4.1   | noarch | server:OX:snapshot
    i | open-xchange-online-help-en           | package | 6.7.0-4.1   | noarch | server:OX:snapshot
    i | open-xchange-passwordchange-database  | package | 6.7.0-15.3  | noarch | server:OX:snapshot
    i | open-xchange-passwordchange-servlet   | package | 6.7.0-17.3  | noarch | server:OX:snapshot
    i | open-xchange-push-udp                 | package | 6.7.0-20.3  | noarch | server:OX:snapshot
    i | open-xchange-resource-managerequest   | package | 6.7.0-15.3  | noarch | server:OX:snapshot
    i | open-xchange-server                   | package | 6.7.0-62.1  | noarch | server:OX:snapshot
    i | open-xchange-sessiond                 | package | 6.7.0-21.3  | noarch | server:OX:snapshot
    i | open-xchange-settings-extensions      | package | 6.7.0-15.3  | noarch | server:OX:snapshot
    i | open-xchange-smtp                     | package | 6.7.0-16.3  | noarch | server:OX:snapshot
    i | open-xchange-spamhandler-default      | package | 6.7.0-15.3  | noarch | server:OX:snapshot
    i | open-xchange-xml                      | package | 6.7.0-22.1  | noarch | server:OX:snapshot
    And yes, I restarted the groupware daemon.

    cornfelt
    Last edited by cornfelt; 01-08-2009, 02:20 PM.

    Leave a comment:


  • Martin Heiland
    replied
    Hi,

    i meant the unix command "file" to determine the type of the file:
    Code:
    oxhegw01:~# file /opt/open-xchange/i18n/server.de_DE.po 
    /opt/open-xchange/i18n/server.de_DE.po: UTF-8 Unicode PO (gettext message catalogue) text
    the exception you've posted above is not related to this issue, however - we have had the exact same problem at the beta phase, but we were not able to reproduce that problem. Did you restart the groupware server yet? What version are you using exactly?

    Greetings

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Here the first 10 lines:
    Code:
    msgid ""
    msgstr ""
    "Project-Id-Version: server\n"
    "Report-Msgid-Bugs-To: \n"
    "POT-Creation-Date: 2006-11-13 15:15+0100\n"
    "PO-Revision-Date: 2008-12-15 09:44+0100\n"
    "Last-Translator: Antje Faber <antje.faber@open-xchange.com>\n"
    "Language-Team: deutsch <de@li.org>\n"
    "MIME-Version: 1.0\n"
    "Content-Type: text/plain; charset=UTF-8\n"
    "Content-Transfer-Encoding: 8bit\n"
    "Plural-Forms: nplurals=2; plural=n != 1;\n"
    "X-Generator: KBabel 1.10.2\n"
    What do you mean with "the output of file <po-file>"?
    Do you mean the outputs which I presented at my first post of this thread (attachment)?

    Additional, I can give you one example of the server.de_DE.po file:
    Code:
    #: tmp/open-xchange/server/src/com/openexchange/groupware/i18n/FolderStrings.java:61
    msgid "Public folders"
    msgstr "Íffentliche Ordner"
    cornfelt

    Leave a comment:


  • Martin Heiland
    replied
    Hi,

    could you please post the first 10 lines of the .po file and the output of "file <po-file>?

    Thanks!

    Leave a comment:


  • Guest's Avatar
    Guest replied
    The strings for the german folder names are under
    Code:
    /opt/open-xchange/i18n/server.de_DE.po
    .

    If I change the "umlaute" e.g. form "÷" to "oe" and I restart the groupware-daemon, the diamonds are gone away, but I have ugly "oe"┤s.

    So I think, there must be an java error with handling of german "Umlaute".
    On javascript-level (with the dictionary " ../htdocs/ox6/lang/de_de.js") works everything fine.

    Can someone help me, to fix this problem?

    thanks,
    cornfelt

    ps. html-replacements for german "umlaute" don't work

    additional, I get this exception:
    Code:
    Jan 7, 2009 5:14:42 PM org.apache.jcs.auxiliary.lateral.LateralCache handleException
    SEVERE: Disabling lateral cache due to error Failed to remove CacheKey: context=1 | key=46 from OXFolderCache
    java.net.SocketException: Broken pipe
            at java.net.SocketOutputStream.socketWrite0(Native Method)
            at java.net.SocketOutputStream.socketWrite(SocketOutputStream.java:109)
            at java.net.SocketOutputStream.write(SocketOutputStream.java:153)
            at java.io.ObjectOutputStream$BlockDataOutputStream.drain(ObjectOutputStream.java:1855)
            at java.io.ObjectOutputStream$BlockDataOutputStream.setBlockDataMode(ObjectOutputStream.java:1764)
            at java.io.ObjectOutputStream.writeFatalException(ObjectOutputStream.java:1558)
            at java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:346)
            at org.apache.jcs.auxiliary.lateral.socket.tcp.LateralTCPSender.send(LateralTCPSender.java:222)
            at org.apache.jcs.auxiliary.lateral.socket.tcp.LateralTCPService.remove(LateralTCPService.java:172)
            at org.apache.jcs.auxiliary.lateral.LateralCache.remove(LateralCache.java:168)
            at org.apache.jcs.engine.CacheAdaptor.handleRemove(CacheAdaptor.java:107)
            at org.apache.jcs.engine.CacheEventQueue$RemoveEvent.doRun(CacheEventQueue.java:736)
            at org.apache.jcs.engine.CacheEventQueue$AbstractCacheEvent.run(CacheEventQueue.java:607)
            at org.apache.jcs.engine.CacheEventQueue$QProcessor.run(CacheEventQueue.java:575)
    Jan 7, 2009 5:14:42 PM org.apache.jcs.engine.CacheEventQueue$AbstractCacheEvent run
    WARNING: java.net.SocketException: Broken pipe
    Last edited by cornfelt; 01-07-2009, 06:16 PM.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    no email text editor icons

    Additional, I had to find out that there are no icons in the email create window to edit the email text

    this was a cache problem.

    but, the "umlaute" are still wrong.
    Attached Files
    Last edited by cornfelt; 12-19-2008, 01:34 PM.

    Leave a comment:


  • Guest's Avatar
    Guest started a topic No german "÷" in ox-Basic-Folders

    No german "÷" in ox-Basic-Folders

    Hi,

    after an upgrade from ox version 6.6 to 6.7 i have some trouble with german "Umlaute", but not at the whole page only at two folders "÷ffentliche Ordner" and "÷ffentlicher Infostore" (look at the attachment). The Folder "EntwŘrfe" contains its umlaut.
    I get instead of the "÷" two diamonds with a question mark.

    How can fix this?

    Thanks,

    cornfelt
    Attached Files
Working...
X