Announcement

Collapse
No announcement yet.

No german "" in ox-Basic-Folders

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Guest's Avatar
    Guest replied
    oh... hat sich glaube ich erstmal erledigt
    Last edited by xordon; 03-18-2009, 03:50 PM.

    Leave a comment:


  • Martin Heiland
    replied
    Hi all,

    a program fix is now available, please see:
    http://www.open-xchange.com/forum/sh...ad.php?p=12237

    Greetings

    Leave a comment:


  • Martin Heiland
    replied
    Hi,

    if you depend on having multiple languages available for your users, this workaround may be a lot less intrusive:

    Edit
    Code:
    /opt/open-xchange/etc/groupware/ox-scriptconf.sh
    and add
    Code:
    -Dfile.encoding=UTF-8
    to the following property
    Code:
    JAVA_XTRAOPTS
    so it should look like this:
    Code:
    JAVA_XTRAOPTS="-Xms512m -Xmx512m -XX:+UseConcMarkSweepGC -XX:NewSize=256m -XX:MaxNewSize=256m -XX:SurvivorRatio=6 -Dfile.encoding=UTF-8"
    Another workaround is to manually restart the groupware process after the system has been booted.

    The problem is that the initscript that is starting the groupware at the system boot time does not use UTF8 as charset because at this stage of the startup process the environment and charset configuration is not yet loaded by the operating system, even if it is configured like this at the entire system. By adding the file encoding we force the groupware to use UTF8 no matter what the system environment says at the boot time. The other workaround (restarting after boot) is based on the fact that the users console is correctly set up to UTF8 and calling the groupware initscript will apply this charset to the process.

    Greetings
    Last edited by Martin Heiland; 02-07-2009, 03:59 AM.

    Leave a comment:


  • pezi
    replied
    Renaming the french po file solved the problem also for Centos 5.2.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    It works.
    I only moved this server.fr_FR.po-file and restarted the server.

    Thanks for your help.

    cornfelt
    Last edited by cornfelt; 01-27-2009, 11:30 AM.

    Leave a comment:


  • Martin Heiland
    replied
    Hi,

    okay sorry seems this does not work on every environments. Those of you who do not use other languages than english and german could try to move server.fr_FR.po out of the /opt/open-xchange/i18n/ directory to let the server.de_DE.po be the only file left. If even this does not help, you could only wait for the update

    Leave a comment:


  • Guest's Avatar
    Guest replied
    I tried it too, on opensuse 11.0. I changed everything to "de_DE.utf8" per `export`. But after an restart of ox-groupware nothing has changed.
    I also changed the UTF8_AUTO_DETECT and set it on 'yes' in the sysconfig, but problem is still there.

    greetings
    cornfelt
    Last edited by cornfelt; 01-27-2009, 09:09 AM.

    Leave a comment:


  • pezi
    replied
    For Centos there is no dpkg-reconfigure locales available. Instead I used
    system-config-language for setting the local to german. reboot - but the problem still exists.

    locale
    LC_CTYPE="de_DE.UTF-8"
    LC_NUMERIC="de_DE.UTF-8"
    LC_TIME="de_DE.UTF-8"
    LC_COLLATE="de_DE.UTF-8"
    LC_MONETARY="de_DE.UTF-8"
    LC_MESSAGES="de_DE.UTF-8"
    LC_PAPER="de_DE.UTF-8"
    LC_NAME="de_DE.UTF-8"
    LC_ADDRESS="de_DE.UTF-8"
    LC_TELEPHONE="de_DE.UTF-8"
    LC_MEASUREMENT="de_DE.UTF-8"
    LC_IDENTIFICATION="de_DE.UTF-8"
    LC_ALL=

    Any chance to solve this problem manually?
    Last edited by pezi; 01-27-2009, 07:53 AM.

    Leave a comment:


  • Martin Heiland
    replied
    Hi,

    i think we found a solution, a customer also encountered this issue and solved it by executing:

    Code:
    dpkg-reconfigure locales
    And selecting all de_DE locales. Then restart the OX Groupware. Could you please try this at your environment?
    This issue will also be addressed by a bugfix in upcomming releases. Thank you all for reporting.


    Greetings
    Last edited by Martin Heiland; 01-26-2009, 06:29 PM.

    Leave a comment:


  • pezi
    replied
    locale
    LANG=en_US.UTF-8
    LC_CTYPE="en_US.UTF-8"
    LC_NUMERIC="en_US.UTF-8"
    LC_TIME="en_US.UTF-8"
    LC_COLLATE="en_US.UTF-8"
    LC_MONETARY="en_US.UTF-8"
    LC_MESSAGES="en_US.UTF-8"
    LC_PAPER="en_US.UTF-8"
    LC_NAME="en_US.UTF-8"
    LC_ADDRESS="en_US.UTF-8"
    LC_TELEPHONE="en_US.UTF-8"
    LC_MEASUREMENT="en_US.UTF-8"
    LC_IDENTIFICATION="en_US.UTF-8"
    LC_ALL=

    Leave a comment:


  • Martin Heiland
    replied
    We're researching for the cause of this, obviously it is related to the locale settings of the underlying operating system, could you please post the output of "locale"?

    Thanks

    Leave a comment:


  • pezi
    replied
    Same problem
    OS: Centos 5.2
    Update from SP4->SP5

    Version Info
    GUI Version: 6.8.0-6801
    Server Version: 6.8.0-6801

    with the yum update command. Reboot of the server after the update.
    German in the folder name is broken.

    Leave a comment:


  • outlow
    replied
    Moin,

    wie schon Beschrieben setze ich zur Zeit zwei Server mit der Beta ein und habe diese nun auf 6.8.0.1 geupdatet.

    Nach dem Update ist wie schon gesagt auf den Servern der unterschiedliche Stand geblieben. Unsere Server werden nach jedem Update rebootet.

    -----

    After a upgrade of OX we reboot every time our Server, the Problem with German Umlaute ist still there on the same machine.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    sure, this could be interesting, but I don't want to restart this engine. on it is some software running, which we and our customers daily use.

    have you any other ideas?

    cornfelt

    Leave a comment:


  • Carsten Hoeger
    replied
    It would be interesting, if that problem does also occur, when the server has been restarted and not the init-script manually on the console, where the environment of the user restarting that script might have any influence.

    Leave a comment:

Working...
X