Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 5 of 5

Thread: mod_proxy

  1. #1
    mrezzonico Guest

    Default mod_proxy

    Hi all,

    I have installed open-xchange on my internal network.
    To access open-xchange from the internet I use mod_proxy (from my dmz the connection is redirected to my internal network).

    I know how to redirect a url with mod_proxy, but I have no success with open-xchange.
    Can someone post the correct configuration for open-xchange ?

    Thanks in advance. Miche

  2. #2
    Dorowan Guest

    Default

    These are the notes I made for myself to access OX via an Apache Reverse Proxy. The setup is running on a virtual Ubuntu 8.04 host.

    Apache Reverse-Proxy

    Necessary packages for the reverse proxy:

    Code:
    # apt-get install apache2 libapache2-mod-proxy-html
    # a2enmod ssl
    # a2enmod proxy
    # a2enmod proxy_html
    # a2enmod proxy_http
    # a2enmod rewrite
    # a2enmod headers
    # /etc/init.d/apache2 force-reload
    Debian and Ubuntu System are a little bit restircted in their default configuration. Proxying has to be enabed.

    Code:
    # nano -w /etc/apache2/mods-available/proxy.conf
    Change this ...
    Code:
            <Proxy *>
                    AddDefaultCharset off
                    Order deny,allow
                    Deny from all
                    #Allow from .example.com
            </Proxy>
    to that ...
    Code:
            <Proxy *>
                    AddDefaultCharset off
                    Order deny,allow
                    #Deny from all
                    #Allow from .example.com
                    Allow from all
            </Proxy>
    The configuration for OX is something like the following. In this example the internal URL is http://oxsrv/ox and the external URL is http://<proxy-server>/somewhere/ox.

    Code:
    # nano -w /etc/apache2/sites-available/ox
    Code:
    RewriteEngine On
    RedirectMatch ^/somewhere/ox /somewhere/ox/
    ProxyPass /somewhere/ox/ http://oxsrv/ox/
    ProxyPassReverse /somewhere/ox/ http://oxsrv/ox/
    
    RedirectMatch ^/ajax /ajax/
    ProxyPass /ajax/ http://oxsrv/ajax/
    ProxyPassReverse /ajax/ http://oxsrv/ajax/
    
    RedirectMatch ^/servlet /servlet/
    ProxyPass /servlet/ http://oxsrv/servlet/
    ProxyPassReverse /servlet/ http://oxsrv/servlet/
    
    RedirectMatch ^/infostore /infostore/
    ProxyPass /infostore/ http://oxsrv/infostore/
    ProxyPassReverse /infostore/ http://oxsrv/infostore/
    
    RedirectMatch ^/oxadmin /oxadmin/
    ProxyPass /oxadmin/ http://oxsrv/oxadmin/
    ProxyPassReverse /oxadmin/ http://oxsrv/oxadmin/
    Now activate the configuration:
    Code:
    # a2ensite ox
    # /etc/init.d/apache2 force-reload

    Normal usage of OX works for me but I cannot access the Infostore via webdav yet.


    Hope I could help.
    Carsten
    Last edited by Dorowan; 05-11-2008 at 12:22 PM.

  3. #3
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    did you try to add /servlet/webdav.infostore/ as proxypass directive?

  4. #4
    Dorowan Guest

    Default

    No, I did not. Normally it should be enough to have /servlet/ in the ProxyPass because everything below should be included too. The Infostore feature is not that important for me right now since I use Alfresco for document management. I can access the Alfresco system running at home from work via webdav through the same proxy server that does not work with OX infostore (I have no direct internet access at work - everything has to go through a webproxy).

    The problem with Infostore WebDAV access via ReverseProxy seems to have something to do with authentication. I think the ReverseProxy does not hand over the authentication process to the OX server in the right way. When searching the web about the error messages I found in my logs I came across many subversion users who reported similar problems when using a reverse proxy. There seems to be a solution on http://silmor.de/49 but I have not tried yet.

    When I start to dig deeper into the problem I will post here. At the moment I have some more important things to get to work (like sending mails via remote relayhost over SSL, but that is just a little tweaking of the postfix conf).

  5. #5
    Dorowan Guest

    Default

    It works now! I always tried the wrong URL http://externalURL/infostore . When I use http://externalURL/servlet/webdav.infostore it works. My fault.

    P.S.; My Client is a Windows XP Pro 32Bit Box.
    Last edited by Dorowan; 05-13-2008 at 12:45 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •