Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 4 of 4
  1. #1

    Question Upgrading from OX 6.22.11 Rev7 to current version

    I have a customer system running 6.22.11 Rev7 on SLES 11. As the system is ancient, and can not be updated (we tried ...), I've started installing a new system with the current version of Open Xchange.
    Installing the new system isn't much of a problem (I hope), but I am concerned as far as the database goes ... Once I have the new system up and running, can I just (as I did on previous re-installs) stop OX, import the oxdatabase_6 dump into the new install, restart OX and it will migrate the database to the current schema? All I can find at the moment are update instructions for in-place updates ...

    Help appreciated!

  2. #2

    Default

    After having the new system mostly operational, I tried to migrate the database ... seems like it's failing ...

    com.openexchange.database.schema=oxdatabase_6
    com.openexchange.exception.OXException: UPD-0019 Categories=ERROR Message='Unable to determine next update task to execute. Executed: com.openexchange.groupware.calendar.update.RepairR ecurrencePatternNullValue,com.openexchange.file.st orage.rdb.groupware.FileStorageRdbCreateTableTask,[lots of text omitted]
    at com.openexchange.exception.OXExceptionFactory.crea te(OXExceptionFactory.java:176)
    at com.openexchange.exception.OXExceptionFactory.crea te(OXExceptionFactory.java:166)
    at com.openexchange.exception.OXExceptionFactory.crea te(OXExceptionFactory.java:139)
    at com.openexchange.groupware.update.UpdateExceptionC odes.create(UpdateExceptionCodes.java:201)
    at com.openexchange.groupware.update.internal.UpdateT askSorter.sort(UpdateTaskSorter.java:93)
    at com.openexchange.groupware.update.internal.UpdateT askCollection.getFilteredAndSortedUpdateTasks(Upda teTaskCollection.java:150)
    at com.openexchange.groupware.update.internal.UpdateE xecutor.runUpdates(UpdateExecutor.java:165)
    at com.openexchange.groupware.update.internal.UpdateE xecutor.execute(UpdateExecutor.java:128)
    at com.openexchange.groupware.update.internal.UpdateP rocess.runUpdate(UpdateProcess.java:137)
    at com.openexchange.groupware.update.internal.UpdateP rocess.run(UpdateProcess.java:115)
    at java.util.concurrent.Executors$RunnableAdapter.cal l(Executors.java:511)
    at java.util.concurrent.FutureTask.run(FutureTask.jav a:266)
    at com.openexchange.threadpool.internal.CustomThreadP oolExecutor$ScheduledFutureTask.run(CustomThreadPo olExecutor.java:1009)
    at com.openexchange.threadpool.internal.CustomThreadP oolExecutor$Worker.runTask(CustomThreadPoolExecuto r.java:840)
    at com.openexchange.threadpool.internal.CustomThreadP oolExecutor$Worker.run(CustomThreadPoolExecutor.ja va:867)
    at java.lang.Thread.run(Thread.java:748)

    Is this due to the attempt of updating the DB schema from the "ancient" version to the current? How can I fix this?

  3. #3

    Default

    Funny ... during the first attempt, I had OX stopped before doing the import. I tried once more, without stopping OX first, and this time it seemed as if the data (at least calendar - still need to have the customer check other infos) was working. Anyway, on a stop/start of the OX server, I got the same error again ...

  4. #4

    Default

    OK, seems like I got it to work ...
    After trying some of the stuff from here: http://oxpedia.org/wiki/index.php?title=UpdateTasks unsuccessfully, I then replaced the contents of the old DB dump's "updateTask" table with that of the current version's dump ... after then re-running all the updateTasks, I can now log in to OX again, and the data from the dump seems to be present ... still need to do more tests and have the customer to a quick check, but at least I got rid of the error...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •