Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 3 of 3
  1. #1
    Crumplerdude Guest

    Default Mapping Local accounts to remote accounts?

    We are using OpenXhange (Express Edition) on a local machine. But as this is a question rather about Postfix I will post it here.

    I will explain it with example values:
    Let's say our domain is example.tld
    Our remote mail server is provided by our ISP on IP
    (mail.example.tld, relay.example.tld)

    Our OpenXchange Installation is installed locally, and can be reached by web on IP

    I created two users in Ox:
    user1 (user1@example.tld)
    user2 (user2@example.tld)

    I configured SMTP Auth to be able to connect to our relay host at relay.example.tld.
    With that, I can send mails to any remote mail address like foo@mailservice.com

    I can send mails to existing local users, but they will only be transported locally. Bad if someone tries to fetch his mail directly from the mail server.

    But when I try to send mails to user3@example.tld (who exists on the remote mail server, but not as an Ox user), I get an error that the user is not existant. Which is natural, because Ox is looking for it locally.

    How can I configure Postfix (or the SMTP module) so it will sent mails always via the relay server?
    Last edited by Crumplerdude; 03-27-2008 at 06:48 PM.

  2. #2
    Crumplerdude Guest


    Additional Info: I have root access to the Ox machine, as well as webmin installed there.

  3. #3
    Crumplerdude Guest


    I found some help in the (german) server support board:

    Change these settings in main.cf

    comment out / uncomment the following lines like that:
    # mydestination = $myhostname,localhost.$mydomain
    # virtual_alias_domains = mysql:/etc/postfix/ox_domains.cf
    Don't forget to do your settings for
    relayhost = relay.example.dom
    relay_domains = example.dom
    Hope this is of any help


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts