Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 3 of 3
  1. #1
    mts Guest

    Default open-xchange-admin: "IOException: Cannot allocate memory" at chmod

    Hello,

    today i try to install Hyperion with the "Open-Xchange Community Edition Installer" (Bugfix-Release) . The success-message at the end of the script was wrong.
    After solving some problem with JSON i get the following error:

    /tmp/open-xchange-admin/build.xml:320: Execute failed: java.io.IOException: java.io.IOException: Cannot allocate memory

    Before all work i run: export ANT_OPTS="-Xms600m -Xmx600m"

    I can reproduce it with this call even after a ant clean:
    ant -Dlib.dir=/opt/open-xchange/lib replacer

    Here the Listing of the file causing the error:
    /tmp/open-xchange-admin#
    ls -l sbin/config.ini.helper
    -rwxr-xr-x 1 root root 613 2007-03-10 10:13 sbin/config.ini.helper


    If i skip this error the same error appearing at the next chmod.

    My System: Debian Etch as Virtual-Root-Server.

    Any help would be great.

    Thanks. Matthias
    Last edited by mts; 04-14-2008 at 11:27 AM.

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    the success message at the end does not check if the installation was really successful, sorry for that

    Does the vserver really provide 600megabytes of RAM? The Java VM will allocate as much memory as you specify and does not check the real available memory, that may lead to outofmemory problems.

  3. #3
    mts Guest

    Default

    Thank you Martin,

    reducing the memory-argument solves this problem.

    ant clean in open-xchange brings me back to the mentioned first problem.

    So i will try a new clean install with the installer...

    Should i respond possible problems on this second run here ? Or better an new Thread ?

    Matthias

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •