Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 5 of 5
  1. #1
    md5 Guest

    Question Problem when installating of Hyperion: File does not exist: /var/www/ajax

    Hi,
    I have been working on resolving this problem so there's a bit of info here.

    Problem description:
    While following the Hyperion installation guide, I am stuck at the "Service Configuration" section. After finishing the "Apache Webserver and mod_jk" part and the ultimate test of browsing http://$serveriIP/ajax/, my vanilla Debian installation does not work: the browser simply show the file not found, not the "Service Temporarily Unavailable" that we're looking for.

    While it may be a apache2 mod_jk problem, I dug through a bit of Debian apache2 mod_jk documentation and still it does not work. So I guess I will post my problem here.

    Specs:
    - OS: Debian Testing (updated to date)
    - Apache: Apache/2.2.8 (Debian) mod_jk/1.2.26
    - Is mod_jk enabled?: a2enmod output says: Module jk already enabled
    - Any site setup for apache: none.
    - Apache server error.log shows: File does not exist: /var/www/ajax

    Config: following the installation guide "Apache Webserver and mod_jk"

    Thanks,

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    would you please post your workers.properties and ox.conf file?

    Greetings

  3. #3
    md5 Guest

    Default

    Hi, Martin,
    Thanks for reply. Here are the two files currently. Notice there is some small modifs, e.g. JkLogStampFormat. I have also tried the exact lines on the installation manual without success.

    luna:/etc/apache2/conf.d$ cat ox.conf
    <IfModule mod_jk.c>
    JkWorkersFile /etc/apache2/workers.properties
    JkLogFile /var/log/apache2/mod_jk.log
    JkLogLevel error
    JkLogStampFormat "[%a %b %d %H:%M:%S %Y]"
    JkRequestLogFormat "%w %V %T"
    JkMount /ajax/* ajp13_worker
    JkMount /servlet/* ajp13_worker
    JkMount /infostore ajp13_worker
    JkMount /infostore/* ajp13_worker
    JkMount /oxadmin/* ajp13_worker
    JkMount /oxadmin ajp13_worker
    </IfModule>

    shuo@luna:/etc/apache2$ cat workers.properties
    #workers.java_home=/usr/lib/jvm/java-1.5.0-sun
    #I've tried with and without this workers.java_home line.
    #The path is really where the sun java is.
    ps=/
    worker.list=ajp13_worker
    worker.ajp13_worker.port=8009
    worker.ajp13_worker.host=localhost
    worker.ajp13_worker.type=ajp13
    worker.ajp13_worker.lbfactor=1
    worker.loadbalancer.type=lb
    worker.loadbalancer.balanced_workers=ajp13_worker


  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Looks nice so far - and i guess there is no real problem

    At the "Service Configuration" part, there is no Groupware running and listening to the mod_jk port. Therefore it's not surprising that you'll get a 404. If you access the servlets, apache tries to contact the ajp interface of the groupware but does not get any response.

    Just go on with the installation, after the groupware is up and running this issue should be solved.

    Greetings

  5. #5
    md5 Guest

    Default

    Hi, Martin,
    Thanks for the suggestion. I will go on with the installation.

    However it feels weird - if mod_jk is working and the server cannot contact something at the mod_jk port, shouldn't it be something else on the log other than "File not found: /var/www/ajax" in the apache2 error log?

    The other odd thing is that, the size of mod_jk log has been zero. I have a feeling that mod_jk is somehow not working, albeit the a2enmod telling that jk is enabled.

    I'll go on with installation for now. Thanks again,
    Last edited by md5; 05-05-2008 at 01:40 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •