Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 8 of 8
  1. #1
    floeschie Guest

    Default Creating new context fails (MySQLNonTransientConnectionException)

    Hey there,

    I'd like to write an installation howto for installing open-xchange community edition on an ubuntu 8.04 LTS server using the open-xchange repository.

    Right now I'm on step "Creating your first context and users" of the Quick Install Guide for the Hosting Edition. Unfortunately, when running the createcontext script, I get a Java exception error and I don't know what's wrong:
    Code:
    $ sudo /opt/open-xchange/sbin/createcontext -A oxadminmaster -P mysecret -c 1 -N mycontext -u administrator -d "System Administrator" -g System -s Administrator -p myothersecret -e administrator@mydomain.tld -q 1024 -L defaultcontext --access-combination-name=all
    Error message:

    Code:
    context 1 could not be created:
    Server response:
     com.mysql.jdbc.exceptions.MySQLNonTransientConnectionException: Could not create connection to database server. Attempted reconnect 3 times. Giving up.
    [Edit]
    When using a wrong password I get this error message, so connection seems to be possible somehow...
    Code:
    context 1 could not be created:
    Server response: Authentication failed
    [/Edit]


    I can access the database using user "root" (no password) or user "openexchange" via the mysql client console without problems...

    Code:
    mysql> SELECT User, Host from mysql.user;
    +------------------+---------------------+
    | User             | Host                |
    +------------------+---------------------+
    | openexchange     | %                   |
    | root             | %                   |
    | root             | 127.0.0.1           |
    | openexchange     | 192.168.178.10      |
    | openexchange     | eriador             |
    | root             | eriador             |
    | debian-sys-maint | localhost           |
    | openexchange     | localhost           |
    | root             | localhost           |
    | openexchange     | host.mydomain.tld |
    +------------------+---------------------+
    10 rows in set (0.00 sec)
    Any hints?
    Last edited by floeschie; 07-04-2008 at 11:18 AM.

  2. #2
    raistlin Guest

    Default

    I have the same problem when i try to configure the context. Does anybody know a solution?

  3. #3
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default Please do not forget to post logs!

    /var/log/open-xchange/open-xchange-admin.log.0

  4. #4
    raistlin Guest

    Default

    Sorry, my fault, attache you'll find the logfile
    Attached Files Attached Files

  5. #5
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    Code:
    Caused by: java.sql.SQLException: Access denied for user 'openexchange'@'localhost' (using password: YES)
            at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:1055)
            at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:956)
            at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3491)
            at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3423)
            at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:910)
            at com.mysql.jdbc.MysqlIO.secureAuth411(MysqlIO.java:3923)
            at com.mysql.jdbc.MysqlIO.doHandshake(MysqlIO.java:1273)
            at com.mysql.jdbc.ConnectionImpl.createNewIO(ConnectionImpl.java:2181)
            ... 23 more
    Please check configured database username and password.
    You can check with:

    Code:
    mysql -h localhost -u openexchange -p configdb

  6. #6
    raistlin Guest

    Default

    tested, i can login without any problems.

    But the createcontext-command exits still with the failure. If i change the password, then the failure message "Authentication failed" appears.

    It seems the connect to the database is made but then there is a failure in processing some command.

  7. #7
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    Quote Originally Posted by raistlin View Post
    tested, i can login without any problems.

    But the createcontext-command exits still with the failure. If i change the password, then the failure message "Authentication failed" appears.

    It seems the connect to the database is made but then there is a failure in processing some command.
    check whether the output of

    Code:
    /opt/open-xchange/sbin/listdatabase -A oxadminmaster -P YOURSECRET --csv
    contains the correct username/password to authenticate to your database.

    The username/password combination to access the database must be configured in two places:

    1.
    Code:
    /opt/open-xchange/etc/admindaemon/configdb.properties
    2. with the
    Code:
    registerdatabase
    command.

  8. #8
    raistlin Guest

    Default

    Now it works, thanks for your help. It seems like i had a little password shaking. I#va made a new installation on a clean server and now it's running

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •