Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 8 of 8
  1. #1
    susist Guest

    Default Problem when sending mail from an alias

    I successfully installed the community edition server version 6.6.0-6610 on a virtual machine (XEN) on my new SUSE 11.0 (AMD 64-bit Dual-Core) - server.

    It runs in a natted network at my home and uses my mydefault.account@mydomain_at_my_isp.com to relay mail through my ISP's mailserver, mails are received with fetchmail and I am very happy with it so far.

    But whenever I use a different e-mail-adress than the default one to sent mail from the ox-web-interface, the mail receives the recipient like this:
    -----------------------------------------------------------------------
    Von: myother.account@my_other_isp.com im Auftrag von My Name [mydefault.account@mydomain_at_my_isp.com]
    An: My Other-Name
    Betreff: blafasel
    ---------------------------------------------------------------------
    Maybe it's more a feature than a bug, though I don't like it very much.

    What can I do, to make my mail appear at the recipient, like it was sent with my myother.account@my_other_isp.com's webmailer.

    I am a afraid that this is the same "feature", that the also java-based googlemail.com-webmailer uses when sending with external mail-accounts.

    Maybe that this behavior is hardcoded in the javamail sourcecode.

    I'm hosting my own domain "help-it.org" on my own rootserver at STRATO, where I have my own staticly assigned public IP-adress.

    I am also my own MAil-provider for my @help-it.org-mail-accounts.

    Using my Outlook 2003 as a POP3-client of my postfix at my rootserver, I don't have that problem.

    I can use myother.account@my_other_isp.com's as a sender-account and it is relayed through the help-it.org-postfix without any problems and reaches the recipient like it was send wth the myother.account@my_other_isp.com's webmailer.

    I already tried to use my help-it.org-postfix as the smtp-server for my ox-server, wich was easily done. It worked like a charm, but didn't had any positv effect to my problem.

    Is there a way to reconfigure OX to disable that "feature"?

    Any hints are very welcome!

    Thanks for reading my post!

    susist
    Last edited by susist; 12-03-2008 at 02:28 PM. Reason: The title of the thread leads to a missunderstanding of the problem

  2. #2
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    Quote Originally Posted by susist View Post
    I successfully installed the community edition server version 6.6.0-6610 on a virtual machine (XEN) on my new SUSE 11.0 (AMD 64-bit Dual-Core) - server.

    It runs in a natted network at my home and uses my mydefault.account@mydomain_at_my_isp.com to relay mail through my ISP's mailserver, mails are received with fetchmail and I am very happy with it so far.

    But whenever I use a different e-mail-adress than the default one to sent mail from the ox-web-interface, the mail receives the recipient like this:
    -----------------------------------------------------------------------
    Von: myother.account@my_other_isp.com im Auftrag von My Name [mydefault.account@mydomain_at_my_isp.com]
    An: My Other-Name
    Betreff: blafasel
    ---------------------------------------------------------------------
    Maybe it's more a feature than a bug, though I don't like it very much.
    That's must be a feature of your isp.
    The ox webmailer does not do that.
    OXpedia.org - the answer to almost all questions.

  3. #3
    susist Guest

    Red face Maybe you didn't got me right

    Your answer is probably correct, when the question would have been:
    Problems while sending mail with another OX-E-Mail-Account on the ox-server.

    So I changed the title of the thread now.

    But In between, I doublechecked again everything and managed to find a solution, which I can live with:

    When I switch the specific alais-e-mail-adress to the the standard-alias-e-mailadress before sending with it, the mail reaches the recipient the way I want.

    You can configure your default E-Mail-Adress within the User-Web-Interface at:

    Einstellungen(Settings) - E-Mail - Einstellungen(Settings) - verfassen(edit) - dropdown-menue "Standard-Absender-Adresse"(standard-sender-adress)

    Everything is OK now again, but I'm quite shore that I'm right, when I think, that sending Mails with non-Standard-Adresses always leads to a "im Auftrag von" (by order of) in the header, is hardcoded in OX and not caused by the SMTP-Server of my relay-account.

    It would be nice if there would be a possibility to en- or disable this "feature" for non-standard-e-mai-adresses within the clients settings for e-mail in future releases.

  4. #4
    Carsten Hoeger is offline Open-Xchange Professional Services
    Join Date
    Mar 2007
    Posts
    703

    Default

    Quote Originally Posted by susist View Post
    You can configure your default E-Mail-Adress within the User-Web-Interface at:

    Einstellungen(Settings) - E-Mail - Einstellungen(Settings) - verfassen(edit) - dropdown-menue "Standard-Absender-Adresse"(standard-sender-adress)

    Everything is OK now again, but I'm quite shore that I'm right, when I think, that sending Mails with non-Standard-Adresses always leads to a "im Auftrag von" (by order of) in the header, is hardcoded in OX and not caused by the SMTP-Server of my relay-account.
    That's at least not the behaviour in the ox as we use it on our own internally and I'm quite sure, that we don't ship a special other version to the outside... ;-)
    OXpedia.org - the answer to almost all questions.

  5. #5
    acid Guest

    Default

    Hi,

    i must reopen this topic.
    I'Ve exact the same problem.
    I've got a user with 5 mail aliases
    If this user sends a mail with one alias the recipient gets a mail from the default mail adress and only in mission of the alias.

    This is sure a ox problem, ox sets the sender bit in the header to the default mail.

    This is a significant problem because we could not use openxchange if this persists...

    greetings

    Philipp

  6. #6
    acid Guest

    Default

    Hi,

    i must push this.

    if i send a mail with RoundCubeWebmail and a non standard e-mail adress, everything is fine, if i do this in ox webmail, the recipient get the mail in mission of my standard e-mail adress

    how can i change that?

  7. #7
    Join Date
    Dec 2008
    Posts
    11

    Default

    Maybe a similar problem here: Default domain of the server is domain.de and the users have Primary E-Mail Address like user1@t1.domain.de or user2@t2.domain.de. But everytime the users are sending mail, the sender's address changed to user1@domain.de or user2@domain.de even if the user hasn't a mail alias for that mail address. And this is if the users are sending mail via the OX webgui or using an IMAP client like thunderbird.

    Regards,
    Ralf

  8. #8
    Join Date
    Dec 2008
    Posts
    11

    Default

    Quote Originally Posted by McNail View Post
    Maybe a similar problem here: Default domain of the server is domain.de and the users have Primary E-Mail Address like user1@t1.domain.de or user2@t2.domain.de. But everytime the users are sending mail, the sender's address changed to user1@domain.de or user2@domain.de even if the user hasn't a mail alias for that mail address. And this is if the users are sending mail via the OX webgui or using an IMAP client like thunderbird.

    Regards,
    Ralf
    I found it by myself: I had to change the postfix setting masquerade_domains in /etc/postfix/main.cf. This was by default set to
    masquerade_domains = $mydomain

    Easiest way is to change this by editing the corresponding registry value "postfix/masquerade/domains" and set it empty. Restart postfix afterthat and it works.

    Regards,
    Ralf

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •