Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 4 of 4
  1. #1
    Join Date
    Mar 2008
    Posts
    21

    Default help: Error code: Messaging error: Expected ";", got "," (MSG-0021,-1239009832-1108)

    dear open-xchange experts,

    first of all: thanks for this great groupware application, it works great for us for nearly half a year now.

    however, today i ran into a problem related to forwarding an email (in general this is work, it is just this one particular mail that exhibits this problem as far as i see). the ox web frontend will complain

    Error code: Messaging error: Expected ";", got "," (MSG-0021,-1239009832-1108)

    (also see attached screenshot)

    any ideas how to fix this / what causes this?

    thanks and keep up the great work,

    guenter
    Attached Images Attached Images
    Last edited by goofy; 01-08-2009 at 12:02 PM.

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    thanks for the report - is it possible to hand over this e-mail to us? If it contains non-public data, you could also send it directly to me martin.braun[at]open-xchange.com. Please use a .eml export or something else to maintain the data structure of the original e-mail.

    Greetings.

  3. #3
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    we where able to reproduce the problem, the issue is a parameterized header that contains a comma character but no quotes around it. For example:

    Code:
    Content-Disposition: attachment;
    	filename="test.xxx";
    	size=1337;
    	creation-date=Wed, 07 Jan 2009 17:29:20 GMT;
    	modification-date=Wed, 07 Jan 2009 17:25:27 GMT
    note that "Wed, 07" contains a delimiter character (the comma) but is not set into quotes. This leads to the reported error message - we assume a ; as delimiter character but , is read because quotes are missing. We're investigating if there is a possible workaround, from the technical side the E-Mail is not standards compliant, but i guess the recipient does not care about that stuff, he just wants to read his mail...

    thanks again for this report
    Martin

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    The problem has been fixed and will be available with the next release.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •