Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 5 of 5
  1. #1
    Join Date
    Nov 2008
    Posts
    24

    Default Kann keine E-Mails mit Attechments versenden

    Hallo kann mir da jemand weiterhelfen,versuche eine E-Mail mit attechment zu Versenden bekomme dann folgende Fehlermeldung.

    WARNING: Upload Quota is less than zero. Using global server property "MAX_UPLOAD_SIZE" instead.
    Mar 19, 2009 10:29:44 AM com.openexchange.ajp13.AJPv13Listener run
    SEVERE: AJP-0001 Category=7 Message=loader constraint violation: when resolving method "javax.mail.internet.MimeBodyPart.setDataHandler(L javax/activation/DataHandlerV" the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) of the current class, com/openexchange/mail/mime/filler/MIMEMessageFiller, and the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) for resolved class, javax/mail/internet/MimeBodyPart, have different Class objects for the type javax/activation/DataHandler used in the signature exceptionID=-1753979352-8
    AJP-0001 Category=7 Message=loader constraint violation: when resolving method "javax.mail.internet.MimeBodyPart.setDataHandler(L javax/activation/DataHandlerV" the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) of the current class, com/openexchange/mail/mime/filler/MIMEMessageFiller, and the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) for resolved class, javax/mail/internet/MimeBodyPart, have different Class objects for the type javax/activation/DataHandler used in the signature exceptionID=-1753979352-8
    at com.openexchange.ajp13.AJPv13Listener.run(AJPv13Li stener.java:310)
    at java.lang.Thread.run(Thread.java:636)
    Caused by: java.lang.LinkageError: loader constraint violation: when resolving method "javax.mail.internet.MimeBodyPart.setDataHandler(L javax/activation/DataHandlerV" the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) of the current class, com/openexchange/mail/mime/filler/MIMEMessageFiller, and the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) for resolved class, javax/mail/internet/MimeBodyPart, have different Class objects for the type javax/activation/DataHandler used in the signature
    at com.openexchange.mail.mime.filler.MIMEMessageFille r.addMessageBodyPart(MIMEMessageFiller.java:1024)
    at com.openexchange.mail.mime.filler.MIMEMessageFille r.fillMailBody(MIMEMessageFiller.java:683)
    at com.openexchange.smtp.filler.SMTPMessageFiller.fil lMail(SMTPMessageFiller.java:165)
    at com.openexchange.smtp.SMTPTransport.sendMailMessag e(SMTPTransport.java:424)
    at com.openexchange.mail.transport.MailTransport.send MailMessage(MailTransport.java:142)
    at com.openexchange.mail.MailServletInterfaceImpl.sen dMessage(MailServletInterfaceImpl.java:973)
    at com.openexchange.ajax.Mail.action(Mail.java:3158)
    at com.openexchange.ajax.AJAXServlet.fireUploadEvent( AJAXServlet.java:702)
    at com.openexchange.ajax.Mail.doPost(Mail.java:3058)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:616)
    at com.openexchange.ajax.AJAXServlet.service(AJAXServ let.java:376)
    at com.openexchange.ajax.SessionServlet.service(Sessi onServlet.java:152)
    at com.openexchange.ajax.PermissionServlet.service(Pe rmissionServlet.java:98)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:689)
    at com.openexchange.ajp13.AJPv13Request.response(AJPv 13Request.java:120)
    at com.openexchange.ajp13.AJPv13RequestHandler.create Response(AJPv13RequestHandler.java:466)
    at com.openexchange.ajp13.AJPv13Connection.createResp onse(AJPv13Connection.java:197)
    at com.openexchange.ajp13.AJPv13Listener.run(AJPv13Li stener.java:268)
    ... 1 more

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hallo,

    scheinbar verwendest du Java 1.6, bitte installiere Java 1.5 da es mit 1.6 das von dir geschilderten Fehlverhalten gibt.

    Gruß

  3. #3
    Join Date
    Nov 2008
    Posts
    24

    Default

    es ist Java 1.5 installiert

    grüße

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hallo,

    möglicherweise ist Java 1.6 UND Java 1.5 installiert, auf Debian basierten Systemen kannst du mit folgendem Kommando die Standard-VM auswählen:

    update-alternatives --config java

    Gruß

  5. #5
    Join Date
    Nov 2008
    Posts
    24

    Default

    OS ist Suse 11.0

    habe noch festgestellt das wenn ich
    zypper rm java-1_6_0-openjdk
    Reading installed packages...

    Problem: conflicting requests
    Solution 1: do not keep java-1_6_0-openjdk-1.2_b09-9.1.x86_64 installed
    Solution 2: do not ask to delete all solvables providing java-1_6_0-openjdk


    allerdings wenn ich es deinstalieren möchte will er mir open-xchange packete auch deinstallieren


    The following packages are going to be REMOVED:
    open-xchange-spamhandler-spamassassin open-xchange-smtp open-xchange-server
    open-xchange-push-udp open-xchange-imap open-xchange-conversion-servlet
    open-xchange-contactcollector open-xchange-admin open-xchange java-1_6_0-openjdk

    noch nen tip was da bei mir falsch läuft?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •