Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    olaf123 Guest

    Default syncml / OXconnector derzeit unmöglich mit OpenXchange ?

    Hallo !

    Nach nun ca. drei Wochen Herumprobieren mit mehreren Installationsbeschreibungen bin ich zu dem Ergebnis gekommen, dass es derzeit keine korrekte Beschreibung für die Installation des OXconnectors gibt.

    Egal, welche Version des Connectors ich genommen habe, ich komme immer wieder an irgendeinen Punkt, an dem die jeweilige Beschreibung nicht mehr mit den Pfaden und/oder Dateien des jeweiligen Paketes übereinstimmt.

    Heute habe ich nochmal mehrere Stunden mit den Dateien
    funambol-ox-connector-7.0.3.zip
    funambol-7.0.6.bin
    von http://forge.ow2.org/project/showfiles.php?group_id=96
    verbracht, wie immer letztendlich sinnlos.

    Benutzt habe ich die entsprechenden Installationsbeschreibungen auf der gleichen Seite:
    funambol-v7-installation-and-configuration-guide.pdf
    funambol-open-xchange-connector-installation-and-configuration-guide.pdf

    Selbst mit größter Kreativität beim Finden der Pfade / Dateien scheitere ich spätestens bei dem Punkt, wo man diverse Dateien "irgendwie" anpassen soll, aber nicht beschrieben wird, was und wie man denn dort überhaupt anzupassen hat.

    Martin Braun hat mich bereits an funambol.com, #funambol und #open-xchange verwiesen.
    Der Kontakt zu funambol.com scheitert an meinen mangelnden Englischkenntnissen, #funambol scheitert an dort herrschender Funkstille, und in #open-xchange ist niemand für dieses Problem zu finden.

    Funambol selbst scheint grundsätzlich installiert zu sein, ich kann das Admin-Center aufrufen, konfigurieren usw. Meist fehlt dann das OX-Modul, daher rufe ich (obwohl schon vorher durchgeführt) dann nochmal die Installation der Module auf.

    Könnte mal irgendjemand hier ganz eindeutig klarstellen, dass es derzeit für einen Normal-User nicht möglich ist, das Ding zum Laufen zu bekommen - oder mich unter Nennung entsprechender, aktueller Links korrigieren ?

    Auch, wenn eigentlich funambol schuld ist, so dürfte die syncml-Funktionalität doch eine so relevante Funktion sein, dass sicherlich haufenweise User bisher und in Zukunft etliche Stunden ihrer Lebenszeit damit verbraten bei dem Versuch, das zu installieren.
    Ich persönlich bin nicht schnell von einem Ziel abzubringen, aber hier sitzt der Frust inzwischen drin.
    Wäre es nicht möglich, dass ein kompetenter User oder jemand vom OpenXchange-Team einen entsprechenden Thread bei funambol eröffnet und Klarheit in die Sache bringt ?

    Gruß
    Olaf

  2. #2
    olaf123 Guest

    Default

    Ich habe mir jetzt mal einen abgebrochen und in meinem Katastrophen-Englisch den aktuellen Stand auf
    https://core.forge.funambol.org/ds/v...essageId=48514
    gepostet.

    Ich stecke nun fest bei dem Punkt

    "4. Installing the Open-Xchange Listener"
    Das, was da entpackt wird aus der Datei "funambol-ox-listener-7.0.3.zip" entspricht nicht dem, was in dem Installations-Guide abgebildet ist bzw. beschrieben wird.

    Mal schauen, ob dort jemand helfen kann.

    Gruß
    Olaf

  3. #3
    olaf123 Guest

    Default

    Hallo
    und herzlich willkommen zu meinem Monolog !

    Stand der Dinge:
    "albertvd" im Forum von funambol
    https://core.forge.funambol.org/ds/v...4#messagefocus
    hat eine Möglichkeit gefunden, den OXConnector zu installieren, aber leider funktioniert die Synchronisation danach nicht einwandfrei:

    Die Synchronisation scheint erstmal _grundsätzlich_ zu funktionieren.
    Aber schon nach ein paar Minuten habe ich den ersten Fehler entdeckt: bereits angelegte Termine, die in OpenXchange zeitlich verschoben werden, werden bei der nächsten Synchronisation auf dem Handy gelöscht, und danach auch nicht mehr beachtet bzw. übertragen.
    Im Funambol-Forum gibt es leider noch immer keine Reaktion darauf, das Interesse am ox-Connector scheint nicht wirklich groß zu sein.

    Ich habe den ganzen Rest noch nicht getestet, da allein schon durch diesen Fehler ein praktischer Einsatz des OXconnectors und somit auch der vernünftige Einsatz von OpenXchange für mich erstmal nicht möglich ist.
    Aber mit der Anleitung ist zumindest die Installation des Connector erstmal wieder möglich (... bis zur nächsten Änderung im Code von funambol / OpenXchange ...).

    Die Anleitung von albertvd enthielt Fehler, im folgenden habe ich diese bereinigt.

    Mein System, auf dem ich das nachvollzogen habe:
    OpenSuse 11.0
    OpenXchange 6.8.0-6802.
    funambol-7.1.1.bi​n
    ox-module​-7.1.0.zip
    Client: Blackberry Pearl 8100, funambol 7.0.5 (und zusätzlich getestet mit nexthaus syncje)

    - Zeilen, die mit "#" beginnen, sind in einer shell auszuführende Befehle (ohne "#" natürlich).
    - Die Adresse "http://192.168.0.1" muss mit der des eigenen PC's ersetzt werden, oder alternativ z.B. mit einer DynDNS-Adresse, wie ich es gemacht habe.
    - Keinen User im Funambol-Server anlegen, dieser wird bei der ersten Synchronisation automatisch erzeugt.

    # mkdir /usr/src/funambol
    # cd /usr/src/funambol
    # wget http://download.forg​e.objectweb.org...1.1.bi​n
    # sh funambol-7.1.1.bin
    # wget http://m2.funambol.o​rg/repositories...203;-7.1.0.zip
    # unzip ox-module-7.1.0.zip
    # cp /usr/src/funambol/Fu​nambol/ox-connector/​ox-connector-7.1.0.s​4j /opt/Funambol/ds-ser​ver/modules/
    # cd Funambol/ox-listener
    # unzip funambol-ox-listener-7.1.0.zip
    # cp -r /usr/src/funambol/Fu​nambol/ox-listener/F​unambol/* /opt/Funambol

    # edit /opt/Funambol/ds-ser​ver/install.properti​es
    (Ich persönlich benutze hier nicht "edit", sondern "joe", aber dafür solltet ihr "joe" vorher natürlich installiert haben. Ansonsten viel Spaß mit "vi" )

    Die modules-to-install Zeile muss am Ende erweitert werden um den Eintrag ",ox-c​onnector-7.1.0".
    Sie sollte also so ähnlich aussehen wie die folgende:

    modules-to-install=content-provider-7.1.​2,email-connector-7.1.1,foundation-7.1.1​,phones-support-7.1.​0,webdemo-7.1.0,ox-c​onnector-7.1.0

    Bei den folgenden zwei Zeilen Eingabezeilen müsst ihr mal schauen, ob die Datei bei euch an der Stelle vorhanden ist.
    Wenn nicht, dann schaut in den Ordner /etc/init.d/rc3.d/ dort gibt es für den start-Befehl einen Dateinamen in der Art von "Sxxopen-xchange-groupware" und für den stop-Befehl einen Dateinamen in der Art von "Kxxopen-xchange-groupware". An der Stelle der beiden "xx" steht bei euch jeweils irgendeine Zahl, die ihr statt der "xx" eintragen müsst.

    Also, normale Variante:
    # /etc/init.d/open-xchange-groupware stop
    # /etc/init.d/open-xchange-groupware start

    Und wenn ihr eine Meldung bekommt, die Datei sei nicht vorhanden, dann gebt ein
    # /etc/init.d/rc3.d/rc3.d/Kxxopen-xchange-groupware
    # /etc/init.d/rc3.d/rc3.d/Sxxopen-xchange-groupware

    Weiter geht's:

    # /opt/Funambol/bin/funambol stop
    # /opt/Funambol/bin/funambol start
    # cd /opt/Funambol/
    # ./bin/install-modules

    Die Nachfragen, ob die Datenbanken neu angelegt werden sollen, bestätigt ihr mit "ja" bzw. "yes".

    # edit /opt/Funambol/bin/ox-listener

    Ändert hier: JMX_PORT=3101 zu JMX_PORT=13101

    # edit /opt/Funambol/config​/com/funambol/oxlist​ener/task/OXListener​Task.xml

    Ändert hier alle Angaben für die "OXUrl" auf http://192.168.0.1:80 (Achtung: ersetzt "192.168.0.1" mit eurer IP, d.h. der Adresse eures PC's.

    Beispiel:
    <void property="OXUrl">
    <string>http://192.168.0.1:8​0</string>
    </void>

    # edit /opt/Funambol/config​/ox/ox/OXConnector.x​ml

    Ändert hier alle Angaben für die "OXUrl" auf http://192.168.0.1:80 (Achtung: ersetzt "192.168.0.1" mit eurer IP, d.h. der Adresse eures PC's.

    Beispiel:
    <void property="OXUrl">
    <string>http://192.168.0.1:8​0</string>
    </void>

    # edit /opt/Funambol/config/Funambol.​xml

    Ändert hier den Absatz für "officer" wie folgt ab:
    <void property="officer">
    <string>com/fu​nambol/server/securi​ty/OXOfficer.xml<​/string>
    </void>

    # edit /opt/Funambol/tools/​tomcat/conf/server.x​ml
    Ändert hier den Port für den AJP Connector von 8009 auf 8010

    <!-- Define an AJP 1.3 Connector on port 8009 -->
    <Connector port="8010" protocol="AJP/1.3" redirectPort="8443" />

    # /etc/init.d/open-xchange-admin start
    Falls eine Fehlermeldung kommt, dann das gleiche wie oben erklärt nochmal machen, in den Ordner " /etc/init.d/rc3.d" schauen, Datei "Sxx...." usw.

    # /etc/init.d/open-xch​ange-groupware start
    Fehlermeldung? Siehe oben.

    # /opt/Funambol/bin/funambol stop
    # /opt/Funambol/bin/funambol start
    # /opt/Funambol/bin/ox-listener start

    Nun konfiguriert den Client richtig mit oxscard usw, wird an anderer Stelle im Forum beschrieben. Danach könnt ihr synchronisieren.

    Das war's. Eigentlich.

    Der von mir oben beschriebene Fehler bei der Synchronisation wird vermutlich an der Kombination Funambol-Server / OpenXchange liegen, und nicht am Client auf dem Handy, da ich dort das gleiche mit dem Nexthaus-Client (syncje) reproduzieren konnte. Ist aber nur eine Mutmaßung.

    Falls jemand was Neues erfährt, wäre ich für eine Info dankbar.

    Gruß
    Olaf
    Last edited by olaf123; 05-03-2009 at 11:02 PM.

  4. #4
    sedeke Guest

    Default Damit du nicht ganz alleine da bist

    Hab ich mich auch ein wenig damit beschäftigt.

    Hab funambol installiert und erstmal mit meinem Thunderbird getestet.
    Ohne OX erstmal, nur Benutzer angelegt per Funambol Admin Tool.

    Läuft. Super.

    Dann nach deiner Doku das OX Module + Connector geladen und installiert.

    Im log hab ich keine Fehler beim start. Der ox-listener gibt mit #ox-listener Status auch eine vernünftige Meldung aus und alles ok.

    Nur dann das Verbinden mit dem Thunderbird geht nicht.
    Muss noch was am OX im "Funambol Admin Tool" eingerichtet werden??
    Die Doku ist, ?? welche Doku??? Gibt es eine??

    Komisch ist wenn ich im funambol plugin im Thunderbird einen Benutzer angebe, der nicht existiert legt ihn Funambol bei sich an. Ist im Funambol Admin Tool" zu sehen.

    Hab ich was vergessen?
    Würde gerne deinen Fehler reporduzieren.

    LG
    Thorsten

  5. #5
    olaf123 Guest

    Default

    Hallo Thorsten !

    Quote Originally Posted by sedeke View Post
    Nur dann das Verbinden mit dem Thunderbird geht nicht.
    Muss noch was am OX im "Funambol Admin Tool" eingerichtet werden??
    Sorry, ich habe mich ausschließlich um die Synchronisation mit dem Handy bemüht, zu den anderen Möglichkeiten (hier Thunderbird) kann ich nichts sagen.

    Quote Originally Posted by sedeke View Post
    Die Doku ist, ?? welche Doku??? Gibt es eine??
    Da hätte ich auch schreien können, weil das, was es gibt, längst überholt ist, daher mein Beitrag.
    Ich kenne nur die Dokus auf http://forge.ow2.org/project/showfiles.php?group_id=96

    Gruß
    Olaf

  6. #6
    sedeke Guest

    Default

    Dann Schau mal hier rein:
    http://download.forge.objectweb.org/sync4j/

    Ist ein komplettes verzeichnis von Fumambol downloads.
    Da ist gar eine Doku "funambol-open-xchange-connector-installation-and-configuration-guide.pdf"

    Versuche da weiter zu kommen.

  7. #7
    sedeke Guest

    Default

    Ach kannst du mir deine
    /opt/Funambol/config​/com/funambol/oxlist​ener/OXListenerConfiguration.xml
    Posten??

    In der pdf Doku gibt es einen Abschnitt mit "basicDataSource".
    Der fehlt mir. Ausserdem ist mir vollig schleicherhaft wie der OX-Listner Benutzer gegen mein OX6 Authentifiziert.
    Theoretisch müsste der eine verbindug zur der MySQL DB aufbauen. Aber ohne Password??
    In OX6 stelle ich ja auch nichts ein, also noch versteh ich den Hintergrund nicht ganz.

    Thorsten

  8. #8
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    die Connectoren von Funambol und anderen Drittanbietern nutzen die OX HTTP API um Daten auszutauschen und einen Benutzer zu authentisieren. Ein Zugriff, direkt auf die Datenbank ist auch nicht gewünscht da wir die HTTP API öffentlich spezifiziert haben und sich andere Applikationen an diese API halten können. Mit dem Zugriff auf die Datenbank würden diverse Probleme auftauchen, mit dem Zugriff über die API profitiert man unter anderem von einer besseren Skalierbarkeit und Fehlerbehandlung.

    Gruß

  9. #9
    sedeke Guest

    Default Hallo Martin

    Schön dass du auch vorbei kommst

    Ja hab ich mir schon gedacht. Nur ist das ganze - naja - kaum beschrieben.
    Bei "funambol" findest du die Version des OX-Connectors 7.0.5
    Bei den Links zur "ow2 Forge Project" (http://forge.ow2.org/project/showfiles.php?group_id=96) ist wiederrum nur die Version 7.0.3 vorhanden.

    Doku - fehlanzeige.

    Bei den Benutzererfahrungen beschrieben von "albertvd" (https://core.forge.funambol.org/ds/v...4#messagefocus) wird das OX-MODULE 7.1.0 verwendet. Ist aber das gleiche. Den Namen finde ich auch besser, da es sich hier um ein Modul zum funambol handelt welches den OX-connector und OX-listener beinhaltet.

    Wenn ich aber unter Ubuntu 8.04 mit OX6 (Build: 6.8.1-6811) genau nach der Doku von "albertvd" verwende oder die, die ich gefunden habe unter http://download.forge.objectweb.org/sync4j/, so bekomme ich keine Verbindung zur OX. Egal welche Version des OX-Modules ist verwende.

    Funambol läuft bei mir aber. Ich habe es zum testen ohne OX-Module installiert und Daten zwischen Outlook und ThunderBird und Nokia N95 abgleichen lassen. Läuft.

    Jetzt versuche ich die Log files auszulesen und festzustellen warum.

  10. #10
    sedeke Guest

    Question so etwas weiter

    bei der Installation hab ich folgenden Fehler oder Warning erhalten:
    Code:
    Warning: selected war files include a WEB-INF/web.xml which will be ignored (please use webxml attribute to war task)
    hab aber keine Ahnung ob das relevant ist.

    Das Authentifizieren schlägt fehl mit folgendem Fehler:
    Code:
    [2009-05-09 11:58:00,725] [funambol.auth] [ERROR] [C14BF8ADE649226A75D37005DF1A7D67] [fmz-zc2tPdP/uDqHryRqhp9ulA==] [] [] Error verifyng user: tsedeke@sousgarden.de 
    com.funambol.ox.exception.OXAccessException: Bad HTTP response format: A JSONObject text must begin with '{' at character 1 of <html><head><title>Apache Tomcat/6.0.16 - Error report</title><style><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP Status 404 - /ajax/login</h1><HR size="1" noshade="noshade"><p><b>type</b> Status report</p><p><b>message</b> <u>/ajax/login</u></p><p><b>description</b> <u>The requested resource (/ajax/login) is not available.</u></p><HR size="1" noshade="noshade"><h3>Apache Tomcat/6.0.16</h3></body></html>
    	at com.funambol.ox.items.dao.OXEntityDAO.login(OXEntityDAO.java:265)
    	at com.funambol.ox.security.OXOfficer.checkCredentials(OXOfficer.java:547)
    	at com.funambol.ox.security.OXOfficer.authenticateBasicCredential(OXOfficer.java:318)
    	at com.funambol.ox.security.OXOfficer.authenticateUser(OXOfficer.java:249)
    	at com.funambol.ox.security.OXOfficer.authenticateUser(OXOfficer.java:77)
    	at com.funambol.server.engine.Sync4jEngine.login(Sync4jEngine.java:1541)
    	at com.funambol.server.session.SyncSessionHandler.login(SyncSessionHandler.java:2197)
    	at com.funambol.server.session.SyncSessionHandler.processMessage(SyncSessionHandler.java:453)
    	at com.funambol.server.engine.SyncAdapter.processInputMessage(SyncAdapter.java:533)
    	at com.funambol.server.engine.SyncAdapter.processXMLMessage(SyncAdapter.java:254)
    	at com.funambol.transport.http.server.LocalSyncHolder.processXMLMessage(LocalSyncHolder.java:97)
    	at com.funambol.transport.http.server.Sync4jServlet.doPost(Sync4jServlet.java:399)
    	at javax.servlet.http.HttpServlet.service(HttpServlet.java:710)
    	at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
    	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
    	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
    	at com.funambol.transport.http.server.LogContextFilter.doFilter(LogContextFilter.java:115)
    	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
    	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
    	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
    	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
    	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
    	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
    	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
    	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)
    	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
    	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
    	at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
    	at java.lang.Thread.run(Unknown Source)
    Caused by: org.json.JSONException: A JSONObject text must begin with '{' at character 1 of <html><head><title>Apache Tomcat/6.0.16 - Error report</title><style><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP Status 404 - /ajax/login</h1><HR size="1" noshade="noshade"><p><b>type</b> Status report</p><p><b>message</b> <u>/ajax/login</u></p><p><b>description</b> <u>The requested resource (/ajax/login) is not available.</u></p><HR size="1" noshade="noshade"><h3>Apache Tomcat/6.0.16</h3></body></html>
    	at org.json.JSONTokener.syntaxError(JSONTokener.java:450)
    	at org.json.JSONObject.<init>(JSONObject.java:178)
    	at org.json.JSONObject.<init>(JSONObject.java:275)
    	at com.funambol.ox.items.dao.OXEntityDAO.login(OXEntityDAO.java:263)
    	... 28 more

    Hat jemand eine Ahnung was das Bedeutet??
    Bin für jede Hilfe dankbar

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •