Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 8 of 8
  1. #1

    Default Upgrade auf Build: 6.9.0.0-6.9.0 Rev4, 2009-05-05 21:27:07

    N'Abend,

    bis vor 20min lief OX unter Debian Lenny super gut.
    Nach einem Update von OX auf die o.g. Version habe ich Probleme:

    Ein tail -f /var/log/open-xchange/open-xchange.log.0
    meint folgendes dazu


    07.05.2009 20:35:18 com.openexchange.timer.osgi.TimerActivator start
    INFO: starting bundle: com.openexchange.timer
    07.05.2009 20:35:19 com.openexchange.charset.osgi.CharsetActivator start
    INFO: starting bundle: com.openexchange.charset
    07.05.2009 20:35:19 com.openexchange.charset.osgi.CharsetActivator start
    INFO: External charset provider replaced with collection charset provider
    07.05.2009 20:35:19 com.openexchange.charset.osgi.CharsetActivator start
    INFO: Charset bundle successfully started
    07.05.2009 20:35:19 com.openexchange.config.osgi.ConfigActivator start
    INFO: starting bundle: com.openexchange.configread
    07.05.2009 20:35:19 com.openexchange.config.internal.ConfigurationImpl processDirectory
    INFO: Can't read /opt/open-xchange/etc/groupware/osgi/org.eclipse.osgi. Skipping.
    07.05.2009 20:35:19 com.openexchange.config.osgi.ConfigActivator start
    SCHWERWIEGEND: Not found:
    java.lang.IllegalArgumentException: Not found:
    at com.openexchange.config.internal.ConfigurationImpl .<init>(ConfigurationImpl.java:136)
    at com.openexchange.config.internal.ConfigurationImpl .<init>(ConfigurationImpl.java:103)
    at com.openexchange.config.osgi.ConfigActivator.start (ConfigActivator.java:86)
    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl$2.run(BundleContextImpl.java:999)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl.startActivator(BundleContextImpl.java:993 )
    at org.eclipse.osgi.framework.internal.core.BundleCon textImpl.start(BundleContextImpl.java:974)
    at org.eclipse.osgi.framework.internal.core.BundleHos t.startWorker(BundleHost.java:346)
    at org.eclipse.osgi.framework.internal.core.AbstractB undle.resume(AbstractBundle.java:350)
    at org.eclipse.osgi.framework.internal.core.Framework .resumeBundle(Framework.java:1118)
    at org.eclipse.osgi.framework.internal.core.StartLeve lManager.resumeBundles(StartLevelManager.java:634)
    at org.eclipse.osgi.framework.internal.core.StartLeve lManager.incFWSL(StartLevelManager.java:508)
    at org.eclipse.osgi.framework.internal.core.StartLeve lManager.doSetStartLevel(StartLevelManager.java:28 2)
    at org.eclipse.osgi.framework.internal.core.StartLeve lManager.dispatchEvent(StartLevelManager.java:468)
    at org.eclipse.osgi.framework.eventmgr.EventManager.d ispatchEvent(EventManager.java:195)
    at org.eclipse.osgi.framework.eventmgr.EventManager$E ventThread.run(EventManager.java:297)
    07.05.2009 20:35:19 com.openexchange.control.osgi.ControlActivator start
    INFO: starting bundle: com.openexchange.control
    07.05.2009 20:35:19 com.openexchange.conversion.engine.osgi.Conversion EngineActivator start
    INFO: Conversion engine successfully started
    07.05.2009 20:35:19 com.openexchange.server.ServiceHolderInit start
    INFO: Service usage inspection not enabled
    07.05.2009 20:35:20 com.openexchange.push.udp.osgi.PushUDPActivator start
    INFO: starting bundle: com.openexchange.push.udp

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    6.9 ist eine Entwicklerversion (unstable), für etwas anderes sollte sie auch nicht genutzt werden da der Code unter Umständen nicht 100% funktioniert.

    Gruß

  3. #3

    Default

    okeo,
    wie bekomme ich das System nun wieder auf eine Stable zurück ?
    Gruß
    Oliver

  4. #4
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,


    Ein Backup von /opt/open-xchange machen.

    OX deinstallieren, falls noch was übrig bleibt löschen (/opt/open-xchange), Paketquellen korrigieren, OX 6.8 neu installieren und die alte Konfig abgleichen, zurückspielen.

    Gruß

  5. #5

    Default

    bis auf das Backup habe ich das Prozedere durch.
    Das Webfrontend zeigt mir bereits wieder Version Build: 6.8.1-6811, 2009-03-23 14:05:19 an.
    ABER ich bekomme keinen Connect zur Datenbank hin. Natürlich habe ich nach der Erstinstallation von OX der Datenbank ein Passwort gegeben.
    Ich vermute nun mal, dass in irgend einem Config-File das Passwort des Adminusers hinterlegt sein sollte.

    Gruß Oliver

  6. #6
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Genau, in den beiden configdb.properties files muss das passwort für den "openexchange" Datenbankuser rein.

    Gruß

  7. #7

    Default

    das war eine ziemlich brutale Reparatur
    Da sich durch das Update die Sun-Java6 im System breit gemacht hat und somit Java5 und Java6 installiert waren, half nur noch die Holzhammermethode:
    apt-get remove openxchange* --purge
    apt-get remove jre5* --purge
    apt-get remove jre6* --purge
    apt-get autoremove

    Und im Anschluß daran alles nochmals neu installieren.
    Dieses wiederum verlief absolut ohne Probleme.
    OX lebt wieder !

    Grüße am Abend
    Oliver

  8. #8

    Default

    Moin,

    der Fehler ist nachvollziehbar.
    Auf einem Testserver habe ich die "unstable" installiert und der Fehler wiederholt sich.

    Gruß
    Oliver

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •