Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 4 of 4

Thread: saslauthd dies

  1. #1
    Aleksander Kikkas Guest

    Default saslauthd dies

    Hello,

    Problem 1.
    Using OXAE in production, the strange things start happening. Severeal times a day, suddenly not possible to login through imap. Log into the OXAE enviroment is possible but no mailbox access. - maillog shows authentication failure. The open-xchange log shows the same:
    ------------------------------------------------
    May 19, 2009 4:18:15 PM com.openexchange.ajax.Folder actionGetFolder
    SEVERE: MSG-1016 Category=5 Message=Connection was refused or timed out while attempting to connect to remote server mail.rakvereteater.ee for user rakvereteater@rakvereteater.ee exceptionID=-2112659204-400
    MSG-1016 Category=5 Message=Connection was refused or timed out while attempting to connect to remote server mail.rakvereteater.ee for user rakvereteater@rakvereteater.ee exceptionID=-2112659204-400
    at com.openexchange.mail.mime.MIMEMailException.handl eMessagingException(MIMEMailException.java:393)
    at com.openexchange.imap.IMAPAccess.connectInternal(I MAPAccess.java:318)
    at com.openexchange.mail.api.MailAccess.connect(MailA ccess.java:302)
    at com.openexchange.mail.MailServletInterfaceImpl.ini tConnection(MailServletInterfaceImpl.java:843)
    at com.openexchange.mail.MailServletInterfaceImpl.get Folder(MailServletInterfaceImpl.java:441)
    at com.openexchange.ajax.Folder.actionGetFolder(Folde r.java:1373)
    at com.openexchange.ajax.Folder.actionGetFolder(Folde r.java:1322)
    at com.openexchange.ajax.request.FolderRequest.action (FolderRequest.java:90)
    at com.openexchange.ajax.Multiple.doAction(Multiple.j ava:394)
    at com.openexchange.ajax.Multiple.parseActionElement( Multiple.java:186)
    at com.openexchange.ajax.Multiple.doPut(Multiple.java :132)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:619)
    at com.openexchange.ajax.AJAXServlet.service(AJAXServ let.java:380)
    at com.openexchange.ajax.SessionServlet.service(Sessi onServlet.java:149)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:689)
    at com.openexchange.ajp13.najp.AJPv13RequestHandlerIm pl.doServletService(AJPv13RequestHandlerImpl.java: 429)
    at com.openexchange.ajp13.AJPv13Request.response(AJPv 13Request.java:128)
    at com.openexchange.ajp13.najp.AJPv13RequestHandlerIm pl.createResponse(AJPv13RequestHandlerImpl.java:28 2)
    at com.openexchange.ajp13.najp.AJPv13ConnectionImpl.c reateResponse(AJPv13ConnectionImpl.java:189)
    at com.openexchange.ajp13.najp.AJPv13Task.run(AJPv13T ask.java:258)
    at java.util.concurrent.Executors$RunnableAdapter.cal l(Executors.java:417)
    at java.util.concurrent.FutureTask$Sync.innerRun(Futu reTask.java:269)
    at java.util.concurrent.FutureTask.run(FutureTask.jav a:123)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run Task(ThreadPoolExecutor.java:650)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:675)
    at java.lang.Thread.run(Thread.java:595)
    Caused by: javax.mail.MessagingException: * BYE JavaMail Exception: java.net.SocketTimeoutException: Read timed out;
    nested exception is:
    com.sun.mail.iap.ConnectionException: * BYE JavaMail Exception: java.net.SocketTimeoutException: Read timed out
    at com.sun.mail.imap.IMAPStore.protocolConnect(IMAPSt ore.java:609)
    at javax.mail.Service.connect(Service.java:291)
    at com.openexchange.imap.IMAPAccess.connectInternal(I MAPAccess.java:279)
    ... 24 more

    -------------------------------------------------------------
    Restarting manually "saslauthd" daemon temporarly solves the problem.

    NB! All the stuff is in the same machine, i mean mailserver - Default Univention OXAE installation.


    Problem 2.

    Is the spamfilter working by default or it is nessecary to change config files manually - tons of spam getting through, no matter marking the spam

    Problem 3.
    3 months ago we bought OXAE and still no solution for the character problem.


    Best regards

    Aleksander

  2. #2
    Join Date
    Mar 2009
    Location
    Austria
    Posts
    139

    Default

    Hi,

    I think I had the same problem! Did you try this solution:

    Concern:

    When working in the Groupware-GUI sometimes accessing the mailbox fails with the error message:

    "Connection was refused or timed out while attempting to connect to remote server for user tester@example.com"

    The following error is shown in /var/log/mail.log

    Mar 20 12:00:33 mail cyrus/imap[5231]: badlogin: example.com
    [192.168.178.5] plaintext tester@example.com SASL(-13): authentication failure: checkpass failed

    Reason:

    This is a known missbehaviour of the saslauthd service. To workaround the issue the following options must be used
    in the /etc/default/saslauthd config file:

    OPTIONS="-n 0 /etc/default/saslauthd"

    Afterwards the saslauthd service must be restared with:

    /etc/init.d/saslauthd restart

    * OS Component
    * OXAE
    * Workaround

    foudn here: http://sdb.open-xchange.com/node/198

  3. #3
    Aleksander Kikkas Guest

    Default Thanks,

    allready found the solution.

    Aleksander

  4. #4
    Join Date
    Mar 2009
    Location
    Austria
    Posts
    139

    Default

    so, what was it?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •