Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 3 of 3
  1. #1
    genius777 Guest

    Default Installation on SUSE 11.0 / Database Problems

    Hello @ll,

    I got a problem when setting up ox. I checked /opt/open-xchange/etc/groupware/configdb.properties and /opt/open-xchange/etc/admindaemon/configdb.properties but the login data for the database is set properly. For some reason the createcontext script doesn't use the database 'configdb' but 'configdb_#' instead.. (I also tried with other database names but it's the same, trying to access databasename_1, databasename_2 then..)

    Anyone got a clue what might cause this error? Does the createcontext script access the database in another way than the other scripts do?

    THANKS IN ADVANCE for any hint!

    Code:
    myHostName:~ # /opt/open-xchange/sbin/oxinstaller --servername=oxserver --configdb-pass=DB_PASSWORD --configdb-user=openexchange --master-pass=admin_master_password
    setting up groupware configuration /opt/open-xchange/etc/groupware
    ..................................................
    groupware daemon must now be restarted if already running
    setting up admin daemon configuration /opt/open-xchange/etc/admindaemon
    ......................
    *** RMI authentication is enabled
    using oxadminmaster as master account
    admin daemon must now be restarted if already running
    myHostName:~ # /etc/init.d/open-xchange-admin restart
    Shutting down open-xchange-admin daemon                               done
    Starting open-xchange-admin daemon                                    done
    myHostName:~ # /opt/open-xchange/sbin/registerserver -n oxserver -A oxadminmaster -P admin_master_password
    server 2 registered
    myHostName:~ # /opt/open-xchange/sbin/registerfilestore -A oxadminmaster -P admin_master_password -t file:///var/opt/filestore
    filestore 3 registered
    myHostName:~ # /opt/open-xchange/sbin/registerdatabase -A oxadminmaster -P admin_master_password -n configdb -p DB_PASSWORD -m true 
    database 4 registered
    myHostName:~ # /opt/open-xchange/sbin/createcontext -A oxadminmaster -P admin_master_password -c 1 \
    > -u oxadmin -d "Context Admin" -g Admin -s User -p admin_password -L defaultcontext \
    > -e my@email.com -q 1024 --access-combination-name=all
    context 1 could not be created: 
    Server response:
     java.sql.BatchUpdateException: Access denied for user 'openexchange'@'localhost' to database 'configdb_6'
    myHostName:~ # /opt/open-xchange/sbin/createcontext -A oxadminmaster -P admin_master_password -c 1 -u oxadmin -d "Context Admin" -g Admin -s User -p admin_password -L defaultcontext -e my@email.com -q 1024 --access-combination-name=all
    context 1 could not be created: 
    Server response:
     java.sql.BatchUpdateException: Access denied for user 'openexchange'@'localhost' to database 'configdb_7'
    myHostName:~ #
    and so on... the number keeps incrementing (why?)

    EDIT: I also added in mysql
    Code:
     GRANT ALL PRIVILEGES ON `configdb`.* TO 'openexchange'@'localhost' WITH GRANT OPTION
    to be sure there are sufficient rights.. but it didn't help...
    Last edited by genius777; 06-17-2009 at 04:34 PM.

  2. #2
    genius777 Guest

    Default

    sorry for opening this thread... I just had to give more privileges to openexchange mysql user

    Code:
    GRANT ALL PRIVILEGES ON *.* TO 'openexchange'@'localhost' IDENTIFIED BY PASSWORD '*9CF8CC5E681E7769530622A5A175C3070E657058' WITH GRANT OPTION
    I just hope I may revoke them later again...

  3. #3
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    sure you can change MySQL user permissions every time.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •