Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 6 of 6
  1. #1
    jonny12 Guest

    Default Imap Login Probleme

    Hallo,
    zusammen.

    OX : 6.10.0 Rev6
    Suse 11.1

    Hab alles nach Anweisung installiert. Passwordmech auf Crypt umgestellt und authentifiziere IMAP mittels pam_mysql und der ox-Database. Ein Login mittels E-Mail Klient geht, aber wenn ich mich an der GUI anmelden möchte kommt folgender Fehler:

    Aug 9 12:45:19 stone imap[1422]: badlogin: localhost [127.0.0.1] PLAIN [SASL(-13): authentication failure: cross-realm login tschneider@defaultcontext denied]


    Woher kommt das "@defaultcontext

    Danke
    Gruß
    Thomas

  2. #2
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi,

    this happens if the values in mail.properties are changed, especially the loginSource parameter. Please check if this value is "login". Also check that the users --imaplogin is only his username. When logging in to the UI, you just need to enter the username, no @defaultcontext.

    Greetings

  3. #3
    jonny12 Guest

    Default

    Hello,

    loginSource=login and the imaplogin is the only the username .
    Also I only use the username to login in the gui.

    ???
    Thx

  4. #4
    jonny12 Guest

    Default

    After a restart, I can login to the Gui but if i want to check email
    it says that the server is down, and it is disabled.

    In the log I see the login request. What is strange, that it isn't using pam_mysql as configured in /etc/pam.d/imap+smtp. It seems that it's using
    normal system login:

    Aug 9 14:56:02 stone saslauthd[3404]: DEBUG: auth_pam: pam_authenticate failed: User not known to the underlying authentication module
    Aug 9 14:56:02 stone saslauthd[3404]: do_auth : auth failure: [user=msteinberg] [service=sieve] [realm=] [mech=pam] [reason=PAM auth error]
    Aug 9 14:56:02 stone sieve[8505]: badlogin: localhost[127.0.0.1] PLAIN authentication failure

    ?
    Thx
    Regards
    Thomas Schneider

  5. #5
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    3,695

    Default

    Hi Thomas,

    well, this seems like a configuration problem of the IMAP server to me. Open-Xchange Server just performs a login through port 143, everthing beyond is handled by the configured authentication method of IMAP. You could ngrep the login procedure to see what data is used for the LOGIN command.

    Greetings

  6. #6
    jonny12 Guest

    Default

    Hi,
    but If I use a email-client (outlook) it can login using pam_mysql and it also uses the port 143.

    ???

    Thx

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •