Homepage | Products | OX Knowledge Base | Support | Try Now | Contact | Company
OX Logo
Results 1 to 3 of 3
  1. #1
    sami Guest

    Default Problem with Wiki on Ubuntu 8.04 installation

    I am unable to complete the step below, covered in the Wiki on Ubuntu 8.04 at...

    http://www.open-xchange.com/wiki/ind...ion_Ubuntu8.04

    The Wiki doesn't mention using sudo and the command fails and indicates I must be root..

    me@ubuntumail:~$ /opt/open-xchange/sbin/initconfigdb --configdb-pass=db_password -a
    need to be root in order to setup the system

    ... then I run it as root and get a different message...

    me@ubuntumail:~$ sudo /opt/open-xchange/sbin/initconfigdb --configdb-pass=db_password -a
    initializing configdb from scratch...ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
    ERROR
    \

    Can anyone help me on this please? Thanks.

  2. #2
    Join Date
    Jul 2009
    Posts
    20

    Default

    hi,

    your problem is such that you are not allowed to connect to your mysql database without a password.

    Simple solution, go to your mysql server, empty your root password, reload, do the initconfigdb thing, go to mysql server and set your password for root, reload mysql.

    Im not sure what initconfigdb is doing exactly, but there are more options.

    root@ox:~# initconfigdb

    /opt/open-xchange/sbin/initconfigdb currently knows the following parameters:

    Parameter | Default value
    ------------------------------------------------------------
    --configdb-user | openexchange
    --configdb-pass |
    --configdb-host | localhost
    --configdb-port | 3306
    --configdb-dbname | configdb

    So another and probably the better solution is to go to your mysql Server, add an user with name openexchange and a password. Allow him to create Database as he needs it , reload your mysql.

    Then use initconfigdb --configdb-user openexchange --configdb-pass yourpassword

    Your problem is your mysql server and it looks like you don't know what you are doing.
    If you have no idea what I'm talking about, please read some mysql documentation, how to setup users, password, databases and grant rights.

    regards

  3. #3
    sami Guest

    Default

    Quote Originally Posted by evildead View Post
    your problem is such that you are not allowed to connect to your mysql database without a password.
    Thanks, but when I installed mySQL (as part of the installation in the Wiki), I chose a password of db_password.

    And then, on this command that's failing, isn't this the switch that specifies the matching password...

    --configdb-pass=db_password


    I accept I'm going wrong somewhere however, because the command's coming back with 'no password'.

    Also, with regard to your point about me not knowing what I'm doing, sure I am new to using this software, but I am following the Wiki exactly.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •